[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

Hello community,

Another stable branch update with some usual package updates we collected thru the month of March for you. You can also published Stable Install Medias including this update.


Don’t miss out on our Easter Sale of Manjaro Merch!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Most of our Kernels got updated
    • Note: 6.0 kernel series got removed. Consider to either update to 6.1 LTS or 6.2 series.
  • Grub got updated to a newer git-master snapshot
    • this may create issues if you have your disk encrypted with luks and may lead to an error: no such cryptodisk found issue. See Known issues and solutions section and follow the discussion about it. Also you may want to read my personal take on that matter …
  • Systemd got updated to 252.8
  • GNOME 43.5 includes a lot of fixes and polish
  • Some updates to Deepin packages
  • NVIDIA driver got updated to 530.41.03
    • Note that there is now compatibility for Linux kernels with Indirect Branch Tracking (IBT). The ibt=off kernel parameter is no longer required. However, it may still be necessary for some systems using VirtualBox. See this post for more info
    • The NVIDIA X Server Settings has been split out of nvidia-utils into it’s own nvidia-settings package now built from source. It is now an optional dependency of nvidia-utils and will need to be installed manually if desired after the update.
  • Firefox is at 111.0.1
  • Thunderbird is at 102.9.1
  • Coding language Gambas is now at 3.18.1
  • KDE Frameworks got renewed to 5.104.0
  • Plasma got its third point-release for 5.27 series
  • KDE Gear 22.12.3 mostly gained fixes for ark, kate and kdenlive
  • Deepin added some smaller updates and fixes to their packages
  • Mauikit 2.2.2 got released
  • Libreoffice 7.5.1 added major improvements to their dark mode and with 7.4.6 more issues got solved in the stable release series
  • Steam Client got updated to
  • KODI 20.1 and its plugins got updated
  • Pamac 10.5.0 adds the update on shutdown option and 10.9.0 is our 2nd try to port everything to GTK4. You can install it via pamac-gtk-dev
  • Phosh got updated to 0.25.1. Also other parts of this mobile friendly UI got renewed.
  • Wine got renewed to 8.4
  • Mesa 23.0.1 with many Changes for Open-Source Radeon & Intel Graphics Drivers
  • Usual KDE-git, Python and Haskell updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.279
  • linux54 5.4.238
  • linux510 5.10.176
  • linux515 5.15.104
  • linux61 6.1.21
  • linux62 6.2.8
  • linux63 6.3-rc3
  • linux515-rt 5.15.94_rt59
  • linux60-rt 6.0.5_rt14

Package Changes (Tue Mar 28 08:51:23 CEST 2023)

  • stable community x86_64: 3101 new and 3010 removed package(s)
  • stable core x86_64: 106 new and 105 removed package(s)
  • stable extra x86_64: 1570 new and 1661 removed package(s)
  • stable kde-unstable x86_64: 416 new and 417 removed package(s)
  • stable multilib x86_64: 94 new and 96 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-03-31

GRUB: some backwards hardware compatibility has been restored

A modification has been reverted in order to restore support to old motherboards: [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #51 by philm

GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Check for modifications to /etc/default/grub
    Most notably, if you use LUKS with full disk encryption, you may need to:
    • check that GRUB_ENABLE_CRYPTODISK=y is not commented out
  • Don’t use tools like grub-customizer as it may create issues with the grub.cfg file.
  • Check if the UUID of your encrypted drive matches in your config files.
  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators.
  • If you modified the above configuration, you then need to update the grub menu with sudo update-grub.
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key.

You may still want to have a liveUSB ready, in the rare case your bootloader does break, in which case you will need to reinstall grub.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. 217174 – Plugging in usb external drive, mount and umount causes kernel Oops Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


Just ran into one issue with Plasma. Upon reboot a blank panel containing only a separator and a task manager (no start button or icons) got placed over top of my panel, only on my primary display. Secondary display panel was fine.

If anyone else sees this the solution is to go into panel edit mode and delete the almost blank panel, your panel is safe just underneath.

Not sure if this is Plasma 5.27 or Manjaro’s customization of Plasma that got overzealous and tried to re-create a default panel when one already existed.

That being said, thanks for all the hard work on this big update Manjaro team!

P.S. Looks like I’m also starting to see some occasional black flickering with the latest Nvidia drivers. Will need to wait on the wiki post and search around to see if this has already been noted by others when I have more time.

1 Like

You can always help to test our install medias. Currently I’m working on creating 22.1.0-rc1 Talos and may share the download links to those who are interested …

Plasma is known that migration scripts not always work when your system is customized. I’m sure you will find a solution to your problem here in our forums!

1 Like

2 posts were split to a new topic: Can’t boot LUKS encrypted install after 2023-03-31 stable update

My issue was on KDE plasma. I needed to install xsettingsd in order for GTK HiDPI scaling to work.

Resolving dependencies...
Choose a provider for libXNVCtrl.so=0-64:
1:  libxnvctrl        525.89.02-1  extra
2:  libxnvctrl-390xx  390.157-1    extra

Enter a number (default=1): 1

Checking inter-conflicts...
Warning: removing 'libxnvctrl' from target list because it conflicts with 'libxnvctrl-470xx'
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libXNVCtrl.so=0-64' required by conky

Since option (1) is default and I’m on 470xxxNvidia I didn’t want to chose 2 but it looks like I’ll either have to or remove conky. What’s the save way forward?

@Yochanan seems there is still some funky with your nvidia-settings splitout. 470xx issue are now more often posted … @6x12 maybe test this: [pkg-upd] 470.182.03-2 (2900050c) · Commits · Packages / Extra / nvidia-470xx-settings · GitLab

KDE Plasma bug - all customizing for 2nd Monitor got lost…

Controll-Panel, Wallpaper, etc. Just resolution and ratio are kept :frowning:

1 Like

There were a lot of changes made to multi monitor support with Plasma 5.27 LTS. Maybe you did customization and settings upstream didn’t expect. Migration scripts not always catch user changes and either reset or remove things to be able to have a functional desktop.


Mine is :100: after said update. No problems or anything.

1 Like

My panel under KDE Plasma disappeared entirely after the update and reboot.

Edit: Nevermind it was on different not connected display. Found it in the panel edit mode like @belyash mentioned.


I got the following warnings, if I continue to update, boot hangs and timeshift restore is needed

:: installing nvidia-utils (530.41.03-4) breaks dependency 'nvidia-utils=525.89.02' required by lib32-nvidia-utils
:: installing nvidia-utils (530.41.03-4) breaks dependency 'nvidia-utils=525.89.02' required by linux515-nvidia
:: installing nvidia-utils (530.41.03-4) breaks dependency 'nvidia-utils=525.89.02' required by linux60-nvidia

I’m facing an issue with dnscrypt-proxy:

[Stable Update] 2023-03-31: DNSCrypt-proxy service no longer works (but dnscrypt itself works)

The service file stops with an error, but if I manually execute dnscrypt-proxy, it works.


Well, it depends which kernel you are running. 6.0 for example got dropped. You may want to first install a newer kernel. Those nvidia-utils warnings might indicate that.

error: no such cryptodisk found , perhaps a needed disk or cryptodisk module is not loaded.
Press any key to continue …”

1 Like

Re-installing grub should fix that. A similar issue was already posted in the testing threads: GRUB/Restore the GRUB Bootloader - Manjaro Also some discussion started here regarding luks encrypted installs: Can't boot LUKS encrypted install after 2023-03-31 stable update

After update to stable Manjaro Gnome I see following message after I enter the encryption password.

error: no such cryptodisk found. perhaps a needed disk or cryptodisk module is not loaded.

Press any key to continue …

Laptop boot-up OK automatically afterwards. Any suggestion?

Minor issues - 2nd monitor panel was incorrect so recreated it. Also a shortcut for Darktable on the Task Manager was not found so recreated it. Everything else perfect so far - slight delay on first boot but to be expected.

1 Like

Interesting first bug - many conkies have just turned RED.

I fixed one - instead of color #666, now we must put #666666

1 Like