Wifi Card not showing up in system after rebooting cant activate special wifi on touch button on laptop

Hello, first off all excuse some wrongdoings i will have while explaining my problem, im using Linux and Manjaro for the first time in my life and im just 2 weeks in the expirience.

My problem is that after i “hard shut downed” my laptop with holding the start key for some seconds and starting him again later that day my wifi where not showing anymore.
I’ve read some troubleshootings and tried finding the card in my system but it seems like the system is not knowing anymore that the card is inside (the ethernet is showing up and working, ive build a workaround with a smartphone on usb tehtering to gain access because im in a hospital and have only wifi access).
Maybe its also a problem with the special touch key (the things over the laptop keyboards) which normally would light up when touched and activate the whole wifi card thingy. some of the other keys work like activating bluetooth but wifi is not, also using the Fn key to activate it like that also doesent work (while making the screen brighter or change sound loudness works)

i wanted to post my inxi -Fazy output but it tells me i cant post links… hmm…

Edit: somehow the touch button for the wifi worked now again and lighted up and even the fn key worked again but still no wifi aviable in the network center , just again phone via usb tethering

You can’t post links as a new member - has to do with trust levels in the forum software.
However, there normally is no link in the output of that command.

Try properly formatting it as preformatted text
this button in the top row of the window you type in : </>

or see this:

[HowTo] Post screenshots and links

  Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=f79f43d2-f04a-4237-b8f6-6aa3102904b9 rw rootflags=subvol=@ quiet
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GT680R/GX680R/GT683R v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-16F2 serial: <superuser required>
    BIOS: American Megatrends v: E16F2IMS V3.0D date: 03/03/2011
  ID-1: BAT1 charge: 32.6 Wh (97.9%) condition: 33.3/86.6 Wh (38.4%)
    volts: 12.4 min: 11.1 model: MS-16F2 type: Unknown serial: N/A status: N/A
  Info: model: Intel Core i5-2410M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2617 high: 2667 min/max: 800/2900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2667 2: 2582 3: 2646
    4: 2574 bogomips: 18364
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF106M [GeForce GT 555M] vendor: Micro-Star MSI
    driver: nvidia v: 390.157 alternate: nouveau,nvidia_drm non-free:
    series: 390.xx+ status: legacy-active (EOL~late 2022) arch: Fermi
    code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0dcd class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: N/A
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 143 s-size: 341x191mm (13.43x7.52")
    s-diag: 391mm (15.39")
  Monitor-1: LVDS-0 res: 1920x1080 hz: 60 dpi: 142
    size: 344x193mm (13.54x7.6") diag: 394mm (15.53") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 390.157 renderer: GeForce GT 555M/PCIe/SSE2
    direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0be9 class-ID: 0403
  Sound API: ALSA v: k5.15.85-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8168 v: 8.050.03-NAPI modules: r8169 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0083 class-ID: 0280
  IF-ID-1: enp0s26u1u5 state: unknown speed: -1 duplex: half mac: <filter>
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f020 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 232.89 GiB used: 67.81 GiB (29.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: MBR
  ID-1: / raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
    used: 67.81 GiB (29.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
    used: 67.81 GiB (29.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
    used: 67.81 GiB (29.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 52 C
  Fan Speeds (RPM): N/A
  Processes: 230 Uptime: 4m wakeups: 1 Memory: 7.74 GiB used: 1.98 GiB (25.5%)
  Init: systemd v: 252 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1355 libs: 377
  tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.24

and this is the output of lshw -C network

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 06
       serial: 6c:62:6d:31:9a:f8
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.050.03-NAPI latency=0 link=no multicast=yes port=twisted pair
       resources: irq:34 ioport:d000(size=256) memory:ec104000-ec104fff memory:ec100000-ec103fff
       description: Network controller
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:37 memory:ec000000-ec001fff
       description: Ethernet interface
       physical id: 6
       bus info: usb@1:1.5
       logical name: enp0s26u1u5
       serial: da:aa:e7:90:6a:8b
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.15.85-1-MANJARO duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair

HI @splox ,
Welcome to the forum, I can recommend you from other posts in the forum that the card is very old and does not have support on linux. Please, consider to buy an usb wifi adapter.
You could read them yourself in the links below:
Wifi Not working and no wifi network showing up

Wifi on but no networks show in list

Trouble with WiFi on laptop :intermittently turns off and must reboot; but now won't come on at all - #3 by j8a

Hope it help, regards

I tried the options which where used in the links but nothing helped…

Now also the touch wifi on/off button stopped his light and the system is again not even seeing the wifi card, even when i had a moment today where the button was working.

Does anyone know what happend there?
Cant try to run a wifi card which is deactivated by some internal funky laptop special buttons…

I have the same issue sometimes it worked and sometimes didnor worked