[Unstable Update] 2021-05-28 - Kernels, Perl, Cinnamon 5.0, Haskell, Tesseract, Cutefish

Hello community,

Another unstable branch update with some usual updates for you.


Find out more about the new Starbook by Starlabs!

  • Most of our Kernels got updated
  • There was a perl rebuild by upstream Arch
  • Cutefish DE got added
  • Cinnamon going to get updated to 5.0.0
  • Other regular upstream updates including python, tesseract and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux44 4.4.270
  • linux49 4.9.270
  • linux414 4.14.234
  • linux419 4.19.192
  • linux54 5.4.122
  • linux510 5.10.40
  • linux511 5.11.22
  • linux512 5.12.7
  • linux513 5.13-rc3
  • linux54-rt 5.4.115_rt57
  • linux59-rt 5.9.1_rt19
  • linux511-rt 5.11.4_rt11

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

7 Likes

This post was flagged by the community and is temporarily hidden.

1 Like

On Unstable:
Is it okay to replace?

:: Replace qca with extra/qca-qt5? [Y/n]

The package was split:
https://archlinux.org/packages/extra/x86_64/qca/

1 Like

I’m not a fan of the new firefox 89 update. I’m getting moderately worse performance on dual monitors and I normally like to watch youtube videos on 1.75x speed on one monitor and do normal items on the second and the performance hit is really noticeable compared to before. I’ll change the performance settings in firefox for now manually to see if that helps but I’ll be looking for an nvidia update or something soon… :neutral_face:

It’s been awhile playing with firejail, but I suggest for those of you combining it with media players and setting the net none flag, go ahead and do some testing on your end to see if streaming-media files are properly “failing.” I accidentally saved an html element as a “video file” and vlc+firejail choked on it to the point of needing to drop to TTY and then gracefully rebooting. For now I’m sticking to the LTS kernel until we get another nvidia/mesa update.

I also cleaned up some orphans today: # pacman -Rns lib32-dconf lib32-libgudev lib32-libgusb lib32-polkit Thanks all.

Maybe it is time to try out Vivaldi

1 Like

A post was split to a new topic: Issues after updating to Cinnamon 5.0.0

A report on today’s update:

:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
warning: manjaro-release: local (21.0.5-1) is newer than core (21.0.4-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

Also, pacman 6 is still not available in the unstable branch.

1 Like

Remove libcanberra-gstreamer & lib32-libcanberra-gstreamer first.

EDIT:

lib32-libcanberra-gstreamer and libcanberra-gstreamer are no longer in the repos

FS#71144 - [libcanberra] Broken dependency since 0.30+2+gc0620e4-4

5 Likes

Brave is my friend for now. Vivaldi is bloated kind off

Dependency resolution failed for libcanberra -

Any ideas?

screenshot: h t t p s ://i.postimg.cc/7ZFBPqCH/Screenshot-20210606-132606.png

Always check Announcement posts and their comments before posting.

See my post above:

got it. thank you

Any Safe way to resolve this

error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-1) breaks dependency 'pacman<5.3' required by pamac-common

EDIT 1:
Issue Resolved

1 Like

Yep, I’m getting the same thing:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-1) breaks dependency ‘pacman<5.3’ required by pamac-common

Now that the new pacman got imported, I guess the new pamac with libalpm13 support is almost ready…

2 Likes

Issue Resolved!!

How did you resolve it? Still does not work for me.

//Edit: mirror refresh worked