[Testing Update] 2023-09-11 - Kernels, Systemd 254.3, Mesa 23.1.7, Phosh, Phoc, LibreOffice

Hello community,

Another testing branch update with some usual package updates for you.

Get the lastest SoftMaker Office with ChatGPT buillt-in. You will find our Special Offer here!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Some Kernels got updated
    • 6.4 and 6.5 kernel series now support several new ASUS laptops and gaming handhelds including Cirrus AMP support
  • Systemd is now at 254.3
  • Mesa got renewed to 23.1.7 which includes fixes for AMD 780m GPUs
  • Phosh and Phoc are now part of upstream packages
  • LibreOffice-Still got updated to 7.5.6
  • Usual KDE-git, Haskell, Perl and Python updates

Additional Info

Python 3.11 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.294
  • linux54 5.4.256
  • linux510 5.10.194
  • linux515 5.15.131
  • linux61 6.1.52
  • linux64 6.4.15
  • linux65 6.5.2
  • linux61-rt 6.1.46_rt13
  • linux64-rt 6.4.6_rt8
  • linux65-rt 6.5_rt6

Package Changes (Mon Sep 11 10:20:58 CEST 2023)

  • testing core x86_64: 14 new and 14 removed package(s)
  • testing extra x86_64: 866 new and 863 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)

Overlay Changes

  • testing core x86_64: 17 new and 17 removed package(s)
  • testing multilib x86_64: 12 new and 12 removed package(s)
  • testing kde-unstable x86_64: 149 new and 147 removed package(s)
  • testing extra x86_64: 88 new and 90 removed package(s)

A list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-09-06

filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.


ansible-core >= 2.15.3-1 update may require manual intervention

2023-08-19 - Robin Candau

As of ansible-core 2.15.3, upstream moved documentation and examples to a separate dedicated repository (see the related changelogs).
This means that, starting from version 2.15.3 the ansible-core package will stop shipping documentation and a default configuration example under /etc/ansible/ansible.cfg.

Regarding the documentation, it is available online: https://docs.ansible.com/
As for the configuration file, as explained in the wiki, a base config can be generated with the following command:

ansible-config init --disabled > ansible.cfg

After updating from ansible-core <= 2.15.2-1 to >= 2.15.3-1, everyone using a custom global Ansible configuration file stored under /etc/ansible/ansible.cfg will have their configuration saved as a pacsave file.
To restore it, run the following command:

mv /etc/ansible/ansible.cfg.pacsave /etc/ansible/ansible.cfg

Arch Linux - News: ansible-core >= 2.15.3-1 update may require manual intervention


Possible glibc 2.38 posix_memalign regression

There seems a performance regression of posix_memalign in Glibc-2.38. More info here: 30723 – Poor posix_memalign performance with long free lists


You can try another malloc like mimalloc or jemalloc as workaround. Install mimalloc and start mpv with:

LD_PRELOAD=/usr/lib/libmimalloc.so mpv


LD_PRELOAD=/usr/lib/libjemalloc.so mpv

For folks that dont want to change things too much … an apparent workaround is to set a lowish cache size:

mkdir -p ~/.config/mpv && printf '\ndemuxer-max-bytes=50MiB\ndemuxer-max-back-bytes=25MiB\n' | tee -a ~/.config/mpv/mpv.conf
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu


Grub conflicting files

Error: Failed to commit transaction:
conflicting files:
grub: /usr/bin/update-grub already exists in filesystem (owned by grub-update)

sudo pacman -Rdd grub-update
sudo pacman -Suu grub

[1] [2] [3]


One core of CPU has high IO-wait operation at 100%

[Unstable Update] 2023-05-21 - Repository changes - #199 by Zesko

Kernel 6.4.4, 6.4.5 and 6.1.39 LTS are affected:
The known issue and report:


Steam crashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


possible kernel bug for amdgpu users

[Testing Update] 2023-06-27 - Kernels, Linux-Firmware, Mesa, Wine, Nvidia, KDE-git - #4 by xvin


Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

pamac install pamac-gtk3
TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization


The "community" repository has been merged into "extra" and is now empty

The [community] repository has been merged into [extra] and is now empty. It may take a bit of time for mirrors to catch up.

:point_right: Update your system and merge the pacman pacnew /etc/pacman.conf.pacnew file.

sudo pacman -Syu "pacman>=6.0.2-11"
OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

Previous testing threads:


rtl8168 not working anymore after this update:

# modprobe r8168
modprobe: ERROR: could not insert 'r8168': Exec format error

Using r8168-dkms from the AUR works.

1 Like

The same happened to me. Same workaround used.

Can also confirm that r8168 has stopped working; and instead the dkms version is in work for now…

Both linux515-r8168 and linux61-r8168 (8.051.02-1) packages fail to load r8168 driver

Loading r8169 driver got NIC working again

sudo modprobe r8169


mhwd -r pci network-r8168


1 Like

I have used and recommending mhwd r8168 driver with r8169 blacklisted for many years without issues
(Oct 20) Network-8168 and network 8169 works really bad with my computer

When I noticed your comment suggesting that r8169 driver has been in use this whole time
I checked modinfo to confirm r8168 driver was still in use and r8169 still blacklisted

Well, you already had r8169 blacklisted manually so nothing changed. :wink:

From what I recall, installing 8168 from MHWD would blacklist 8169 so I’m not sure what you’re talking about when you say it was the other way around.

//EDIT: I don’t understand your post actually, you say two conflicting thing to me:

With 8.051.02-1, the r8169 kernel driver is blacklisted by default as they conflict.

Remove linuxXXX-r8168, reboot and the r8169 kernel driver will be used instead. Apparently it’s been in use this whole time and you weren’t actually using r8168 at all.

You say now 8169 is blacklisted by default (so it wouldn’t change anything for people using 8168 as it should already be blacklisted, right?), and you say if you reboot after removing 8168, it will use 8169, and then you say that people were not using 8168 anyway.

I’m confused.

Whatever, I don’t use 8168 since long now.

1 Like

solved with 6.5.2 → no more amd_gpio param 0014

i have theses errors

avertissement : les permissions pour le répertoire /etc/credstore/ sont différentes
système de fichiers : 0, paquet : 700
avertissement : les permissions pour le répertoire /etc/credstore.encrypted/ sont différentes
système de fichiers : 0, paquet : 700

sept. 11 18:43:20 systemd-journald[323]: Time spent on flushing to /var/log/journal/e1d2ad259a0c4b3494932a11ddd42221 is 6.072ms for 1126 entries.
sept. 11 18:43:20 systemd-journald[323]: [🡕] System Journal (/var/log/journal/e1d2ad259a0c4b3494932a11ddd42221) is 424.2M, max 2.3G, 1.9G free.
sept. 11 18:43:20 systemd-journald[323]: Received client request to flush runtime journal.
sept. 11 18:43:20 systemd-journald[323]: File /var/log/journal/e1d2ad259a0c4b3494932a11ddd42221/system.journal corrupted or uncleanly shut down, renaming and replacing.

sept. 11 18:43:31 wireplumber[913]: Failed to get percentage from UPower: org.freedesktop.DBus.Error.NameHasNoOwner

boot on Kernel 6.5
by default ( acpi-cpufreq )
on boot options kernels
with amd-pstate=passive ( version v1 )
with amd-pstate=active ( version v2 with epp )

Not that I know of. I just checked the current MHWD code and there is no reference to either driver.

Previously, there was only a post-install message1. Now the module is blacklisted1 as it should be since r8168 & r8169 conflict.

Note that r8169 is an in-tree kernel module while r8168 is an out-of-tree kernel module provided by Realtek. The r8168 driver should only be used for devices not yet supported by r8169. If they’re both installed, only one will be loaded at boot depending on the chipset.2

I hope that cleared it up.

1 using linux61-r8168 as an example
2 r8168/r8169 - which one should I use?

Just install 8168 from MHWD, /etc/modprobe.d/r8169_blacklist.conf is created. Remove 8168, /etc/modprobe.d/r8169_blacklist.conf is removed.

1 Like

Ah, I forgot to look at mhwd-db. :man_facepalming: Indeed, it is.

Well, then the issue people are having may not related to blacklisting, after all.

Either way, r8168 was updated from 8.050.03 to 8.051.02, so maybe something related there.

For sure to me, people with 8168 installed from MHWD would not have issue with the blacklisting of 8169, because this is how it already is/was.

1 Like

I reinstalled network-r8168 to document and verify driver failure

sudo mhwd -i pci network-r8168
[sudo] password for nik: 
> Installing network-r8168...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/network_drivers/r8168/MHWDCONFIG
Processing classid: 0200
:: Synchronising package databases...
 core downloading...
 extra downloading...
 multilib downloading...
resolving dependencies...
looking for conflicting packages...

Packages (2) linux515-r8168-8.051.02-1  linux61-r8168-8.051.02-1

Total Installed Size:  0.11 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing linux515-r8168...
installing linux61-r8168...
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating module dependencies...
linux515-r8168: install reason has been set to 'explicitly installed'
linux61-r8168: install reason has been set to 'explicitly installed'
modprobe: ERROR: could not insert 'r8168': Exec format error
> Successfully installed network-r8168
inxi -Na; sudo modprobe r8168
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: N/A modules: r8169, r8168 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d800 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
modprobe: ERROR: could not insert 'r8168': Exec format error
sudo modprobe r8169; inxi -Na
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel modules: r8168 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d800 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200

mhwd install automatically created /etc/modprobe.d/r8169_blacklist.conf

Forum search suggests manual creation of r8169 blacklist is needed for r8168-dkms
so I removed r8168 drivers using pamac instead of mhwd, to retain the blacklist
pamac remove linux515-r8168 linux61-r8168
Installed AUR driver - pamac build r8168-dkms
and swapped the drivers around - sudo modprobe -r r8169; sudo modprobe r8168

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8168 v: 8.051.02-NAPI modules: r8169

Removing 8168 does not bring 8169 back, as it does modprobe -r 8169 in post remove.

	if [ -e "${MODULESBLACKLIST}" ]; then

	modprobe -r r8169

Ah, good catch. Something like this then?

diff --git a/pci/network_drivers/r8168/MHWDCONFIG b/pci/network_drivers/r8168/MHWDCONFIG
index 9b32329..86307d6 100644
--- a/pci/network_drivers/r8168/MHWDCONFIG
+++ b/pci/network_drivers/r8168/MHWDCONFIG
@@ -32,5 +32,6 @@ post_remove()
                rm "${MODULESBLACKLIST}"
-   modprobe -r r8169
+ modprobe -r r8168
+ modprobe r8169
1 Like