[Stable Update] 2023-09-10 - Kernels, Systemd, Firefox, Thunderbird, LLVM

Hello community,

Another stable branch update with some usual package updates for you.

Get the lastest SoftMaker Office with ChatGPT buillt-in. You will find our Special Offer here!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Most Kernels got updated
  • Firefox is at 117.0 and Thunderbird at 115.2.0
  • Rebuilds for llvm 16.0.6
  • Mauikit 3.0.1 got released
  • Qemu is now at 8.1.0
  • PipeWire got updated to 0.3.79
  • Systemd got renewed to 253.10
  • Usual KDE-git, Haskell, Perl and Python updates

Additional Info

Python 3.11 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.294
  • linux54 5.4.256
  • linux510 5.10.194
  • linux515 5.15.130
  • linux61 6.1.51
  • linux64 6.4.14
  • linux65 6.5.1
  • linux61-rt 6.1.46_rt13
  • linux64-rt 6.4.6_rt8
  • linux65-rt 6.5_rt6

Package Changes (Wed Sep 6 07:47:27 CEST 2023)

  • stable core x86_64: 42 new and 40 removed package(s)
  • stable extra x86_64: 2157 new and 2300 removed package(s)
  • stable kde-unstable x86_64: 261 new and 261 removed package(s)
  • stable multilib x86_64: 33 new and 34 removed package(s)

A list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-09-10

LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.


All initramfs builds fail with ERROR: Hook ‘zfs’ cannot be found

There was an issue with zfs-utils 2.1.11-1 package having the initcipio files wrongly installed. Please update to zfs-utils 2.1.11-1.1 and re-run mkinitcpio -P. If you have an already unbootable system, you may recover by using an install media and chroot into it to complete the update.


xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11

A bug report was opened on 468217 – xf86-input-libinput 1.3.0 DPI and mouse acceleration issue on KDE Plasma X11 and a temporary fis is also mentioned on Mouse acceleration - ArchWiki

Widgets on Plasma desktop are lost after update


GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators. You have to redo that whenever you update a kernel or call update-grub on your own. You can read more about it here
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key. This happens if you forgot to remove the dashes in /boot/grub/grub.cfg after update-grub got called.

We may add a alpm-hook to grub package to do that monkey job for you automatically. As an alternative you may reinstall grub, as the newer version can handle both cases, including the dashes.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. 217174 – Plugging in usb external drive, mount and umount causes kernel Oops Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


My only surprise was that 2 updates turned out to be over 150 updates, everything is fine though.

1 Like

Waiting for the singapore repo to sync

Small glitch with w utility from Arch package procps-ng, probably is linked against newer systemd 254:

$ pacman -Qo /usr/bin/w
/usr/bin/w is owned by procps-ng 4.0.4-1
$ ldd /usr/bin/w
/usr/bin/w: /usr/lib/libsystemd.so.0: version `LIBSYSTEMD_254' not found (required by /usr/bin/w)
	linux-vdso.so.1 (0x00007ffcd61d9000)

KDE is now broken. A few seconds after login the plasma wayland session crashes, killing all apps. Plasma restarts in a diminished mode, showing a Plasma Renderer icon in the system tray. Clicking on it a window opens with non-antialiased text asking which renderer to use for qtquick. From that moment on the wayland session keeps crashing periodically.

in dmesg:

mdgpu 0000:03:00.0: amdgpu: ring gfx_0.0.0 uses VM inv eng 0 on hub 0
[  243.010903] amdgpu 0000:03:00.0: amdgpu: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[  243.010904] amdgpu 0000:03:00.0: amdgpu: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[  243.010905] amdgpu 0000:03:00.0: amdgpu: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[  243.010906] amdgpu 0000:03:00.0: amdgpu: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[  243.010907] amdgpu 0000:03:00.0: amdgpu: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[  243.010908] amdgpu 0000:03:00.0: amdgpu: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[  243.010910] amdgpu 0000:03:00.0: amdgpu: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[  243.010911] amdgpu 0000:03:00.0: amdgpu: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[  243.010912] amdgpu 0000:03:00.0: amdgpu: ring kiq_0.2.1.0 uses VM inv eng 11 on hub 0
[  243.010913] amdgpu 0000:03:00.0: amdgpu: ring sdma0 uses VM inv eng 12 on hub 0
[  243.010914] amdgpu 0000:03:00.0: amdgpu: ring sdma1 uses VM inv eng 13 on hub 0
[  243.010915] amdgpu 0000:03:00.0: amdgpu: ring vcn_dec_0 uses VM inv eng 0 on hub 8
[  243.010916] amdgpu 0000:03:00.0: amdgpu: ring vcn_enc_0.0 uses VM inv eng 1 on hub 8
[  243.010918] amdgpu 0000:03:00.0: amdgpu: ring vcn_enc_0.1 uses VM inv eng 4 on hub 8
[  243.010919] amdgpu 0000:03:00.0: amdgpu: ring jpeg_dec uses VM inv eng 5 on hub 8
[  243.013735] amdgpu 0000:03:00.0: [drm] Cannot find any crtc or sizes
[  338.015858] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  338.015887] nvme 0000:06:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[  338.015893] nvme 0000:06:00.0:   device [15b7:5025] error status/mask=00000001/0000e000
[  338.015900] nvme 0000:06:00.0:    [ 0] RxErr                  (First)
[  340.014837] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  340.014942] nvme 0000:06:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[  340.014948] nvme 0000:06:00.0:   device [15b7:5025] error status/mask=00000001/0000e000
[  340.014954] nvme 0000:06:00.0:    [ 0] RxErr                  (First)
[  340.014966] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  355.514989] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  355.515088] nvme 0000:06:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[  355.515094] nvme 0000:06:00.0:   device [15b7:5025] error status/mask=00000001/0000e000
[  355.515101] nvme 0000:06:00.0:    [ 0] RxErr                  (First)
[  355.515117] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  362.515845] pcieport 0000:00:02.4: AER: Corrected error received: 0000:06:00.0
[  362.515866] nvme 0000:06:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[  362.515872] nvme 0000:06:00.0:   device [15b7:5025] error status/mask=00000001/0000e000
[  362.515878] nvme 0000:06:00.0:    [ 0] RxErr                  (First)

Addendum… most likely the issue was the packages in the nonfree.eu repo that I had enabled to get hardware video encoding.

1 Like

similar to mine. but the update-process crashed while updating. after downloading the installation started as usual but within it suddenly crashed the whole wayland-session. never had such a behaviour in any linux-updating.

Same for me.

Element not working anymore after update (Window Border is modified because privacy):

Fixed by removing config files and re-sign in

~$ rm -rf .config/Element

i can confirm that the same issue was fixed for me when i switched back to the regular mesa packages instead of the mesa-nonfree versions


After this update, keepass is not working, gives me Aborted (core dumped). I guess due to some update in mono.

UPD: Uninstalling and reinstalling the keepass package helped. Maybe it’s the same problem as in Arch " FS#78263 - [keepass] updating mono breaks keepass until its install file commands are run".

1 Like


For what it is worth, I did not have this issue with the fork of Keepass I use, called KeepassXC.

1 Like

I voted “no issue” as in the end nothing was broken and everything’s great after a restart. But I can confirm what others mentioned above: If you’re on the KDE Plasma Wayland session, your desktop will crash in the middle of the update closing all applications on you. As a precaution I reinstalled Grub and the Kernel just in case pacman also crashed before reconfiguring those, if you want to be on the extra safe side you can do that using this command for your kernel version:

sudo pacman -S linux65 grub efibootmgr os-prober 
1 Like

The update notifier shows you how many updates there are when it polls the mirror. It is not unusual for there to be (many) more updates once you start the update process if you do this before the update notifier’s next polling of the mirror.


The only safe way to apply major updates like this is to completely log out of the GUI, switch to a tty, log in there, and update the system from the command line, like so… :arrow_down:

sudo pacman -Syu && pamac update

This way…

  • only a bare minimum of shared libraries will be in use that are going to be overwritten by the update process; and…

  • you will be updating all your official repo packages first before everything else from the AUR, Snap, FlatPak and whatever else there is.


  • Always merge your .pacnew files.

  • If you want stability, don’t use Wayland as the display server for Plasma. Seriously, don’t, unless you’re willing to deal with breakage. Wayland is a work in progress and is still not production-ready when used with Plasma — it even still has issues underneath GNOME.

1 Like

This update broken my cinnamon installation. Window manager (muffin) refuses to launch, says clutter doesn’t have any backends available.

it’s a problem with llvm-libs. Downgraded it to previous version (15.x) and cinnamon is working again (amdgpu). I’m using mesa nonfree repo, so it may be caused by olded mesa version (still 23.1.5 there).

Now how do we get hardware acceleration on manjaro ?
There is some problem with chrome 116 as well, i wasnt able to get hw enabled before this update

I seem to be in the minority, but I always use pamac to update my system. The update went smoothly (I’m running KDE-Wayland on an AMD 6700 XT).


My GNOME Wayland session would not start anymore because of the nonfree.eu mesa package that I had to uninstall and by reverting mesa to extra via sudo pacman -Syuu in order to make my system usable again.

According to this thread from Arch forum, hardware acceleration is broken in chromium 116 by it’s developers.

If you want HW acceleration to work in browser use Firefox instead. Or earlier versions of chromium and chromium-based browsers

Archwiki article on HW accelereation. Some information there is outdated though.

  1. Download the package libva-mesa-driver-[VERSION]-x86_64.pkg.tar.zst for Intel or AMD GPU.

  2. Install :

$ sudo pacman -U libva-mesa-driver-[VERSION]-x86_64.pkg.tar.zst