[Stable Update] 2023-10-04 - Kernels, Systemd, LibreOffice, NVIDIA, Mesa, GNOME, AMDVLK

Hello community,

Another stable branch update with some usual package updates for you.

Get the lastest SoftMaker Office with ChatGPT buillt-in. You will find our Special Offer here!

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

Additional Info

Python 3.11 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.295
  • linux54 5.4.257
  • linux510 5.10.197
  • linux515 5.15.133
  • linux61 6.1.55
  • linux64 6.4.16 [EOL]
  • linux65 6.5.5
  • linux66 6.6.0rc3
  • linux61-rt 6.1.54_rt15
  • linux64-rt 6.4.6_rt8
  • linux65-rt 6.5.2_rt8

Package Changes (Sat Sep 30 03:36:30 CEST 2023)

  • stable core x86_64: 50 new and 51 removed package(s)
  • stable extra x86_64: 2564 new and 2682 removed package(s)
  • stable kde-unstable x86_64: 298 new and 260 removed package(s)
  • stable multilib x86_64: 49 new and 50 removed package(s)

A list of all changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-10-04

Changes to default password hashing algorithm and umask settings

2023-09-22 - David Runge

With shadow >= 4.14.0, Arch Linux’s default password hashing algorithm changed from SHA512 to yescrypt [1].

Furthermore, the umask [2] settings are now configured in /etc/login.defs instead of /etc/profile.

This should not require any manual intervention.

Reasons for Yescrypt

The password-based key derivation function (KDF) and password hashing scheme yescrypt has been chosen due to its adoption (readily available in libxcrypt, which is used by pam [3]) and its stronger resilience towards password cracking attempts over SHA512.

Although the winner of the Password Hashing Competition [4] has been argon2, this even more resilient algorithm is not yet available in libxcrypt [5][6].

Configuring yescrypt

The YESCRYPT_COST_FACTOR setting in /etc/login.defs is currently without effect, until pam implements reading its value [7]. If a YESCRYPT_COST_FACTOR higher (or lower) than the default (5) is needed, it can be set using the rounds option of the pam_unix [8] module (i.e. in /etc/pam.d/system-auth).

General list of changes

  • yescrypt is used as default password hashing algorithm, instead of SHA512
  • pam honors the chosen ENCRYPT_METHOD in /etc/login.defs and does not override the chosen method anymore
  • changes in the filesystem (>= 2023.09.18) and pambase (>= 20230918) packages ensure, that umask is set centrally in /etc/login.defs instead of /etc/profile

[1] yescrypt - scalable KDF and password hashing scheme

[2] umask(1p) — Arch manual pages

[3] PAM - ArchWiki

[4] https://www.password-hashing.net/

[5] [RFC] Add argon2 backend. by ferivoz · Pull Request #113 · besser82/libxcrypt · GitHub

[6] Add support for Argon2 by maandree · Pull Request #150 · besser82/libxcrypt · GitHub

[7] pam_unix: Support reading YESCRYPT_COST_FACTOR from /etc/login.defs · Issue #607 · linux-pam/linux-pam · GitHub

[8] pam_unix(8) — Arch manual pages

Arch Linux - News: Changes to default password hashing algorithm and umask settings


filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.

updates for linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module


LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam
Steam crashes at launch with libgudev 238 · Issue #9805 · ValveSoftware/steam-for-linux · GitHub

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.

Previous stable update threads:


Interrupted this update after looking at the list of packages that pamac update --no-aur displays:
apart from some reasonable updates of packages already in my system, there are 36 new packages that were about to be installed.
I tried to find out why - using pacman -Si <package>etc., but that gave me no clue at all.
Before continuing this update, can someone please explain why these packages shall be installed?
(current Manjaro system, “stable” release chain, Xfce Desktop, Intel CPU, no unusual HW/SW in my system)
Thx a lot :wink:

Wird installiert (36):
  onevpl                           2023.3.1-1                                   extra     958,5 KB
  libnvme                          1.5-1                                        extra     231,9 KB
  lib32-libxtst                    1.2.4-1                                      multilib  12,0 KB
  lib32-at-spi2-core               2.50.0-1                                     multilib  173,2 KB
  lib32-libjpeg-turbo              3.0.0-1                                      multilib  310,6 KB
  lib32-libtiff                    4.6.0-1                                      multilib  227,4 KB
  lib32-lcms2                      2.15-1                                       multilib  168,6 KB
  lib32-colord                     1.4.6-1                                      multilib  119,4 KB
  lib32-gdk-pixbuf2                2.42.10-2                                    multilib  128,3 KB
  lib32-libogg                     1.3.5-1                                      multilib  24,8 KB
  lib32-libvorbis                  1.3.7-1                                      multilib  184,3 KB
  lib32-libltdl                    2.4.7-3                                      multilib  19,1 KB
  lib32-alsa-lib                   1.2.10-2                                     multilib  409,0 KB
  lib32-libasyncns                 1:0.8+r3+g68cd5af-2                          multilib  11,4 KB
  lib32-opus                       1.4-1                                        multilib  200,5 KB
  lib32-flac                       1.4.3-1                                      multilib  168,0 KB
  lib32-libsndfile                 1.2.2-1                                      multilib  235,6 KB
  lib32-libpulse                   16.1-6                                       multilib  287,5 KB
  lib32-tdb                        1.4.9-1                                      multilib  43,3 KB
  lib32-libcanberra                1:0.30+r2+gc0620e4-2                         multilib  65,8 KB
  lib32-gmp                        6.3.0-1                                      multilib  297,8 KB
  lib32-nettle                     3.9.1-1                                      multilib  348,2 KB
  lib32-libtasn1                   4.19.0-1                                     multilib  41,2 KB
  lib32-p11-kit                    0.25.0-2                                     multilib  486,9 KB
  lib32-gnutls                     3.8.1-1                                      multilib  868,1 KB
  lib32-libcups                    2.4.7-1                                      multilib  252,0 KB
  lib32-libepoxy                   1.5.10-1                                     multilib  222,4 KB
  lib32-librsvg                    2:2.57.0-1                                   multilib  1,6 MB
  lib32-libxcomposite              0.4.6-1                                      multilib  6,0 KB
  lib32-libxcursor                 1.2.1-2                                      multilib  21,6 KB
  lib32-libxinerama                1.1.5-1                                      multilib  5,9 KB
  lib32-gtk3                       1:3.24.38-1                                  multilib  3,0 MB
  libdovi                          3.2.0-2                                      extra     220,1 KB
  perl-http-cookiejar              0.014-1                                      extra     14,1 KB
  python-annotated-types           0.5.0-1                                      extra     19,3 KB
  python-pydantic-core             1:2.6.3-1                                    extra     1,5 MB

1 Like
Warning: installing jre-openjdk (21.u35-3) breaks dependency 'java-runtime-openjdk=20' required by java-openjfx

Do I need to remove anything using openjfx and reinstall after or is there another way?

1 Like

Probably because one of your already installed packages got a bunch of new dependencies, that it didn’t have before. For example libnvme is (new?) dependency for libblockdev which is (new?) dependency for udisks2. This udisks2 for me required to install btrfs-progs also now… although I will never use btrfs on this machine.

Sadly I don’t know any way (if there is any at all?) to make pacman or pamac to show the reason for brand new packages for being installed. Only sane way is to install the updates first and then afterward see which packages required those packages in question.

I had the same problem. Checked Arch’s web and java-openjfx have been flagged for a month. Didn’t find any packages that depend on it, so just uninstalled it and updated the system

1 Like
trizen -R java-openjfx
:: Pacman command: /usr/bin/sudo /usr/bin/pacman -R java-openjfx
Abhängigkeiten werden geprüft …
Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von java-openjfx verletzt Abhängigkeit »java-openjfx=20«, benötigt von bluej

trizen -R java-openjfx bluej
:: Pacman command: /usr/bin/sudo /usr/bin/pacman -R java-openjfx bluej


Maxi says the system was in the process of being updated
not bootable for at least 3 minutes and 5 seconds :wink:

maxi -w
Currently running: 6.1.53-1-MANJARO (linux61)
will run until ^c is pressed
  : 0.    linux515 vmlinuz-5.15-x86_64 initramfs-5.15-x86_64.img=37M fallback=130M
  : 0.    linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =39M fallback=134M
  : 0.    linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =42M fallback=152M
 0:18.393 linux515 <vmlinuz missing>   <initrd missing>         =    fallback=<no>
 0:18.520 linux61  <vmlinuz missing>   <initrd missing>         =    fallback=<no>
 0:18.520 linux65  <vmlinuz missing>   <initrd missing>         =    fallback=<no>
 3:05.062 linux515 vmlinuz-5.15-x86_64 <initrd missing>         =    fallback=<no>
 3:05.062 linux61  vmlinuz-6.1-x86_64  <initrd missing>         =    fallback=<no>
 3:05.062 linux65  vmlinuz-6.5-x86_64  <initrd missing>         =    fallback=<no>
 3:10.567 linux515 vmlinuz-5.15-x86_64 initramfs-5.15-x86_64.img=35M fallback=<no>
 3:10.673 linux515 vmlinuz-5.15-x86_64 initramfs-5.15-x86_64.img=37M fallback=<no>
 3:23.819 linux515 vmlinuz-5.15-x86_64 initramfs-5.15-x86_64.img=37M fallback=55M
 3:23.925 linux515 vmlinuz-5.15-x86_64 initramfs-5.15-x86_64.img=37M fallback=130M
 3:29.004 linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =30M fallback=<no>
 3:29.110 linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =38M fallback=<no>
 3:38.671 linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =38M fallback=0
 3:38.778 linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =38M fallback=47M
 3:38.882 linux61  vmlinuz-6.1-x86_64  initramfs-6.1-x86_64.img =38M fallback=134M
 3:44.379 linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =21M fallback=<no>
 3:44.485 linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =42M fallback=<no>
 3:55.089 linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =42M fallback=0
 3:55.193 linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =42M fallback=67M
 3:55.300 linux65  vmlinuz-6.5-x86_64  initramfs-6.5-x86_64.img =42M fallback=152M

I only had two packages that depended on it, so they’re uninstalled for now, but it looks like I won’t be able to reinstall until java-openjfx is updated?

Hmm, thx a lot - that gave me a clue, at least:
As usual, Arch Wiki is a great source of knowledge :smiley:
I will go through the list of “new packages to be installed”, and - one by on - take a look at the "reverse dependency using pacman -Sii <package>( I completely forgot about the “double-i Option”).
I.e. with pacman -Sii libnvme I can quickly detect that libblockdev is the package that “pulls” libnvme into the system when updating with pamac. After that, before updating, I will try to de-install something already in my system that is unnessesary but pulls these “lib32…” packages.
That’s fine with me - any other/better idea?

1 Like

To remove lib32 packages I suggest
pamac remove --unneeded --no-save --orphans "lib32*"

1 Like

Minor issue in Gnome:
Files ignores my Dark Mode system setting since the update.

Had to remove pdfsam (AUR) due to a conflict with the update of java 20.0.2.u9-3 → 21.u35-3

A little off topic, BUT what is this utility “maxi” cant find it, I assume it’s included as part of a suite.


A post was split to a new topic: Choose a provider for nodejs<20

After update I was locked out of my machine. The update included a pacnew files for /etc/shells which I accepted since I never changed this file. But it removed the line for zsh which I use. After booting with a USB drive and adding the path to zsh back to /etc/shells I was able to login again.


After update and before I rebooted, a USB drive was not recognized. This happened on both my PCs. Of course a reboot fixed that.

Good point, thx !!

In addition to that, I found the “-debug” option for pacman (unfortunately, pamac seems to miss it): with this option applied like sudo pacman -Suy -debug, pacman displays a lot of output, but including its decision making process of whether or not a packet update has to be applied, and for what reason (and that was my “missing piece”).
With this information, it was easy for me to pin-down the reason why pamac wanted to install approx. 30 neu “lib32-…” packets: lib32-libdecor was due to be updated from V01.1 to V0.2.0, which added a new dependency for lib32-gtk3 (which in turn pulls all the other lib32-… packets).
Lib32-libdecor is needed by lib32-mesa-demos (companion of mesa-demos), but looking at mesa-demos I found no reason to keep it in my system (never used it, it is not needed by any other packet).
Therefore, I uninstalled mesa-demos and lib32-mesa-demos, and re-started the general system update:
“all well” this time, no more new unexpected packets. → Issue solved. Thx to all who helped me!


Trying to mount an encfs folder gives this error now:
fusermount: mounting over filesystem type 0x7366746e is forbidden. fuse failed.

Looks like an issue with a new kernel driver with NTFS perhaps, which this drive is in my case, but that’s all I found looking around.

Which led to a pull request that looks to be merged: Add NTFS3 kernel driver fs to the whitelist of mount targets by mrdvdrm · Pull Request #830 · libfuse/libfuse · GitHub.

Looks like a workaround is to mount it on a non-NTFS disk for now until the issue is fixed here

After updating the kernel, I noticed that every time I’d shut down my PC, it would still stay on in a sense, light on and all and require a hard shutdown, like it were stuck.
This only happened after updating to 6.5 and stopped as soon as I reverted back to 6.4.16, even updating to the newer Kernel 6.5.5 had the exact same issue, so i have no idea what’s going on there but I can’t really upgrade as a result. Everything else seems to work fine except for that so I’m thinking it’s a kernel issue.

Hardware is a Dell Precision Tower 3620 if it matters, Intel i3-7100 is the CPU.

1 Like