[Stable Update] 2022-04-15 - Kernels, Mesa, Nvidia, Budgie, PipeWire, LIbreOffice, KDE Frameworks, Wine

Hello community,

here comes another stable branch update.

image
It’s Easter! Use code EP8C6KTN0GQP to get $30 off from our latest MiniPC!

  • Most of our Kernels got updated
  • Mesa got renewed to 21.3.8
  • Nvidia was updated to 510.60.02
  • Blender is now at 3.1.2
  • Some updates to Xorg-Stack
  • Plasma is now at 5.24.4
  • Deepin got some packages renewed
  • A second point release is now available for LibreOffice 7.3
  • KDE Frameworks is at 5.92.0
  • Calamares got updated to 3.2.53
  • Budgie saw a new release: 10.6
  • We added fixes for PPPoE to NetworkManager. Please let us know if that improves issues with DSL/PPPoE connections.
  • GStreamer is now at 1.20.1
  • PipeWire is now at 0.3.49
  • Wine got renewed to 7.5
  • and even more Python and Haskell packages have arrived

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux49 4.9.309
  • linux414 4.14.274
  • linux419 4.19.236
  • linux54 5.4.188
  • linux510 5.10.109
  • linux515 5.15.32
  • linux516 5.16.18
  • linux517 5.17.1
  • linux515-rt 5.15.32_rt39
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt16

Package Updates (Mon Apr 4 21:15:33 CEST 2022)

  • stable community x86_64: 2028 new and 2019 removed package(s)
  • stable core x86_64: 64 new and 67 removed package(s)
  • stable extra x86_64: 936 new and 955 removed package(s)
  • stable kde-unstable x86_64: 400 new and 399 removed package(s)
  • stable multilib x86_64: 63 new and 57 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Manjaro 21.2.6 Release

Qonos 21.2.6 is now available!

image

Download XFCE

Full

https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso.sig
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso.sha1
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso.sha256
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso.torrent
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-220416-linux515.iso.pkgs

Minimal

https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso.sig
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso.sha1
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso.sha256
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso.torrent
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux515.iso.pkgs

Minimal (linux510)

https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso.sig
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso.sha1
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso.sha256
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso.torrent
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux510.iso.pkgs

Minimal (linux54)

https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso.sig
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso.sha1
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso.sha256
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso.torrent
https://download.manjaro.org/xfce/21.2.6/manjaro-xfce-21.2.6-minimal-220416-linux54.iso.pkgs

Download GNOME

Full

https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso.sig
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso.sha1
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso.sha256
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso.torrent
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-220416-linux515.iso.pkgs

Minimal

https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso.sig
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso.sha1
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso.sha256
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso.torrent
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux515.iso.pkgs

Minimal (linux510)

https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso.sig
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso.sha1
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso.sha256
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso.torrent
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux510.iso.pkgs

Minimal (linux54)

https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso.sig
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso.sha1
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso.sha256
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso.torrent
https://download.manjaro.org/gnome/21.2.6/manjaro-gnome-21.2.6-minimal-220416-linux54.iso.pkgs

Download KDE

Full

https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso.sig
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso.sha1
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso.sha256
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso.torrent
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-220416-linux515.iso.pkgs

Minimal

https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso.sig
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso.sha1
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso.sha256
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso.torrent
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux515.iso.pkgs

Minimal (linux510)

https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso.sig
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso.sha1
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso.sha256
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso.torrent
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux510.iso.pkgs

Minimal (linux54)

https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso.sig
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso.sha1
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso.sha256
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso.torrent
https://download.manjaro.org/kde/21.2.6/manjaro-kde-21.2.6-minimal-220416-linux54.iso.pkgs

34 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:


:arrow_right: 2022-04-15

KeePassXC auto-type does not work

Upgrading KeePassXC from version 2.6.6 to 2.7.0 partially breaks the “auto-type” function. This is fixed upstream in version 2.7.1.

In in the meantime, to have it behave (and work) as it did with version 2.6.6, change the following option:

Tools → Settings → General → Auto-Type → uncheck “Always ask before performing Auto-Type”

Version 2.7.1, which did not make it into this batch of Stable Updates, works correctly, even with the above option enabled.

Desktop Icons (DING) Gnome extention and File Previews stop working due to a crash in sushi.

This has been fixed upstream in sushi version 41.2. To restore functionality you can manually upgrade.

sudo pacman -U https://archive.archlinux.org/packages/s/sushi/sushi-41.2-1-x86_64.pkg.tar.zst

2022-03-14

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild or remove it:
pamac build qt5-styleplugins
DSL/PPPoE may require downgrading 2 packages

First please check if new bugfix version 1.36.2-1.0 of NetworkManager improves things.

If it does not, downgrade to 1.34.0 (and restart network manager after) :

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

Bug report: FS#73948 - networkmanager 1.36.0 breaks DSL connection

Older dicussion: my-internet-connection-is-no-longer-working

mangohud (AUR) prevents Wine/Proton applications from starting
  • Consider disabling the mangohud overlay until the bug is fixed upstream.
VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

2022-02-27

Microsoft Teams does not open.

See this thread.

2022-02-05

Issues with Jack2 when using Pipewire.

Pipewire tend to replace all stuff related to Audio. This time jack2 seems to create issues. In the past pipewire-jack provided jack2. However, since the lack of dbus support that line got removed and only conflicts kept. So if you use jack2 with the dbus feature, you may want to remove the pipewire-jack package. If not you can continue and additionally install lib32-pipewire-jack package.

Last update removed linux514. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have.

sudo mhwd-kernel -r linux514
sudo pacman -Syu
sudo mhwd-kernel -i linux515
New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic

2022-01-02

Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

9 Likes

Huge thanks to the Team and contributors for all the work put into Manjaro.

Going to bring over my findings from another thread that had discussions on the update before the official announcement went up.

3 Likes

A small, specific, and very weird change in behavior after this update. In xfce4-terminal I usually use Ctrl-Shift-PgUp and Ctrl-Shift-PgDn to scroll several pages up or down. After the update, I can no longer use those two keyboard shortcuts. Other shortcuts like Ctrl-Shift-UpArrow (one line up) and Ctrl-Shift-Home (all the way up) are still available but Ctrl-Shift-PgUp isn’t available. I also see that all those shortcuts are still available in the numeric keypad but not for the PgUp / PgDn keys that are to the left of Num Lock. Very specific, and causing me to scroll differently.

Did some keyboard setting change in this update?

There’s something weird happening with the System Settings and Manjaro Settings Manager, the application will halt/hang when I try to open the “Hardware Configuration” page, also tried to open the setting through the terminal with manjaro-settings-manager --debug --module msm_mhwd and systemsettings msm_mhwd for Manjaro Settings and System Settings respectively, and it gives nothing, not literally, but nothing useful.

Manjaro Settings outputs:

$ manjaro-settings-manager --debug --module msm_mhwd
Icon theme "Numix-Circle" not found.

and display nothing, nothing shows up.

System Settings outputs:

$ systemsettings msh_mhwd
Icon theme "Numix-Circle" not found.

the System Settings window shows up but is stuck or rather hang giving a blank screen.

EDIT:

Okay, while I’m tinkering with my pc (not related to the problem) I need to install some software and then update the package, do a couple of restarts, and somehow the Hardware Configuration page problem is solved, it’s either because of some package that also got installed (when installing the software I needed, there’s also an additional package that needs an update, couldn’t remember what it was) from the update or because the restart solves it.

VA-API stopped working:

vainfo (and any application using it):

$ vainfo
libva error: /usr/lib/dri/iHD_drv_video.so init failed
vaInitialize failed with error code 1 (operation failed),exit
lspci -k | grep i915
        Kernel driver in use: i915
        Kernel modules: i915

This is fixed by setting LIBVA_DRIVER_NAME=i965 as per this thread:

$ LIBVA_DRIVER_NAME=i965 vainfo
vainfo: VA-API version: 1.13 (libva 2.14.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.4.1
...

Which config file is the correct one to place the environment variable LIBVA_DRIVER_NAME? Is this the proper way to fix this problem?

Even after setting the variable there is still graphical problems running some electron based software (the main surface is just grey).

I tried removing all video related drivers and used mhwd to automatically reinstall them, then I reinstalled manjaro-vaapi but this did not affect anything.

1 Like

Hello all,
with the Mate-edition I had to uninstall the package “mate-tweak” for the update to work.

I am on kernel 5.16. I checked “run config wizard” in kdenlive and it shows VAAPI is working.

The package:

manjaro-mate-settings

has the following missing dependencies, since a long time ago:

gnome-icon-theme
gnome-icon-theme-symbolic

See the image attached.

1 Like

I’m on kernel 5.17.

Screenshot_20220415_232002

However, running kdenlive with the variable set makes it work:

LIBVA_DRIVER_NAME=i965 kdenlive

Screenshot_20220415_233413

I just need to figure out the proper place to set this environment variable so that it work system wide.

This turned out to be an unrelated problem that had to do with the application not working with Electron 18, modifying the package to use electron17 fixed it.

2 Likes

manjaro-mate-settings package is broken since a long time ago.

  1. Remove it without removing its dependencies.

  2. Remove its dependencies you have installed from AUR.

  3. Mark the rest of its dependencies as explicitly installed.

  4. Install mate-tweak package as usual.

1 Like

All went fine except for the fact that I faced an issue with the utility “solaar” (to set logitech hardware):

After the new update, I’m running into the following error message with ParaView:

/opt/paraview/bin/paraview: symbol lookup error: /opt/paraview/lib/libvtkfides.so.1: undefined symbol: _ZN6adios25ADIOS9DeclareIOENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

I attempted to remove and reinstall (yay -R paraview && yay -S paraview), but the error still occurs. Note that even though I’m using yay above, paraview is not an AUR package.

This is with the i3 version of Manjaro (though I’ve installed qtile as my WM).

Is the AMD p-state driver enabled in this release (for 5.17) or is there additional configuration required to enable? Are there recommendations not to enable this yet?

I have this in my 5.17.1 booted kernel:

[strit@odin ~]$ zgrep PSTATE /proc/config.gz 
CONFIG_X86_INTEL_PSTATE=y
CONFIG_X86_AMD_PSTATE=y

So I guess, yes, it’s enabled.

2 Likes

It is enabled, but I’m pretty confident that for now, you need to add kernel parameters and configure your UEFI for it to replace acpi-cpufreq.

Kernel parameters to add: amd_pstate.enable=1 and amd_pstate.shared_mem=1 in some case
UEFI setting to enable: CPPC

See this post for source of info from last month [Testing Update] 2022-03-24 - Linux517, Nvidia, Palemoon (not) - #5 by stephane

The issue is fixed withmanjaro-mate-panel-layout 20220415-2.

Fixed with manjaro-mate-settings 20220415-1.

See above.

FYI, MATE packages in general are rarely maintained. This is true for Arch, Manjaro and the AUR.

The Arch packages were orphaned for quite some time, then a maintainer stepped up and updated some.

We currently have no dedicated maintainers for several of our community editions. I’m playing catch up a little and we build ISO’s occasionally to make sure things aren’t broken, that’s about it.

2 Likes

i updated intel-media-driver from 22.2.2-1 (manjaro package) to 22.2.2-2 from ala.
Now vaapi works with mpv and /usr/lib/dri/iHD_drv_video.so

sudo pacman -U https://archive.archlinux.org/packages/i/intel-media-driver/intel-media-driver-22.2.2-2-x86_64.pkg.tar.zst

3 Likes

Thanks! This worked for me too, now iHD works with vainfo.

I’m having font problem with FireFox on some site