My internal microphone is no longer detected


My internal microphone is no longer detected after this update, and no sound is captured (although I’ve had no chance to notice that for about two weeks).

  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes

That also happens with kernels 5.10 and 5.4. Meanwhile pacmd shows just one source with flags DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY and property “Monitor of Built-in Audio Analog Stereo”.

To check that the internal microphone is actually working, I booted from a USB stick with some older Manjaro image (kernel 5.8). The microphone worked indeed, while pacmd showed two sources: index 0, which is the same “Monitor”, and index 1, which the installed system misses.

		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix" = "ALC3246 Analog" = "ALC3246 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xd5328000 irq 141"
		alsa.driver_name = "snd_hda_intel"

try installing pipewire, install this package manjaro-pipewire - it will automatically remove pulse, then reboot and check

Well… It wasn’t quite automatic because of dependencies. Now the sound is captured, but I lost volume control (KDE).

Now it looks solved after a couple more remove/install rounds. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.