[Stable Update] 2022-02-14 - Kernels, Haskell, Cutefish 0.7, Deepin, Firefox, Maui 2.1.1, Systemd

Hello community,

Another stable branch update with some usual updates for you.

Don’t miss out on 20% discount on all of our #Merch! Visit the store today!

Checkout our latest spin of Cutefish!

  • Most of our Kernels got updated
  • Cutefish got updated to 0.7
  • Some more Deepin packages got updated
  • Firefox is now at 97.0
  • Maui got renewed to 2.1.1
  • systemd drops cloudflare from fallback DNS servers
  • The usual upstream updates including Haskell and Python

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.302 [EOL]
  • linux49 4.9.299
  • linux414 4.14.264
  • linux419 4.19.227
  • linux54 5.4.178
  • linux510 5.10.98
  • linux515 5.15.21
  • linux516 5.16.7
  • linux517 5.17-rc3
  • linux515-rt 5.15.18_rt28
  • linux516-rt 5.16.2_rt18

Package Updates (Wed Feb 9 08:02:28 CET 2022)

  • stable community x86_64: 746 new and 760 removed package(s)
  • stable core x86_64: 37 new and 37 removed package(s)
  • stable extra x86_64: 145 new and 243 removed package(s)
  • stable kde-unstable x86_64: 314 new and 314 removed package(s)
  • stable multilib x86_64: 13 new and 13 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

Issues with Jack2 when using Pipewire.

Pipewire tend to replace all stuff related to Audio. This time jack2 seems to create issues. In the past pipewire-jack provided jack2. However, since the lack of dbus support that line got removed and only conflicts kept. So if you use jack2 with the dbus feature, you may want to remove the pipewire-jack package. If not you can continue and additionally install lib32-pipewire-jack package.

Last update removed linux514. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have.

sudo mhwd-kernel -r linux514
sudo pacman -Syu
sudo mhwd-kernel -i linux515
Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic

Older Issues:

Xorg crashes with multiple monitors if portrait view or custom display scale is used on 2nd display (possibly leading to infinite login loop)

Error: LightDM infinite login loop
[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #244 by LS650V
for problem descriptions and possible solutions.

KDE Plasma shows visual graphical errors

This is a known issue based on changes within SVG files. Clearing the Plasma SVG cache fixes it. Do this: rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

If did not help, try strengthened variant of clearing cache (to be sure that it is not the cache-related issue)
  1. Log out from user session to shutdown all KDE and user apps which could use the cache.
  2. Enter TTY, for example TTY3: Ctrl+Alt+F3.
  3. Login in that textual terminal.
  4. Clear all cache and extra KDE-related stuff by entering these 3 commands: KDE - ArchWiki.
  5. Type systemctl reboot to reboot PC.

Nvidia 495xx driver series drops Kepler support; need to manually switch to 470xx.

mhwd’s video-nvidia now provides 495xx; if you need 470xx you must manually switch before updating, by using the commands below.

With the new 495xx driver series a lot of Wayland adjustments got added. Also Nvidia decided to remove Kepler support. Therefore you may want to switch drivers to 470xx series, which still supports those graphic cards:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx

Nvidia 340xx driver series no longer works.

This driver is end of life by NVIDIA, you should not be using it as there are serious security issues with this driver. You have to either get newer supported hardware or switch to Nouveau:

#remove old
sudo mhwd -r pci video-nvidia-340xx
sudo mhwd -r pci video-linux
#install new nouveau
sudo mhwd -i pci video-linux

Reboot after and you're done.
Shotcut Scrolling doesn't work any more in Cinnamon

You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards. Source

Fullscreen loses focus

Full-screen apps like YouTube and games:

  • Load fine but after briefly showing the application you’re dumped back into your Desktop Environment (DE) whilst the application was still running fine in the background.
  • Clicking on the running application briefly brings you back to it but you’re dumped again to the DE after a second or 2.

disable the Desktop Icons (DING) extensions

SDDM shows wrong/default theme


Set SDDM theme to Breath in System Settings / Startup and Shutdown / Login Screen (SDDM).

No search results in application launcher when using multiple kickoff instances

Edit 2: Bug is fixed with the 2022-01-23 Stable Release of Manjaro. People who have replaced the Applet by using Solution 1 may want to revert the solution.

Edit: Bug is now fixed Upstream. It will be in the next Plasma 5.23.5 Release, which is scheduled at Tue 2022-01-04.

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there’s more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

Steam shows black screen

:warning: Opting in or out for Steam beta changes nothing.


  • Open a terminal
  • Execute:
    LD_PRELOAD=/lib/libharfbuzz.so steam

Buzzing sound while using headphones.


  • Execute:
    sudo nano --backup /etc/tlp.conf
  • Only if you have to, set SOUND_POWER_SAVE_ON_BAT=0 as well

No idea how much it affects battery life, though.

Unable to login in remotely using ssh using rsa keys

After this upgrade authentication might not work and might find the following error in the ssh log:

userauth_pubkey: key type ssh-rsa not in PubkeyAcceptedAlgorithms [preauth]

Good solution:

  • generate new keys using a more secure algorithm like ED25519

Lazy solution (acceptable for rsa keys with a length >= 3000bits):

  1. Execute:
    sudo nano --backup /etc/ssh/sshd_config
  2. copy-paste the following into the above file:
  3. To save, press Ctrl+X Enter Y

It works now, but you’re still using SHA1 which has been showing weaknesses for years now (although it’s not actually cracked, it’s not recommended any more and why ssh disabled it)

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.

Brave segfaults / crashes


  • Clear cache / Data
  • Re-install Brave afterwards

You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv

nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules

Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages:

sudo pacman -Rdd lib32-libcanberra-pulse \
lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer

Note: there are 4 packages to remove: copy all those two lines of the command.
We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!




pamac build $(pacman -Qoq /usr/lib/python3.9) --no-confirm

Just finished the Upgrade on Manjaro XFCE and everything went smooth so far. But now Pamac shows me that there would be an upgrade of qt5-styleplugins to version in the AUR. I also did not originally install this package from the AUR, as I understand, it was installed automatically and my possibly be a system relevant component of qt5 (The dependencies are qt5-base and gtk2). Could you guys correct that? Many thanks! :blush:


qt5-styleplugins was dropped from the repos as part of dropping GTK 2 packages. GTK 2 has reached its end of life: GTK 4.0 – GTK Development Blog. You may continue using it from the AUR if you wish.


Small issue noticed right away with my conky… it appears that the font line spacing has increased, so my conky is vertically longer than normal. Here is my conky font config:

  font = 'DevaVu Sans Bold:size=10',

Noticed fonts were touched in this update, but makes me wonder… was there always an issue that is now corrected, or was an issue introduced, or do we have some extra controls somewhere where I can change the line spacing?

[2022-02-14T13:05:13-0600] [ALPM] upgraded fontconfig (2:2.13.94-2 -> 2:2.13.96-1)
[2022-02-14T13:05:13-0600] [ALPM-SCRIPTLET] Rebuilding fontconfig cache...

[2022-02-14T13:05:17-0600] [ALPM] upgraded lib32-fontconfig (2:2.13.94-1 -> 2:2.13.96-1)
[2022-02-14T13:05:17-0600] [ALPM-SCRIPTLET] Rebuilding 32-bit fontconfig cache...

Running with the idea that this is a correction to learn to work with… I have resolved it in conky by:

  1. increasing the font size… font = 'DevaVu Sans Bold:size=11.5', and
  2. adding a voffset to every line… ${voffset -5}

How can I remove GTK2? As far as I can see in Pamac, GTK2 has been installed automatically in version 2.24.33-2 (legacy) and has dependencies to viewnior, gimp, hexchat, to the AUR package anydesk-bin and others. What should optimally be removed?

Completely dropping GTK2 is nowhere near done yet. See Arch Linux - Todo: GTK 2 EOL

You can wait and see if your programs will update to GTK 3 /4 or find a replacement program that is.

Please can you advise how I can check whether qlogic devices are fitted to my laptop. For example is there a simple option for mhwd or hwinfo to do this?

in the list there is : steam-native-runtime , nvidia-settings , gtk-engine-murrine ( mate ) …

I’ve been using steam-manjaro and AFAIK it doesn’t depend on gtk2 so long as you don’t install two optional dependencies:

  1. steam-native (which you mentioned)
  2. lib32-libappindicator-gtk2

I’m pretty sure steam-manjaro was pre-installed for me in KDE Plasma, the above two options are not selected/installed, and I’ve had a great steam experience since July 2021.

I was able to uninstall qt5-styleplugins without any problems, it just has been in the orphans. But after I deleted this, the Kvantum manager was also removed. I didn’t install it myself, it was pre-installed when I set up my Manjaro a few years ago. Is this how it is intended in Manjaro Xfce?

Kvantum was installed as a dependency of one of the dropped themes. You can always reinstall Kvantum if you would still like to use it.

1 Like

What is the release number for this?


After the update I started experiencing screen tearing. restarting fixed it

Version numbers are basically meaningless on a rolling release. They only mark snapshots for ISO releases. There is no new ISO release, therefore there is no new release version.

Either way, you can check with

❯ pamac info manjaro-release | grep Version
Version               : 21.2.3-1


❯ pacman -Si manjaro-release | grep Version
Version         : 21.2.3-1


❯ lsb_release -a
LSB Version:	n/a
Distributor ID:	ManjaroLinux
Description:	Manjaro Linux
Release:	21.2.3
Codename:	Qonos

I’ve found this:

“The solution is in /usr/share/fontconfig/conf.avail/60-Latin.conf edit to move DejaVu Serif, DejaVu Sans, DejaVu Sans Mono to the top of each block”

Worked for me.


Again, this update has gone smoothly for me. As other users have reported before me, I only noticed that the default monospaced font has changed from DejaVu Sans Mono to Noto Sans Mono with the fontconfig update. However, I don’t consider this change to be a problem so far, as I haven’t been able to see it causing any issues, and I think I actually like it. :slight_smile:

1 Like

After the last update I can no longer log into my system (KDE). At first it affected only the log in screen (sddm) and I managed to log into TTY.
After choosing “other” and typing my username into the field, password was also accepted.
Sadly I was stupid enough to reboot my system once more and now cannot log in with either method.

Before the reboot i tried to change my password with passwd but received the following error:

passwd myuser
Changing password for myuser.
Current password:
passwd Authentication service cannot retreive authentication info
passwd: password unchanged

I would like to attempt to roll back my system via timeshift.

Am i correct in the assumption that the process for this would be to:
boot from live cd,
chroot into the system,
mount md0 (the raid10 array that holds the system backups (rsync)),
then issue sudo timeshift --restore?

Thanks for your help. Please also feel free to split this off to correct support category.
Cheers Beer!

After restoring last nights snapshot and dealing with some grub problem which in turn forced me to update the system while reinstalling grub, things are back to normal for now.
Still no idea what may have caused the inital password problem however. :thinking:

Quick question, after the update I’ve got some interesting danglers…

❯ pacman -Qdt
gnome-shell-extension-gamemode 6-1
kvantum-theme-matchama 20191118-1
matcha-gtk-theme 20211225-1

I consider these vital packages, so I’m wonderiing whether this is intentional?

P.S. I use the minimal install, if that’s relevant.