[Stable Update] 2022-01-23 - OpenSearch, Kernels, KDE Software, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

Hello community,

Another stable branch update with some usual updates for you.


Don’t miss out on our latest Manjaro Product: UM700 EliteMini - starting from $499

  • Most of the Kernels got updated
  • With this we also updated Cinnamon to 5.2 series. More info in the release review
  • kicad is at 6.0.1
  • lazarus IDE is now at 2.2.0
  • opensearch 1.2.3 got added
  • Systemd got renewed to 250.2
  • Xorg-Server is now at 21.1.3
  • Mesa got renewed to 21.3.4
  • Nvidia driver is at 495.46
  • Plasma is at 5.23.5
  • KDE Gear got updated to 21.12.1
  • KDE Frameworks are now at 5.90.0
  • We updated Firefox to 96.0.2 add Thunderbird to 91.5.0
  • Most Gnome parts are now at 41.3
  • LibreOffice got updated to 7.2.5
  • PipeWire is now at 0.3.43
  • With 7.0rc5 Wine got another RC
  • AMDVLK is now at 2021.Q4.3
  • libadwaita is now at 1.0
  • The usual upstream updates including Haskell and Python

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.299
  • linux49 4.9.297
  • linux414 4.14.262
  • linux419 4.19.225
  • linux54 5.4.173
  • linux510 5.10.93
  • linux514 5.14.21 [EOL]
  • linux515 5.15.16
  • linux516 5.16.2
  • linux510-rt 5.10.90_rt60
  • linux515-rt 5.15.13_rt26

Package Updates (Mon Jan 17 16:50:28 CET 2022)

  • stable community x86_64: 2060 new and 1967 removed package(s)
  • stable core x86_64: 56 new and 57 removed package(s)
  • stable extra x86_64: 928 new and 990 removed package(s)
  • stable kde-unstable x86_64: 407 new and 406 removed package(s)
  • stable multilib x86_64: 31 new and 33 removed package(s)

All package changes are listed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

NVIDIA 495xx driver is spamming invalid dbus messages resulting in Gigabytes of log files

Depending on the usage of the GPU, the driver spams invalid dbus messages at a very high rate (~100 lines per second) which will fill multiple Gigabytes of system log files within a few days.

Upstream NVIDIA Bug: [BUG] NVIDIA v495.29.05 driver spamming dbus-enabled applications with invalid messages - Linux - NVIDIA Developer Forums

Temporary Fix: Install nvidia-fake-powerd (AUR) - (don’t forget to start / enable the service with sudo systemctl enable nvidia-fake-powerd and sudo systemctl start nvidia-fake-powerd)

nvidia-fake-powerd is a service, which will redirect those dbus messages to /dev/null, so technically it just prevents that it’s written into system log files.

Xorg crashes with multiple monitors if portrait view or custom display scale is used on 2nd display (possibly leading to infinite login loop)

Error: LightDM infinite login loop
[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa - #244 by LS650V
for problem descriptions and possible solutions.

KDE Plasma shows visual graphical errors

This is a known issue based on changes within SVG files. Clearing the Plasma SVG cache fixes it. Do this: rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

If did not help, try strengthened variant of clearing cache (to be sure that it is not the cache-related issue)
  1. Log out from user session to shutdown all KDE and user apps which could use the cache.
  2. Enter TTY, for example TTY3: Ctrl+Alt+F3.
  3. Login in that textual terminal.
  4. Clear all cache and extra KDE-related stuff by entering these 3 commands: KDE - ArchWiki.
  5. Type systemctl reboot to reboot PC.

This update removes linux512. What you can do.

Time to time we have to drop kernel series from our repos. So either you adopt to the new 5.15 LTS or choose any other still supported kernel we have. Note: 5.13 is marked EOL and will be dropped next!

sudo mhwd-kernel -r linux512
sudo pacman -Syu
sudo mhwd-kernel -i linux515

Nvidia 495xx driver series drops Kepler support; need to manually switch to 470xx.

mhwd’s video-nvidia now provides 495xx; if you need 470xx you must manually switch before updating, by using the commands below.

With the new 495xx driver series a lot of Wayland adjustments got added. Also Nvidia decided to remove Kepler support. Therefore you may want to switch drivers to 470xx series, which still supports those graphic cards:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx

Nvidia 340xx driver series no longer works.

This driver is end of life by NVIDIA, you should not be using it as there are serious security issues with this driver. You have to either get newer supported hardware or switch to Nouveau:

#remove old
sudo mhwd -r pci video-nvidia-340xx
sudo mhwd -r pci video-linux
#install new nouveau
sudo mhwd -i pci video-linux

Reboot after and you're done.

Pamac can't handle file conflicts checking

If you experience this issue update libpamac with: sudo pacman -Sy libpamac
For details see: Hangs on file conflicts checking (#1138) · Issues · Applications / pamac · GitLab

Shotcut Scrolling doesn't work any more in Cinnamon

You now need to hold down the (aka “the Windows key”) to make the mouse wheel scroll the timeline forwards & backwards. Source

Fullscreen loses focus

Full-screen apps like YouTube and games:

  • Load fine but after briefly showing the application you’re dumped back into your Desktop Environment (DE) whilst the application was still running fine in the background.
  • Clicking on the running application briefly brings you back to it but you’re dumped again to the DE after a second or 2.

disable the Desktop Icons (DING) extensions

SDDM shows wrong/default theme


Set SDDM theme to Breath in System Settings / Startup and Shutdown / Login Screen (SDDM).

Older Issues:

No search results in application launcher when using multiple kickoff instances

Edit 2: Bug is fixed with the 2022-01-23 Stable Release of Manjaro. People who have replaced the Applet by using Solution 1 may want to revert the solution.

Edit: Bug is now fixed Upstream. It will be in the next Plasma 5.23.5 Release, which is scheduled at Tue 2022-01-04.

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there’s more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

With 21.1.4 and initial 21.1.5 release it was not possible to install on non-BTRFS filesystems

Seems grub-btrfs preinstalled in version 4.10.1 introduced a regression to error out when no BTRFS filesystem was found on your system. This was part of 21.1.4 ISO and our initial 21.1.5 release. Please re-download 21.1.5, which is now fixed.

Fixed ISOs:

58de4cd58b23fea2ef69c055dd0088726350294a  manjaro-gnome-21.1.5-211008-linux513.iso
a8af15b768479ea321c897aa83e573e26bd61784  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
aef8a60820666cddce79c980258693d0cf13da9a  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
564c64ddf342c9b7483c469a6d8dca2f94492719  manjaro-kde-21.1.5-211008-linux513.iso
3781a3c0d3a92496b1418dafb49cef247379aa93  manjaro-kde-21.1.5-minimal-211008-linux513.iso
1f4c83be758275e3d0bb17a0b32138b7a0b313a8  manjaro-kde-21.1.5-minimal-211008-linux54.iso
00737362c81c3c3d4ec7fba6f7a7ec72701a0450  manjaro-xfce-21.1.5-211008-linux513.iso
c2e2f5018d9a50a1112bbcc761a22c8e4dcb7275  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
a34e27a17ab5fcc6473f1ad503d2049a9c904608  manjaro-xfce-21.1.5-minimal-211008-linux54.iso

Broken ISOs:

91cf900bb978dfbb3d32fec083c27d4c428b03ca  manjaro-gnome-21.1.5-211008-linux513.iso
c9f07d7ab4f3bb3a75b1a3c84e909cbf3bd74309  manjaro-gnome-21.1.5-minimal-211008-linux513.iso
7e0673c604e1ce267f59d0056ddf819cede21f38  manjaro-gnome-21.1.5-minimal-211008-linux54.iso
1f56c7feaf7c5fea485b30a6d3c513fb3d0188bb  manjaro-kde-21.1.5-211008-linux513.iso
0922345bdec24b2eb5ed6f635c600b2a499a1ed9  manjaro-kde-21.1.5-minimal-211008-linux513.iso
74fd38b172be9c996d6d59e40e4a730b93f9c88f  manjaro-kde-21.1.5-minimal-211008-linux54.iso
3b9409492b791f4380f617489c63e327ae7f6d53  manjaro-xfce-21.1.5-211008-linux513.iso
10a8d165d9bd0a8edcae1a640e0c753b1ff1c54c  manjaro-xfce-21.1.5-minimal-211008-linux513.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso
3d72ecdb9494f0e7876018286f875f1a0cef1191  manjaro-xfce-21.1.5-minimal-211008-linux54.iso

Steam shows black screen

:warning: Opting in or out for Steam beta changes nothing.


  • Open a terminal
  • Execute:
    LD_PRELOAD=/lib/libharfbuzz.so steam

Buzzing sound while using headphones.


  • Execute:
    sudo nano --backup /etc/tlp.conf
  • Only if you have to, set SOUND_POWER_SAVE_ON_BAT=0 as well

No idea how much it affects battery life, though.

Unable to login in remotely using ssh using rsa keys

After this upgrade authentication might not work and might find the following error in the ssh log:

userauth_pubkey: key type ssh-rsa not in PubkeyAcceptedAlgorithms [preauth]

Good solution:

  • generate new keys using a more secure algorithm like ED25519

Lazy solution (acceptable for rsa keys with a length >= 3000bits):

  1. Execute:
    sudo nano --backup /etc/ssh/sshd_config
  2. copy-paste the following into the above file:
  3. To save, press Ctrl+X Enter Y

It works now, but you’re still using SHA1 which has been showing weaknesses for years now (although it’s not actually cracked, it’s not recommended any more and why ssh disabled it)

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.

Brave segfaults / crashes


  • Clear cache / Data
  • Re-install Brave afterwards

You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv

nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules

Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages:

sudo pacman -Rdd lib32-libcanberra-pulse \
lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer

Note: there are 4 packages to remove: copy all those two lines of the command.
We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!



qBittorrent, suddenly appears light themed. Before it was dark themed, like qt5ct specified…

My eyes almost died when opened qBitorrent and saw all white

Edit: Solution: install qt6ct and select Kvantum theme and Cantarell Fonts


Manjaro KDE,If you update to the kernel of version 5.15 and later, you will not wake up after closing the laptop cover and opening the laptop cover again.
The kernel of 5.14 and earlier does not have this problem.


Use 5.15 kernel. Wake up works fine.
Ryzen 5 3500U


zoom (the flatpak version) was not working after the update.


I was able to fix that by running:

$ flatpak upgrade

I think org.freedesktop.Platform.GL.nvidia needed an upgrade after updating the nvidia drivers.

I don’t know why pamac doesn’t display an upgrade for those flatpak pakages. I always need to upgrade them from the terminal.


We updated Firefox to 96.0.1

To 96.0.2 i think?
Stable: 96.0.2-0.2

Google Drive KIO in dolphin doesn’t work anymore.

Telegram has render issues (all text & icons are pixelated, also the bottom line is corrupted showing the window below it)


Maybe run the update command a second time. I did that after 5 minutes update process and then I got prompted to remove end-of-life stuff from Branch 18.08. Hopefully I did not remove something important.

$ flatpak update
Info: org.freedesktop.Platform//18.08 is end-of-life, with reason:
The Freedesktop SDK 18.08 runtime is no longer supported as of 31th August 2020. Please ask your application developer to migrate to a supported platform.
Info: org.freedesktop.Platform.html5-codecs//18.08 is end-of-life, with reason:
The Freedesktop SDK 18.08 runtime is no longer supported as of 31th August 2020. Please ask your application developer to migrate to a supported platform.

ID                                              Branch          Op
1. [-] org.freedesktop.Platform.Locale                 18.08           r
2. [-] org.freedesktop.Platform.html5-codecs           18.08           r
3. [-] org.freedesktop.Platform                        18.08           r

Uninstall complete.

You mean this is actually an unedited screenshot? If yes, then that’s hilarious, but also sucks.


[SOLVED] I had the following error:
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (495.46-3) breaks dependency ‘nvidia-utils=495.44’ required by linux513-nvidia

Solved this by removing Kernel 5.13.x from my system (it was installed but not running) from Settings → Kernel.

Ran update again and no error this time.

KDE desktop icons not shown, if the image file is an SVG; it’s OK if the image is an PNG.

LOL The messages are edited
the rest are not

1 Like

Also the flatpak version doesn’t have this issue

I get this conflict:

:: Replace hwids with core/hwdata? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing hwids breaks dependency 'hwids' required by linux-driver-management

And that’s actually an understatement, because hwids is (directly or indirectly) required by 1400 packages, removing it would break kwin, lightdm, linux510, plasma-desktop, systemd and much more, so it’s not like I could just uninstall or fix one or a few affected packages.

Should I just reply “no”? Would the update still go through normally? But then it would prompt the same thing next time, right?

There is a known issue with Asus Laptops (on multiple distros) where the built-in keyboard is unresponsive in initramfs when cold booting - such that if you have an encrypted root you cannot type in your password.

The solution on Arch based distros was to add i8042 to the MODULES section & move up keyboard keymap in the HOOKS section of mkinitcpio.conf.

After this update, the solution has stopped working & the keyboard is again unresponsive - but only if cold booting. Rebooting is perfectly fine.

Anyone else with an Asus Laptop have a similar experience, or is it just me?

::Edit:: Nevermind, user error. Fixed it. The solution still works.

@philm is the latest packager of linux-driver-management.
Is this still needed on your system?

$ pactree -r linux-driver-management

Try to remove if not.
The move to hwdata is inevitable: that package needs fixing or removal.

Alternative command for people who don’t want to install some weird helpers but use good old pamac
pamac build $(pacman -Qoq /usr/lib/python3.9) --no-confirm


Testing Update discussion suggests installing qbittorrent-qt5 from AUR

[Testing Update] 2022-01-17 - OpenSearch, Kernels, KDE, Cinnamon, Pipewire, Mesa - #51 by michaldybczak
qbittorrent-qt5 is compiled and installed. Works and looks fine. I guess this is the best solution for now

1 Like