[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice

On KDE I wanted the green Dolphin icon back, instead of the blue one. To do this I tried to change my theme. Once I did, I got the KDE logo on the Application Launcher button rather than the Manjaro one. I’d like to get the Manjaro Logo back. The Manjaro Logo is shown in the screenshot for the theme I am on (Breath Dark).

I also would love to get the green Dolphin logo back. It made Dolphin feel like it matched the default color scheme so much better.

1 Like

I decided to have a go at it. After some tinkering I could not get the audio devices to show up. Eventually I decided to rollback the ALSA update to, restarted and voila the audio devices are back.

This is the rollback command I used:

sudo pacman -U /var/cache/pacman/pkg/lib32-alsa-lib- /var/cache/pacman/pkg/alsa-lib- /var/cache/pacman/pkg/lib32-alsa-plugins-1.2.5-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/alsa-plugins-1:1.2.5-2-x86_64.pkg.tar.zst /var/cache/pacman/pkg/alsa-ucm-conf- /var/cache/pacman/pkg/alsa-utils-

I will create an issue at the ALSA repo as well but at least we have sound again.

Well the blue Dolphin logo should resolve itself with a later KDE update as the Manjaro team worked with the KDE dev team to make it color aware to the color scheme. You could reinstall Breath icon theme and use that but is depricated so no garantee it will work later on down the line. So default is now Breeze icon theme and you should use that.

To fix the Starter Icon you could rightklick on the taskbar and enter “edit mode”, then hover the mouse over the start menu and klick on settings … there you could change the icon.

1 Like

ALSA believes the issue is fixed in version

So we just have to wait until this is released in an update.

i don’t think you can change the dolphin icon color from blue to green because that is the one that comes in breath dark theme. for getting back manjaro icon right click on the application launcher and select configure. there you can change the icon buy searching for manjaro.

Having an issue with steam, was playing a game before updating, updated, and now it hangs on ‘preparing to launch’.

I then checked the steam settings and the setting to enable proton for all non-linux games was unticked for some reason, I try to tick it after which steam requires a restart but it fails to restart, I get:

Thread "CJobMgr::m_WorkThreadPool:2" (ID 114032) failed to shut down

Spammed at me. Only way for me to exit steam is to kill it. No known solution.

Also to make matters worse, my GUI theme got all messed up after the update (I’m on KDE, qt applications display properly, but gtk applications seem to be using the wrong theme all of a sudden.) but that was easy to fix, just had to reapply it.

Also optimus-manager is not working

$ optimus-manager
Traceback (most recent call last):
  File "/usr/bin/optimus-manager", line 33, in <module>
    sys.exit(load_entry_point('optimus-manager==1.4', 'console_scripts', 'optimus-manager')())
  File "/usr/bin/optimus-manager", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: optimus-manager

I’m using the latest one, 1.4-3

Xfce, Kernel 4.14.

With this update, lightdm now is working again:

After Stable Update 2021-09-24 LightDM no longer automatically start - #34 by D.Dave

Having an issue when I am trying to update today :slightly_smiling_face:

resolving dependencies...
looking for conflicting packages...
:: libxnvctrl-390xx and libxnvctrl are in conflict. Remove libxnvctrl? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libxnvctrl-390xx and libxnvctrl are in conflict

Has anybody else running nvidia-390xx drivers faced a similar issue ? TIA

Nevermind. Solved it ! :+1:t4:

It is funny, but 1.4-2 worked for me after update just fine. And 1.4-3 is broken. Will switch to AUR version temporarily.

UPD. AUR version works just fine.

Appreciate your efforts in discovering the problem and establishing a workaround. Cheers.

It happens the same with Kernel 5.10 and 5.15, with the NVIDIA 495XX and 470XX drivers.

This is the log journalctl:


1 Like

1.4-3 broke it for me, i had no issues prior to that.
trying to switch to another card in optimus manager-qt brings an error:
unable to connect to optimus manager daemon:
no such file or directory.

1 Like

If optimus-manager is going to be that problematic, I’ll just drop it from the repos. I do not have hardware with hybrid graphics to test. The previous maintainer did, but he is no longer on the team.

Can we still use it from github?

6 posts were merged into an existing topic: Optimus manager doesn’t work after upgrade

I have the same problem on 5.10, 5.14 and 5.15


A post was merged into an existing topic: Optimus manager doesn’t work after upgrade

A post was merged into an existing topic: Optimus manager doesn’t work after upgrade

I know: Don’t post if all is good!.. Yeah, all is great here!.. Accept this post though as a way to wish all the wonderful Manjaro Team and Community merry Christmas and a prosperous new year of 2022!!!..