After Stable Update 2021-09-24 LightDM no longer automatically start

Done: doesn’t help.

It is really weird… at this point I have no idea. I come back to you if I have another idea. Maybe someone know what your actual problem is…

I have no system which is running lightdm or xfce4 right now.


In the meantime I thank you for your efforts, for devoting your time :slight_smile:

1 Like

This might be relevant:

I don’t have hybrid graphic (Intel/Nvidia): I have only Intel; I also tried to boot with different kernels, without success.

I’m going to accept the fact of login using TTY instead of graphic greeter.

I also tried to uninstall again lightdm and lightdm-greeter and delete his directories (I discovered that are reported in /usr/lib/tmpfiles.d/lightdm.conf)


Then reboot for the umpteenth time, reinstall it again and so on: lightdm doesn’t want to autostart anymore, and I repeat: I also restored the system backup from the day before the stable update.
I also disabled the service lightdm.service: is useless, since it doesn’t autostart anymore: is a weight on the startup.

So I login from TTY, by executing startxfce4, and I had to replicate the environment variables from ~/.profile to ~/.bashrc (eg, like export QT_QPA_PLATFORMTHEME="qt5ct");
This because seems that by starting the graphical environment from startxfce4 doesn’t source ~/.profile: I verified this by doing echo $QT_QPA_PLATFORMTHEME: resulted in an emtpy output, is ok instead by having the env variables in ~/.bashrc.

still in ~/.bashrc, I made an alias to quickly execute startxfce4:
alias sd="startxfce4" (sd stands for Start Desktop).

lxdm, the alternative for lightdm, works fine, but is not customizable like lightdm, and furthermore, the system’s mouse theme is not applyed by lxdm.

Hm, shouldn’t be a thing depending on your hardware. Maybe try a newer LTS Kernel 5.4 or 5.10

$ sudo mhwd-kernel -i linux54
$ sudo mhwd-kernel -i linux510

I have no issues with this on my old Lenovo ThinkPad 60.

1 Like

I already tried newer kernels, without success.

Other solutions are:

1 Like

I already had, since months, i915 in mkinitcpio, as well I also tried logind-check-graphical=true in /etc/lightdm/lightdm.conf.

As you seem to be the only one having this issue, moved that conversation into the original topic until we have a solution / workaround after which we can update the wiki…


I am also experiencing the same issue. My CPU is Ryzen 3 3200G, mobo Asus TUF Gaming x570-Plus, running kernel 5.14.10-1, and Cinnamon 5.0.5 DE. I opened the file mkinitcpio as root and there is no MODULES section, see content:

# mkinitcpio preset file for the 'linux514' package


PRESETS=('default' 'fallback')


fallback_options="-S autodetect"

Editing the /etc/lightdm/lightdm.conf by replacing false by true did not work.
I can only access the desktop by launching “startx” in tty.
Thanks for any help.

You’re supposed to add it, but that looks like the wrong file. What’s it’s full pathname?


Full path name: /etc/mkinitcpio.d/linux514.preset
Hope this helps.

1 Like

Wrong file.

Please start reading from here as @pheiduck already mentioned


I spent a great part of the morning reading that page several times before posting. Sorry but this is all way above my understanding. I stick to startx.

OK, seems like you overlooked something simple:

For example to enable early KMS for the Intel graphics driver:
MODULES=(... i915 ...)

(Emphasis mine…)

:stuck_out_tongue_winking_eye: :grin:

Furthermore also @Aragorn explained to you what you have to do:

But you’ll have to add amd instead of i915:


However I repeat that in my case this doesn’t help with lightdm.service’s problem.

1 Like

Thank you so much for replying. In a terminal I did sudo pacman -S mkinitcpio and it simply re-installed the file. So it is properly installed somewhere but I do not know where exactly. The second issue is how and where do I add the text MODULES=(amd)? Again, thanks a lot. :slightly_smiling_face:

sudo nano /etc/mkinitcpio.conf

add to the Modules section and save as the above poster suggested.