Optimus manager doesn't work after upgrade

while here you see no answers, you can also go to https://aur.archlinux.org/ find your package there, read comments, leave your comments there, subscribe to updates.

Also consider to check the [HowTo] Increase your chances of solving your issue

Worked for me with the v.1.4.3 re-build (the version in the repos), but it’s gone now, ok :grinning_face_with_smiling_eyes:

optimus-manager works perfectly. I had problems after the last update (2016-12-16) and it stopped working, but I did the following:

  1. I have made the necessary changes related to Python 3.10, as described here:
  2. Then I installed and configured optimus-manager 1.4.3 from AUR.
    The video switches to Nvidia when the laptop is plugged in and to Intel when it is on battery. It works without a problem with a second monitor, as it was before update.

i just installed optimus manager from the AUR but it still doesn’t work.
is it ok to upgrade python to 3.10 while Manjaro is on 3.9?


Because OM is and will probably always be buggy.

I think there’s something else here, optimus-manager 1.4-3 should not have been pushed to Stable (maybe it was by mistake?) when only 2 days ago we found in the testing branch that it should be rebuild vs. python 3.10 to work correctly and when we knew that this time

1 Like

I use Manjaro mainly for the Optimus Manager. Because OM is and will probably always be buggy sounds to me now as if I had bet on the wrong horse with Manjaro.

No … nothing to do with ‘compatibility’ … more just the nature of the thing itself.
I think its a solution to a problem that doesnt exist, and its implemented poorly.

Thanks @CyberNoob , rollback worked for me.
I think it is the safest way to rollback and wait for a bug free release

Package used: optimus-manager-git

1 Like

I have a Thinkpad X1 Extreme and the connectors for external screens are hardwired to the Nvidia GPU. The only way I can use an external screen with the laptop screen turned off is to use Nvidia’s proprietary drivers in combination with optimus-manager. Couldn’t get it to work with Nouveau drivers or without optimus-manager – it’s either not working at all or the frame rate drops to 1 frame in 10 seconds. Looked it up online and the suggested fix was to use optimus-manager.

Will investigate if there is a better solution by now. Would be more than happy to drop it, especially now that I have to get it from the AUR.

This works with the 2022-01-02 update. Simply use optimus-manager-git 1.4-1 from the AUR.

I hope 1.4-3 gets updated with Python 3.10.


I have a laptop that is not operating after the update.
How can I work with that now? What is the solution?

Define not operating?

Here: another topic
I got the solution.

it works now after the Python 3.10 update.
either follow the instructions on the update thread or uninstall OM and reinstall it.

Hello Friends, I’m experiencing issues with optimus-manager myself.

It seems the package is no longer being maintained in the official repositories pacman -S return invalid package name.

I’ll try the package from AUR.

What’s the reason pushing it into AUR instead of releasing on official repos?

1 Like

I must admit that I also had a problem after the manjaro update, but it was because I updated the kernel to version 5.15 and at that moment my “optimus-manager” stopped working, I solved it by changing the kernel to “LTS” 5.10

Thanks for the highlight.
For the record the AUR package is working, uninstalling the ex-official package and installing it (AUR) worked.
That said I’m kinda baffled that a project as big as Manjaro doesn’t have the resources to test this packages. I mean pretty much all laptops have hybrid GPU solutions, no? (considering NVIDIA still dominates on laptop market)