Optimus manager doesn't work after upgrade

so what should i do now?:
remove the one i have and install it from the AUR?

Hello, I temporary fix it doing a rollback (downgrade) from 1.4-3 to 1.4-1, I exec this command:

sudo pacman -U /var/cache/pacman/pkg/optimus-manager-1.4-1-any.pkg.tar.zst

And now I have my two monitor working fine :D. I think this solution work temporary while Manjaro Team fix package.

$optimus-manager --status                                                                                                                                                                                       

Optimus Manager (Client) version 1.4

Current GPU mode : nvidia
GPU mode requested for next login : no change
GPU at startup : nvidia
Temporary config path: no
$sudo pacman -Ss optimus-manager                                                                                                                                                                                

[sudo] password for cybernoob: 
community/optimus-manager 1.4-3 [installed: 1.4-1]
    Management utility to handle GPU switching for Optimus laptops
$systemctl status optimus-manager
● optimus-manager.service - Optimus Manager Commands Daemon
     Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-12-18 15:56:34 -03; 6min ago
    Process: 591 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_daemon_start (code=exited, status=0/SUCCESS)
    Process: 692 ExecStartPre=/usr/bin/python3 -u -m optimus_manager.hooks.pre_xorg_start (code=exited, status=0/SUCCESS)
   Main PID: 1255 (python3)
      Tasks: 1 (limit: 18496)
     Memory: 62.3M
        CPU: 2.197s
     CGroup: /system.slice/optimus-manager.service
             └─1255 /usr/bin/python3 -u -m optimus_manager.daemon

dic 18 15:56:32 tesla python3[692]: [738] INFO: switching=none, nothing to do
dic 18 15:56:32 tesla python3[692]: [786] INFO: Loading module nvidia
dic 18 15:56:32 tesla python3[692]: [1073] INFO: Loading module nvidia_drm
dic 18 15:56:34 tesla python3[692]: [2852] INFO: Writing to /etc/X11/xorg.conf.d/10-optimus-manager.conf
dic 18 15:56:34 tesla python3[692]: [2852] INFO: Writing state {'type': 'pending_post_xorg_start', 'switch_id': '20211218T155631', 'requested_mode': 'nvidia'}
dic 18 15:56:34 tesla python3[692]: [2852] INFO: Xorg pre-start hook completed successfully.
dic 18 15:56:34 tesla systemd[1]: Started Optimus Manager Commands Daemon.
dic 18 15:56:34 tesla python3[1255]: [1] INFO: # Commands daemon
dic 18 15:56:34 tesla python3[1255]: [1] INFO: Opening UNIX socket
dic 18 15:56:34 tesla python3[1255]: [1] INFO: Awaiting commands

I expect this can help you.

Best Regards.

i was finally able to atleast install optimus-manager 1.4.3 from aur and went past the black screen that i was getting for days but now i am not able to enable the optimus-manager.service.

please help

while here you see no answers, you can also go to https://aur.archlinux.org/ find your package there, read comments, leave your comments there, subscribe to updates.

Also consider to check the [HowTo] Increase your chances of solving your issue

Worked for me with the v.1.4.3 re-build (the version in the repos), but it’s gone now, ok :grinning_face_with_smiling_eyes:

optimus-manager works perfectly. I had problems after the last update (2016-12-16) and it stopped working, but I did the following:

  1. I have made the necessary changes related to Python 3.10, as described here:
  2. Then I installed and configured optimus-manager 1.4.3 from AUR.
    The video switches to Nvidia when the laptop is plugged in and to Intel when it is on battery. It works without a problem with a second monitor, as it was before update.

i just installed optimus manager from the AUR but it still doesn’t work.
is it ok to upgrade python to 3.10 while Manjaro is on 3.9?


Because OM is and will probably always be buggy.

I think there’s something else here, optimus-manager 1.4-3 should not have been pushed to Stable (maybe it was by mistake?) when only 2 days ago we found in the testing branch that it should be rebuild vs. python 3.10 to work correctly and when we knew that this time

1 Like

I use Manjaro mainly for the Optimus Manager. Because OM is and will probably always be buggy sounds to me now as if I had bet on the wrong horse with Manjaro.

No … nothing to do with ‘compatibility’ … more just the nature of the thing itself.
I think its a solution to a problem that doesnt exist, and its implemented poorly.

Thanks @CyberNoob , rollback worked for me.
I think it is the safest way to rollback and wait for a bug free release

Package used: optimus-manager-git

1 Like

I have a Thinkpad X1 Extreme and the connectors for external screens are hardwired to the Nvidia GPU. The only way I can use an external screen with the laptop screen turned off is to use Nvidia’s proprietary drivers in combination with optimus-manager. Couldn’t get it to work with Nouveau drivers or without optimus-manager – it’s either not working at all or the frame rate drops to 1 frame in 10 seconds. Looked it up online and the suggested fix was to use optimus-manager.

Will investigate if there is a better solution by now. Would be more than happy to drop it, especially now that I have to get it from the AUR.

This works with the 2022-01-02 update. Simply use optimus-manager-git 1.4-1 from the AUR.

I hope 1.4-3 gets updated with Python 3.10.


I have a laptop that is not operating after the update.
How can I work with that now? What is the solution?

Define not operating?

Here: another topic
I got the solution.

it works now after the Python 3.10 update.
either follow the instructions on the update thread or uninstall OM and reinstall it.

Hello Friends, I’m experiencing issues with optimus-manager myself.

It seems the package is no longer being maintained in the official repositories pacman -S return invalid package name.

I’ll try the package from AUR.

What’s the reason pushing it into AUR instead of releasing on official repos?

1 Like