[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice

Just a minor issue with Gnome extension Dash to Dock:
When I switch off the button “Angepasstes Thema dieser Erweiterung nutzen”, all icons in the dock are gone. The dock is empty no matter what options I set in the area below that button.

1 Like

I am still experiecing this problem with the screen set to blank out but after attempting to wake up the screen, I just get a blank screen until I type my password and the login prompt appears so I have to login again.

I changed light-locker to dm-tool to unlock it and I still encounter the same issue with this update. I think its similar to this:

Thanks its worked (:slight_smile:

This is little info to offer any help, could you make a new post in #support , keeping in mind these two post below on how to provide system information and increase the chances to solve the issue you are experiencing.

If the info in your profile is still correct please upgrade to a supported version of the kernel, 5.9 is no longer maintained.

Bluetooth has stopped working on Manjaro Gnome after this update. Running on a ThinkPad T14s Intel model. The Gnome Bluetooth settings panel shows Bluetooth as being turned off and I’m unable to move the toggle switch in the settings panel to the “on” position.

UPDATE:

I was able to (partially) resolve the issue. It is, perhaps, related to this issue reported as an upstream bug on the Ubuntu ticketing system. At any rate, the kludge discussed by this commenter there worked for me: Rebooting the laptop while plugged into power, opening the Gnome Bluetooth settings panel, disconnecting the power, and then toggling on Bluetooth in the settings panel. This is obviously not ideal, especially if the issue recurs, so I look forward to some kind of better resolution down the line.

1 Like

@thewhat Possibly a more permanent fix: it looks as though my default application for html/text files somehow ended up as winebrowser. Definitely not a choice I made so I’m not sure how it got set that way, but System Settings > Applications > text > html and then move winebrowser below Firefox or your default browser of choice.

3 Likes

yeah i remove it from there. i think its a problem happend in env paths bcz i already installed wine

Update to my own post:
the problem is the option Enable Unity7 like glossy backlit items under Customize windows counter indicators. When this option is set to on, the items in the dash have a glossy background. But when the extension is switched off and on again, the items in the dock are gone.

I verified it with another laptop that was not updated yet: this behaviour has not changed in the last update!

Sorry for any inconvenience

1 Like

Problems in computers with opensource video drivers are solved like so:
sudo pacman -Rd --nodep gdm
sudo pacman -S gdm
With proprietary drivers, I have not found a solution ???

Thank you for the great work! Can you please add a status flag to each issue? It may help users to know if any particular issue concerned is resolved.

After the update, optimus-manager (v 1.4-2 from official repository) completely stop working.

Error loading config file : Cannot find header for section [optimus]

I install the aur version (v 1.4-3) and it’s solves the problem.

yay -Sa optimus-manager

(Don’t forget the “a” or yay will install the old v 1.4-2 from official repository,
and I think it was python 3.9 to python 3.10 who break optimus manager.)

Otherwise everything else work fine. Thanks for all the updates :heart: !

4 Likes

Fix coming with 1.4-3 soon.

1 Like

I had this warning:

Installing graphviz (2.50.0-1)...                                        [53/81]
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.

ldd /usr/lib/graphviz/libgvplugin_gdk.so.6 said that libgdk-x11-2.0.so.0 was missing.
pamac search libgdk-x11 said it belongs in package gtk2.

I have no recollection of removing gtk2, but maybe it was removed as an orphan at some time.
Nevermind, pamac install gtk2 fixed he problem.

1 Like

not sure if its related to the update but im getting this error in virtual machine manager:

Error starting domain: internal error: qemu unexpectedly closed the monitor: 2021-12-17T21:12:09.862776Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.863790Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864289Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864664Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
qxl_send_events: spice-server bug: guest stopped, ignoring
kvm_set_irq: Input/output error

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 101, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 1329, in startup
    self._backend.create()
  File "/usr/lib/python3.9/site-packages/libvirt.py", line 1353, in create
    raise libvirtError('virDomainCreate() failed')
libvirt.libvirtError: internal error: qemu unexpectedly closed the monitor: 2021-12-17T21:12:09.862776Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.863790Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864289Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864664Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
qxl_send_events: spice-server bug: guest stopped, ignoring
kvm_set_irq: Input/output error

A post was split to a new topic: After latest stable update my computer won’t boot

Thank you for the comments. I’ll keep it in mind next time. It seems like it works after I re-installed pulse.

Hello Yochanan,

I updated to 1.4-3, but I still got the error on optimus-manager.

dic 18 00:22:35 tesla systemd[1]: Starting Optimus Manager Commands Daemon...
dic 18 00:22:35 tesla python3[609]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla python3[671]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: Started Optimus Manager Commands Daemon.
dic 18 00:22:35 tesla python3[718]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Main process exited, code=exited, status=1/FAILURE
dic 18 00:22:35 tesla python3[762]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Control process exited, code=exited, status=1/FAILURE
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Failed with result 'exit-code'.

My package is from official repository:

community/optimus-manager 1.4-3 [installed]
    Management utility to handle GPU switching for Optimus laptops

Is it necessary reinstall package??

Thanks for your help.

1 Like

After this update I cannot longer launch my application by hitting Super+1,Super+2,… Any suggestions how to fix it? It breaks my whole workflow.

3 Likes

My screen flashes consistently with Finished TLP startup/shutdown but never boots to the login screen before my XFCE desktop.

Unsure if this is caused by optimus-manager since I have it configured to use the GTX 1650 GPU automatically.

SOLVED: rebuilt optimus-manager from AUR

After I updated, now after suspend, the system does not recover, instead a black screen, it seems to me this is due to the fact that I have a fermi video card (390xx driver)

1 Like