[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice

Everything went well, except the Manjaro logo of Whisker which disappeared replaced by that of Xfce, and the favorites to replace they had returned as during a new installation.
Once everything is replaced as before, it’s ok.

if i open news it copy a file and show wine icon

I am using a “Roccat Ryos MK Pro” on Kernel "5.15.7-1, so it is not a common brand issue. As a sidenote, i have also installed roccat-tools-ryosmk roccat-tools-common from the AUR (off course there is one for “-iskufx” too). I wonder what has changed in the new Kernel version, that your keyboard seemingly worked with the change. Did you have any of the drivers from AUR installed? Did your keyboard worked before and stopped working with the update?

Nice, finally a kernal update that gets off 5.13. First thing I always did under a new manjaro install was go to 515 cause there were critical things broken out of the box in 513.

You can configure it to meet your preferences: [Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird - #86 by alven
or switch command interpreter back to bash in user profile settings of terminal emulator.

Well i have configured it with powerlevel10k which shows additional symbols for e.g. home directory or an hourglass after the time it took to execute the command. Worked fine till the last update. Now these symbols are missing and only a generic replacement character is shown. I thought perhaps powerline fonts have been uninstalled but that seems not to be the case.

EDIT: OK i solved it … i had to use my own profile as breath profile is not writable, set the shell to zsh and the font to MesloLGS NF 10 Regular. Now the symbols are shown again:

I tied this earlier but i did not realize that the font was not saved in breath profile.


Yeah it stopped working with the update. I checked out the installed roccat packages: roccat-tools-common, roccat-tools-iskufx, roccat-tools-isku, kmod-roccat as AUR. I now removed komd-roccat as it seemed not necessary. I also reinstalled the 5.15.7-1 Kernel. Now 5.15.7-1 works fine again. Weird :slight_smile:

Yeah… I have that problem too, some icons in Pamac suddenly become too small…

kmod-roccat is a Kernel module for the old kone ROCCAT. Also have a look if you really need roccat-tools-isku, as you have “iskufx” already installed. For me it never stopped working, that is why I guess there was a conflict with a driver for a hardware you don’t have installed.

To be honest I’m no expert in linux sound configurations, the possibilities seem endless; recent code commits and configuration changes within sof etc. I suppose updating to latest and reverting all the alsa packages to their predecessors might seem a reasonable start.

A post was split to a new topic: Update hung installing updates

the 12-16 update does not solve my problem posted here

Fn F8 -F9 does not dim or increase brightness in my Samsung Amoled Display, sound control and keyboard backlit both they works (Tnx to tuxedo-keyboard) it seems I’m back to kernel 5.10 where the control was not functioning. Kernels 5.11 to 5.13 managed controls perfectly

After the update I have a degraded stability of the system. Sound stops a few minutes after system launch. Sound menu shows no sound input or output devices. Apps that related to sound hang. Firefox randomly hangs.

Dell XPS13

just updated in the morning everything is fine. try reloading your .zshrc or switch to nerd font

I wonder if we should report this elsewhere, an upstream repo perhaps.

Hmm do you know in which package the Hack Nerd Font is located? Seems i cannot select that … only “normal” Hack.

its in the aur

sudo pacman -S nerd-fonts-hack

1 Like

After the update, GDM stopped recognizing the Wayland session. Gnome only starts in the X session, and Weston is not visible. This effect occurred on 7 computers I service (2 nvidia-properitary driver, 3 nvidia-opensource driver and 2 amd-radeon opensource driver). Do you have any idea how to fix this more quickly?
(At tty session weston starts normally.)

1 Like

Hmm … doesn’t work well with my custom configuration but Manjaro default seems to be good now.

On my first reboot after updating WiFi was not working at all, strangely one more reboot and all started working again.

What I did noticed is that I now get a kernel fault:

 4.304771] BUG: kernel NULL pointer dereference, address: 0000000000000000
[    4.304779] #PF: supervisor instruction fetch in kernel mode
[    4.304781] #PF: error_code(0x0010) - not-present page
[    4.304784] PGD 0 P4D 0 
[    4.304788] Oops: 0010 [#1] PREEMPT SMP NOPTI
[    4.304792] CPU: 0 PID: 1268 Comm: tpacpi-bat Tainted: G           OE     5.15.7-1-MANJARO #1 89d91431fe07b9fd339e5f86d7a009210c48fcc6
[    4.304797] Hardware name: LENOVO 20Y7CTO1WW/20Y7CTO1WW, BIOS R1OET28W (1.07 ) 07/15/2021
[    4.304799] RIP: 0010:0x0
[    4.304807] Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.
[    4.304808] RSP: 0018:ffffbb0a898e3e68 EFLAGS: 00010246
[    4.304811] RAX: 0000000000000000 RBX: ffffa03fc82c2900 RCX: 0000000000000001
[    4.304814] RDX: 0000000000000001 RSI: 0000000000000000 RDI: ffffa03fc37eda00
[    4.304816] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
[    4.304817] R10: 0000000000000001 R11: 0000000000000000 R12: 0000000000000001
[    4.304819] R13: ffffffffffffffea R14: ffffa03fc37eda00 R15: 0000000000000000
[    4.304821] FS:  00007fe9334ab740(0000) GS:ffffa04496e00000(0000) knlGS:0000000000000000
[    4.304824] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    4.304827] CR2: ffffffffffffffd6 CR3: 000000012439a000 CR4: 0000000000350ef0
[    4.304829] Call Trace:
[    4.304832]  <TASK>
[    4.304834]  proc_reg_llseek+0x49/0x90
[    4.304841]  ? __fdget_pos+0x13/0x60
[    4.304845]  ksys_lseek+0x83/0xc0
[    4.304849]  do_syscall_64+0x5c/0x90
[    4.304854]  ? do_user_addr_fault+0x20b/0x6b0
[    4.304861]  ? exc_page_fault+0x72/0x180
[    4.304865]  entry_SYSCALL_64_after_hwframe+0x44/0xae
[    4.304870] RIP: 0033:0x7fe93374299b
[    4.304873] Code: ff ff c3 0f 1f 40 00 48 8b 15 d1 04 0d 00 f7 d8 64 89 02 48 c7 c0 ff ff ff ff eb ba 0f 1f 00 f3 0f 1e fa b8 08 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 05 c3 0f 1f 40 00 48 8b 15 a1 04 0d 00 f7 d8
[    4.304875] RSP: 002b:00007ffc6602d1d8 EFLAGS: 00000246 ORIG_RAX: 0000000000000008
[    4.304879] RAX: ffffffffffffffda RBX: 00007fe933bc7de0 RCX: 00007fe93374299b
[    4.304881] RDX: 0000000000000001 RSI: 0000000000000000 RDI: 0000000000000003
[    4.304882] RBP: 000055edcd378d70 R08: 00007ffc6602d180 R09: 00000000ffffffff
[    4.304884] R10: 00007fe933813a00 R11: 0000000000000246 R12: 000055edcd3572a0
[    4.304886] R13: 00007ffc6602d3e0 R14: 000055edcd3573e0 R15: 000055edcd42e440
[    4.304890]  </TASK>
[    4.304892] Modules linked in: xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrtype iptable_filter iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c br_netfilter cmac algif_hash algif_skcipher af_alg bridge stp llc bnep overlay btusb uvcvideo btrtl btbcm videobuf2_vmalloc btintel videobuf2_memops videobuf2_v4l2 bluetooth videobuf2_common videodev mc ecdh_generic joydev mousedev intel_rapl_msr intel_rapl_common think_lmi wmi_bmof firmware_attributes_class edac_mce_amd qrtr ns snd_ctl_led kvm_amd mt7921e amdgpu snd_hda_codec_realtek mt76_connac_lib kvm snd_hda_codec_generic snd_hda_codec_hdmi mt76 snd_hda_intel irqbypass snd_intel_dspcfg crct10dif_pclmul crc32_pclmul mac80211 snd_intel_sdw_acpi ghash_clmulni_intel snd_hda_codec r8169 aesni_intel libarc4 snd_hda_core vfat crypto_simd thinkpad_acpi fat realtek cryptd snd_pci_acp5x snd_hwdep rapl gpu_sched ledtrig_audio ucsi_acpi mdio_devres cfg80211 psmouse pcspkr tpm_crb snd_pcm sp5100_tco
[    4.304965]  platform_profile drm_ttm_helper snd_rn_pci_acp3x typec_ucsi snd_timer ccp libphy snd_pci_acp3x typec snd rfkill ttm k10temp i2c_piix4 roles wmi soundcore tpm_tis tpm_tis_core video tpm pinctrl_amd mac_hid acpi_cpufreq i2c_scmi rng_core squashfs acpi_call(OE) loop ipmi_devintf ipmi_msghandler crypto_user fuse ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 serio_raw atkbd libps2 i8042 crc32c_intel xhci_pci serio
[    4.305006] CR2: 0000000000000000
[    4.305009] ---[ end trace 62691aa760c569a7 ]---
[    4.305011] RIP: 0010:0x0
[    4.305014] Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.
[    4.305015] RSP: 0018:ffffbb0a898e3e68 EFLAGS: 00010246
[    4.305018] RAX: 0000000000000000 RBX: ffffa03fc82c2900 RCX: 0000000000000001
[    4.305020] RDX: 0000000000000001 RSI: 0000000000000000 RDI: ffffa03fc37eda00
[    4.305022] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
[    4.305024] R10: 0000000000000001 R11: 0000000000000000 R12: 0000000000000001
[    4.305025] R13: ffffffffffffffea R14: ffffa03fc37eda00 R15: 0000000000000000
[    4.305027] FS:  00007fe9334ab740(0000) GS:ffffa04496e00000(0000) knlGS:0000000000000000
[    4.305030] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    4.305032] CR2: ffffffffffffffd6 CR3: 000000012439a000 CR4: 0000000000350ef0