[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

@philm could this be added to the open issues, please?
Also, is this worked on? How can it be that a “stable” release breaks a core component of the os and there are zero replies by the maintainers?

What is it about? Don’t know what you’re talking about? Nvidia?

it seems that as described above (and here) a rotated secondary monitor no longer allows logging in.
Creating a new user without any saved rotation works, but when setting the “correct” rotation one gets thrown back to the login screen.
It somewhat seems x-server related.
Thanks for looking into the issue!

1 Like

I also requested that this was added to New Issues earlier.


and done.

Sorry it took so long. Just a reminder for all eligible users (tl1 and up?): the wiki post can be edited.

1 Like

No, I didn’t. I had decided to stick to Recommended and LTS.

5.15 might just do the trick. Might install it before the next update.

Unless somebody advises against a noob using the 5.15, e. g. due to some stability issues?

5.15 is the new LTS… but it is still pretty new. All-in-all it has been quite good for me, just one issue being worked through that seems to have a workaround by not using hardware acceleration in VLC (and some suggested even in Firefox).

1 Like

A post was split to a new topic: Trouble booting

6 posts were merged into an existing topic: Sudden crash&reboot with 5.10; with 5.4 not crash, but no graphic

En, have some issue with vmmouse, apparently. And the virtual machine cannot start Xorg.server anymore. When using VPN, I can only see a black screen with a cursor on left top. Not sure can I just remove the vmmouse from my xorg.config.d?

I have a fresh installation with Manjaro 21.1.6 fresh installed Xfce, knernel 5.13.x As long as I updated it after install, Xorg failed to start.

End of my Xorg.0.log : The whole log file

[    10.063] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event3)
[    10.063] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
[    10.063] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
[    10.063] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "vmmouse"
[    10.063] (II) LoadModule: "vmmouse"
[    10.063] (II) Loading /usr/lib/xorg/modules/input/vmmouse_drv.so
[    10.063] (II) Module vmmouse: vendor="X.Org Foundation"
[    10.063] 	compiled for 1.20.8, module version = 13.1.0
[    10.063] 	Module class: X.Org XInput Driver
[    10.063] 	ABI class: X.Org XInput driver, version 24.1
[    10.063] (II) VMWARE(0): VMMOUSE module was loaded
[    10.063] (II) Using input driver 'vmmouse' for 'ImExPS/2 Generic Explorer Mouse'
[    10.063] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[    10.063] (EE) 
[    10.063] (EE) Backtrace:

Core Dump from journalctl:

Dec 06 08:08:14 ManjaroDev2 systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Dec 06 08:08:14 ManjaroDev2 systemd[1]: lightdm.service: Failed with result 'exit-code'.
Dec 06 08:08:14 ManjaroDev2 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib/>
Dec 06 08:08:14 ManjaroDev2 audit: BPF prog-id=33 op=UNLOAD
Dec 06 08:08:14 ManjaroDev2 audit: BPF prog-id=32 op=UNLOAD
Dec 06 08:08:14 ManjaroDev2 audit: BPF prog-id=31 op=UNLOAD
Dec 06 08:08:14 ManjaroDev2 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 3.
Dec 06 08:08:14 ManjaroDev2 systemd[1]: Stopped Light Display Manager.
Dec 06 08:08:14 ManjaroDev2 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib>
Dec 06 08:08:14 ManjaroDev2 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib/>
Dec 06 08:08:14 ManjaroDev2 systemd[1]: Starting Light Display Manager...
Dec 06 08:08:14 ManjaroDev2 systemd[1]: Started Light Display Manager.
Dec 06 08:08:14 ManjaroDev2 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib>
Dec 06 08:08:15 ManjaroDev2 audit[756]: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 pid=756 comm="Xorg" exe="/usr/lib/Xorg" sig=11 >
Dec 06 08:08:15 ManjaroDev2 audit: BPF prog-id=34 op=LOAD
Dec 06 08:08:15 ManjaroDev2 audit: BPF prog-id=35 op=LOAD
Dec 06 08:08:15 ManjaroDev2 audit: BPF prog-id=36 op=LOAD
Dec 06 08:08:15 ManjaroDev2 systemd[1]: Started Process Core Dump (PID 776/UID 0).
Dec 06 08:08:15 ManjaroDev2 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@6-776-0 comm="syste>
Dec 06 08:08:15 ManjaroDev2 systemd-coredump[777]: [🡕] Process 756 (Xorg) of user 0 dumped core.
                                                   Found module linux-vdso.so.1 with build-id: 21dd0b95b6d40459fda840e512d3ee4b5e26d389
                                                   Found module vmmouse_drv.so with build-id: e636f276063a5298a37b4e6c7a7badb7c58a01a9
                                                   Found module libgobject-2.0.so.0 with build-id: 3e451709a0a5772b9550d3a4c28dcb37a87028fa
                                                   Found module libgudev-1.0.so.0 with build-id: a9f734ea9206d637d5aacfbd86298c91cdc1a33a
                                                   Found module libwacom.so.2 with build-id: 1d9b89a6d39be5568d5f44888b8a74f46a30c152
                                                   Found module libevdev.so.2 with build-id: b62ae69f839f1b6b06ef2c1df19f25ff09b0d824
                                                   Found module libmtdev.so.1 with build-id: 0cea2a842ae9a0ef02a08477076caab0e5ac5e42
                                                   Found module libinput.so.10 with build-id: 77f3eca5dddc8cac29b71bc5041a79ce57fceb56
                                                   Found module libinput_drv.so with build-id: d9f69f11259485316bd206e67e34dd23bbede5cc
                                                   Found module libvulkan.so.1 with build-id: 07b49771f04f350af7587839fcec8b52fa4f3164
                                                   Found module libdrm_nouveau.so.2 with build-id: 8fc69302331a748147c45364774cb3da9b5994c0
                                                   Found module libdrm_amdgpu.so.1 with build-id: 587ec7f42cd8e6298ef2bf769df3a9417be90103
                                                   Found module libelf.so.1 with build-id: cc912d9cef94d907317afba5edd9176e9828e776
                                                   Found module libdrm_radeon.so.1 with build-id: d3d24f3707416f7c3cef6fd731f732c0b984dd1d
                                                   Found module libsensors.so.5 with build-id: dc8b2c1c0d8525411aca188ea3cc3fb86d381d30
                                                   Found module virtio_gpu_dri.so with build-id: 485271131aae5a573f803418b6bbb1f58d034acb
                                                   Found module libnss_files.so.2 with build-id: 1a36dfc01d3a1010b2ee79766a24a8090a3266d5
                                                   Found module libxcb-sync.so.1 with build-id: dda14591103b01b1311906053bf1ca9e82ade35c
                                                   Found module libxcb-present.so.0 with build-id: 68f5465258750e2397b1333b3ffc01ee33caa4e1
                                                   Found module libxcb-dri3.so.0 with build-id: 9407a2480e09dc5a1dd9d9a0652fa8d32b328c91
                                                   Found module libwayland-client.so.0 with build-id: d274361e7aa57c9b63504a039e063322450cbb9c
                                                   Found module libxcb-xfixes.so.0 with build-id: a6b197ace5b9b59f913f5969eb419a88d1194f47
                                                   Found module libxcb-dri2.so.0 with build-id: 2dd6e65129a809dab828a1d26215a3f7a363fcc8
                                                   Found module libX11-xcb.so.1 with build-id: 0db4f94d8ae31b8dc9a83f825a9171656f1e532c
                                                   Found module libEGL_mesa.so.0 with build-id: fb943970628f1b739095eb6e3a22e90b402ecd0a
                                                   Found module libEGL.so.1 with build-id: 473944aea0e3dbc5d595dee647702a3cdc0aed78
                                                   Found module libicudata.so.69 with build-id: 0ab994a49ef1848499c4af333b3266f28432a922
                                                   Found module libicuuc.so.69 with build-id: 5cf18c56e2f64efdac32cf61fb9c0c48e9bb1797
                                                   Found module libxml2.so.2 with build-id: b9441ffabb52b50c290152592f17cd78a381d493
                                                   Found module libncursesw.so.6 with build-id: 859adb8b03a5655151b4da104bc4b326a0d4bc8c
                                                   Found module libedit.so.0 with build-id: 4b0babfcad161c2ad0af6e59e2493258db23a331
                                                   Found module libstdc++.so.6 with build-id: 8ab0e57054dd1dcba681f217016afc6a4e639783
                                                   Found module libLLVM-13.so with build-id: 82982c299d46219d0eab8ee9cb8bb7365483453b
                                                   Found module libglapi.so.0 with build-id: 57828fb70af7c1f2aa70b096d748851a1fd39a9c
                                                   Found module libepoxy.so.0 with build-id: b6357fc6b748c512f90339433d74502b9d0621dc
                                                   Found module libglamoregl.so with build-id: f11fbd5dd1b833fee0692e2424a46c3c4b0b3047
                                                   Found module libffi.so.8 with build-id: f90d8b734f6de9b25faedb8cbfab7054dafc0a42
                                                   Found module libexpat.so.1 with build-id: 8850138eae6d9d4d43c5c4b2ac48393bc4279037
                                                   Found module libwayland-server.so.0 with build-id: 7156897eafc4b7562f2b214e6ad8ca6c85c57e47
                                                   Found module libgbm.so.1 with build-id: 42e129ba16de8ff426f740e7686a1f02a738abf9
                                                   Found module modesetting_drv.so with build-id: c766a023325f305cb19f2f5e6c2686f6fbe47a43
                                                   Found module libxcb.so.1 with build-id: 0d1ef11740a5daad2ee331e812a51aa6574af222
                                                   Found module libX11.so.6 with build-id: e9192497aa39fab51358826d1a1b5fb77edc5081
                                                   Found module libGLX.so.0 with build-id: 0f40ceaa036edc65147e9559b94e0219472493fc
                                                   Found module libGLdispatch.so.0 with build-id: 195b34c1bb271f3b1162c897cfbcfb859e656b93
                                                   Found module libGL.so.1 with build-id: 8b3028bab286029945569a0dfcf695f0f61d9c3b
                                                   Found module libglx.so with build-id: ae4b78d320f5ba64ca20762a238c4f4efebe4e61
                                                   Found module libpcre.so.1 with build-id: 845483dd0acba86de9f0313102bebbaf3ce52767
                                                   Found module libbrotlicommon.so.1 with build-id: f68934f94312f770550ebc6c5acfd6359b098b07
                                                   Found module libglib-2.0.so.0 with build-id: d4aa102e545015a506c3ee06398676b70f65bcbc
                                                   Found module libgraphite2.so.3 with build-id: 47761dc11e553f519cde97ed9ee985be12ccdae2
                                                   Found module libresolv.so.2 with build-id: c915c72668282861a813f7ea3c0780f37b681dc0
                                                   Found module libkeyutils.so.1 with build-id: ac405ddd17be10ce538da3211415ee50c8f8df79
                                                   Found module libkrb5support.so.0 with build-id: adf65240a4d2aba772d7a0772b4d015469934113
                                                   Found module libcom_err.so.2 with build-id: eb61ef71c8b97846db759fb89a115405cff6dd30
                                                   Found module libk5crypto.so.3 with build-id: eb8220b8f36675aac769450be4cb6bb7f97ec38a
                                                   Found module libkrb5.so.3 with build-id: 72d26767c5cb1097db75a5f5bff88860233c902b
                                                   Found module libgpg-error.so.0 with build-id: 3801187d42c4955bd93c605451430cdf1b164e63
                                                   Found module libbrotlidec.so.1 with build-id: f871e6f204ab8d48099915126ba01be989a8000f
                                                   Found module libharfbuzz.so.0 with build-id: f3507938a0d15efd3c81f0f9f1dd98cfdaf2144f
                                                   Found module libpng16.so.16 with build-id: 2dc0bce07f199bf983c07a05fb95a6f4af83a9b3
                                                   Found module libbz2.so.1.0 with build-id: 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
                                                   Found module libgssapi_krb5.so.2 with build-id: e6e098ad51ce7bdd3dbe902d7b0f69a90f8a9e08
                                                   Found module libgcc_s.so.1 with build-id: 7f8508bb914546ada778809b64b99d234337d835
                                                   Found module libgcrypt.so.20 with build-id: db45f5d5e0f7af1e77324fea1885f974619ad268
                                                   Found module libcap.so.2 with build-id: f028e24efdfb362a37fa8dd280c3894b007f88b1
                                                   Found module liblz4.so.1 with build-id: e63600ab23b2f6997f42fac2fa56e1f02ce159a1
                                                   Found module libzstd.so.1 with build-id: 4b10444c1560ebc574af4d5f488b7408b22d450e
                                                   Found module liblzma.so.5 with build-id: 8b615460aa230708c5183f16bede67aa0437d95e
                                                   Found module librt.so.1 with build-id: 75484da2d6f1515189eefa076e0a40328834cd16
                                                   Found module libfreetype.so.6 with build-id: 65e7f4a1e5557b0ceeaa433e5356f857fe9c669b
                                                   Found module libfontenc.so.1 with build-id: 5a11f1fb8c3f2714be9eb6697318f20e301e1d2f
                                                   Found module libz.so.1 with build-id: 81bf6e728a6d6f5b105b0f8b25f6c614ce10452a
                                                   Found module ld-linux-x86-64.so.2 with build-id: 040cc3dd10461562f177df39e3be2f3704258c3c
                                                   Found module libc.so.6 with build-id: 4b406737057708c0e4c642345a703c47a61c73dc
                                                   Found module libxcvt.so.0 with build-id: 30bad674c8227152bb709556a3657d0258554309
                                                   Found module libpthread.so.0 with build-id: 07c8f95b4f3251d08550217ad8a1f31066229996
                                                   Found module libtirpc.so.3 with build-id: 5bef2adfdee3df283f593b3e2d37b6dac405256a
                                                   Found module libdrm.so.2 with build-id: 8585630908d716a9ebf17abe665324984d15aa13
                                                   Found module libudev.so.1 with build-id: 258fe43468efcef8308a84d3e11f4ff9eac6cdbe
                                                   Found module libdbus-1.so.3 with build-id: e937e5ef5cc9606af5f5f5bae96be6314828d1de
                                                   Found module libsystemd.so.0 with build-id: 0fe75afcfd652b9dcee054aa5ae8588ec8a3107c
                                                   Found module libxshmfence.so.1 with build-id: 8876d9ccf620858795724ca24b9e567585a77cec
                                                   Found module libXfont2.so.2 with build-id: 154202dd7ddb86f6ae4d3bc762dfd8570b86882a
                                                   Found module libXdmcp.so.6 with build-id: 8ca0792d23c8b8b4c0864297512349292bea5955
                                                   Found module libXau.so.6 with build-id: 1c67764663e07bec24d8951e5fd93f4d165979ff
                                                   Found module libnettle.so.8 with build-id: 9a878e513c02007598fcf1e2e286c2203f13536e
                                                   Found module libpciaccess.so.0 with build-id: 9dd24e76ebc38465541313b36446ffb4af842c12
                                                   Found module libdl.so.2 with build-id: 5abc547e7b0949f89f3c0e21ab0c8331a7440a8a
                                                   Found module libm.so.6 with build-id: 2b8fd1f869ecab4e0b55e92f2f151897f6818acf
                                                   Found module libpixman-1.so.0 with build-id: 341f793dcada3a48a306a793d265a517e3f2e7d6
                                                   Found module Xorg with build-id: 83f949e9d0c66d61b415bfb7bfcccd3da90ac876
                                                   Stack trace of thread 756:
                                                   #0  0x00007f9e39f12f48 x86_64_fallback_frame_state (libgcc_s.so.1 + 0xff48)
                                                   #1  0x00007f9e39f14c64 _Unwind_Backtrace (libgcc_s.so.1 + 0x11c64)
                                                   #2  0x00007f9e3a3c93f6 __backtrace (libc.so.6 + 0x10b3f6)
                                                   #3  0x0000555730a69059 xorg_backtrace (Xorg + 0x150059)
                                                   #4  0x0000555730a73e79 n/a (Xorg + 0x15ae79)
                                                   #5  0x00007f9e3a4a2870 __restore_rt (libpthread.so.0 + 0x13870)
                                                   #6  0x00007f9e310c925b n/a (vmmouse_drv.so + 0x325b)
                                                   #7  0x000000000000000d n/a (n/a + 0x0)
                                                   #8  0x00000000a9b2a797 n/a (n/a + 0x0)
Dec 06 08:08:15 ManjaroDev2 systemd[1]: systemd-coredump@6-776-0.service: Deactivated successfully.

And I don’t know will delete or change the /usr/share/X11/xorg.conf.d/50-vmmouse.conf make any difference:

Section "InputClass"
	Identifier	"vmmouse"
	MatchIsPointer	"on"
	MatchTag	"vmmouse"
	Driver		"vmmouse"

Is it a Xorg issue, VMWare driver issue? What the best next action?

8 posts were split to a new topic: When will the next stable update arrive?

For reference on my system , as mentioned by other people here, upgrading to Kernel 5.15 broke suspend. When i try to resume the system just end up rebooting . Switching to 5.10 fixed the issue

System:    Host: fcx1 Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 Console: pty pts/13 Distro: Manjaro Linux
Machine:   Type: Laptop System: LENOVO product: 20KHCTO1WW v: ThinkPad X1 Carbon 6th serial: PF1LERWC
           Mobo: LENOVO model: 20KHCTO1WW v: SDK0J40697 WIN serial: L1HF91Z02GE UEFI: LENOVO v: N23ET75W (1.50 )
           date: 10/13/2020
Battery:   ID-1: BAT0 charge: 43.0 Wh (79.5%) condition: 54.1/57.0 Wh (95.0%) volts: 11.9 min: 11.6
CPU:       Info: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP cache: L2: 1024 KiB
           Speed: 799 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
           Device-3: DisplayLink MB16AC type: USB driver: N/A
           Display: server: X.org driver: loaded: i915 note: n/a (using device driver)
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.5
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Device-2: Plantronics Plantronics Blackwire 3220 Series type: USB driver: plantronics,snd-usb-audio,usbhid
           Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e
           IF: enp0s31f6 state: down mac: e8:6a:64:b1:17:09
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp2s0 state: up mac: d4:3b:04:2d:39:5d
           IF-ID-1: br-c0fcf59f56e3 state: up speed: 10000 Mbps duplex: unknown mac: 02:42:bd:45:0b:5d
           IF-ID-2: docker0 state: up speed: 10000 Mbps duplex: unknown mac: 02:42:16:64:65:00
           IF-ID-3: tailscale0 state: unknown speed: 10 Mbps duplex: full mac: N/A
           IF-ID-4: vetha5d1dc5 state: up speed: 10000 Mbps duplex: full mac: 22:7e:1b:7a:1b:9e
           IF-ID-5: vethaed8967 state: up speed: 10000 Mbps duplex: full mac: 06:47:08:e6:ae:20
           IF-ID-6: vethc024bb4 state: up speed: 10000 Mbps duplex: full mac: 36:e5:85:cf:7c:5e
Drives:    Local Storage: total: 476.94 GiB used: 75.31 GiB (15.8%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN720 SDAQNTW-512G-1001 size: 476.94 GiB
Partition: ID-1: / size: 459.72 GiB used: 75.31 GiB (16.4%) fs: btrfs dev: /dev/dm-0
           ID-2: /boot/efi size: 299.4 MiB used: 712 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           ID-3: /home size: 459.72 GiB used: 75.31 GiB (16.4%) fs: btrfs dev: /dev/dm-0
           ID-4: /var/log size: 459.72 GiB used: 75.31 GiB (16.4%) fs: btrfs dev: /dev/dm-0
Swap:      ID-1: swap-1 type: partition size: 16.91 GiB used: 0 KiB (0.0%) dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 55.0 C pch: 55.5 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 493 Uptime: 2h 0m Memory: 15.38 GiB used: 6.11 GiB (39.7%) Shell: Zsh inxi: 3.3.09

Installed the update 3 days ago. Since then i have a system freeze, when

  • user sessions in gnome are switched
  • user session logs out and another user session is logged into
  • random system freezes while browsing with firefox or desktop is idling.
  • random mouse/keyboard freeze when computer is going to sleep (that issue was already present, since i switched to AMD CPU/MB, i use caffeine to prevent this)

I tried different kernels 5.15, 5.14, 5.13 and 5.10 (recommended) same behaviour.
I’m quite unexperienced with manjaro and wasn’t able to fix it so far or find some alike issues here.
A timeshift backup back to pahvo (3/12/2021) brought it back to work for now.

see Ryzen - ArchWiki for suggestions… the core one I feel relevant for you may be adjusting “power idle control” in the BIOS

… for me, I am also thinking of applying a bit more Voltage to the CPU. The wiki suggested “Curve Optimization” +4 to 6 points, but I don’t want to enable PBO just for that… so I may try adjust Vcore or LLC (Load Line Calibration) instead… as that’s really central to my issue @ System auto-rebooted... mce: [Hardware Error] in dmesg related to CPU… but the topic where I also learned about “Power Idle Control”.

Also make sure you have an updated BIOS… one with hopefully at least AGESA (for my motherboard, BIOS’s with beta AGESA|c are available, but I generally wait for official/non-beta versions)

Click for a recanted story (in my own words) about why this happens

While searching for solutions, I read a lot of comments that “It’s rock stable on Windows, why not GNU/Linux?” And here is what some of my reading has revealed… which sounds true, and explains why some of these BIOS tweaks work.

In the past, CPU binning yielded stable non-OC’d CPU’s, idle was generally always stable, and it was a bit of a lottery on how well it would overclock; if at all.

Today, with the focus on higher clocks and boosting… the binning tends to yield CPU’s that hit the desired boosted (semi-OC) mark (at higher non-idle voltage), leaving users needing to tweak in some cases to get idle stable (when the voltage gets too low for your silicon’s “happy place”) … the new (inverse) lottery… yes, it’s opposite day! :rofl:

But I also feel that idle on Linux is far more idle than on windows (my average CPU load in conky is 2% with 70+ Firefox tabs and Thunderbird open). So much bloat, background processes, telemetry, etc, at play in Windows that… really how idle is idle on Windows? So it turns out that GNU/Linux allows your CPU to hit stages of lower volts/power than windows ever did/does… which in turn really tests out it’s low voltage/power tolerance; leading to BIOS adjustments to achieve full stability (at idle)… I know, crazy right? :crazy_face:

1 Like

I’ve had yet another nvidia problem. Error message was:

[FAILED] Failed to start Light Display Manager

on the text-mode console, which left me again with no graphics :roll_eyes:

The (long) fixing process was trying to find the correct combination of kernel + nvidia driver to have installed.

My previous inxi output can be seen HERE.

The -nvidia-470xx series didn’t work for many tested kernels (before the update I used to have NVIDIA 460.73.01, acc to previous inxi output [Edit: LINKED] above). The combination that finally worked for my hardware was:

$ pacman -Qs linux515
local/linux515 5.15.2-2
    The Linux515 kernel and modules
local/linux515-nvidia-390xx 390.144-6 (linux515-extramodules)
    NVIDIA drivers for linux.

So the solution consisted in issuing the proper mhwd-kernel and pacman commands from the tty(the text interface I got after booting without graphics when pressing Ctrl+Alt+F2) (I did it as root), so minimally:

  • mhwd-kernel -i linux515; confirming operations, then
  • pacman -S linux515-nvidia-390xx, confirming operations then rebooting.

Obviously, as I was trying and testing kernel+nvidia driver combinations, eventually I had to issue commands to remove an unused kernel/driver than got in the way through dependencies and/or incompatibilities, so eventually a mhwd-kernel -r [kernel] (careful!! – read the command’s man pages and messages!! and make sure you have another working kernel to use afterwards), and a pacman -R [package] (also careful!! – read the command’s man pages and messages!!).

For completeness, here’s my current inxi output of the working state (with graphics :sweat:):

$ inxi --admin --verbosity=7 --filter --no-host --width | xclip
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=7d129f16-68a5-4166-af3c-be36b7ba6c40 rw quiet
  root=/dev/mapper/luks-d4d370d7-082e-437f-b4ae-84c750147f53 apparmor=1
  security=apparmor resume=UUID=85ffc8b9-36cc-4a1d-a122-a69aa6ef2518
  udev.log_priority=3 pcie_aspm=off
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: H310M H 2.0 v: x.x
  serial: <superuser required> UEFI: American Megatrends v: F12
  date: 08/13/2019
  Message: No system battery data found. Is one present?
  RAM: total: 15.57 GiB used: 2.12 GiB (13.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: Intel Core i3-9100F bits: 64 type: MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: B (11)
  microcode: EA cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB bogomips: 28808
  Speed: 1181 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 1181 2: 1253
  3: 3450 4: 1741
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
  flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
  hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
  md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
  pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
  rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme
  vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 390.144
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:128b
  class-ID: 0300
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
  loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
  s-diag: 583mm (23")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 55 size: 885x498mm (34.8x19.6")
  diag: 1015mm (40")
  OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144
  direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  class-ID: 0403
  Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel
  bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
  v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Gigabyte driver: r8169 v: kernel port: c000 bus-ID: 05:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Device-1: luks-bd4c91ef-b67b-4d8c-a73d-f8f8642b867b maj-min: 254:1
  type: LUKS dm: dm-1 size: 931.51 GiB
  p-1: sda1 maj-min: 8:1 size: 931.51 GiB
  Device-2: luks-d4d370d7-082e-437f-b4ae-84c750147f53 maj-min: 254:0
  type: LUKS dm: dm-0 size: 155.57 GiB
  p-1: sdb3 maj-min: 8:19 size: 155.57 GiB
  Message: No RAID data found.
  Local Storage: total: 1.13 TiB used: 781.92 GiB (67.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: CC43 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
  model: WDS240G2G0A-00JH30 size: 223.57 GiB block-size: physical: 512 B
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0400
  scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 155.57 GiB size: 152.13 GiB (97.79%)
  used: 45.85 GiB (30.1%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-d4d370d7-082e-437f-b4ae-84c750147f53 label: N/A
  uuid: 7d129f16-68a5-4166-af3c-be36b7ba6c40
  ID-2: /boot/efi raw-size: 4 GiB size: 3.99 GiB (99.80%) used: 424 KiB (0.0%)
  fs: vfat dev: /dev/sdb2 maj-min: 8:18 label: N/A uuid: 50B3-509E
  ID-3: /home raw-size: 931.51 GiB size: 915.89 GiB (98.32%)
  used: 736.07 GiB (80.4%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
  mapped: luks-bd4c91ef-b67b-4d8c-a73d-f8f8642b867b label: N/A
  uuid: 5e60496a-8abb-4130-b96e-7a2f3ef1bc44
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sdb1 maj-min: 8:17 label: N/A
  uuid: 85ffc8b9-36cc-4a1d-a122-a69aa6ef2518
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: USB OPTICAL MOUSE type: Mouse
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
  power: 100mA chip-ID: 275d:0ba6 class-ID: 0301
  Device-2: 1-8:3 info: Megawin Defender Gaming Keyboard type: Keyboard
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
  power: 100mA chip-ID: 0e6a:02c0 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: nvidia temp: 43 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
  Processes: 234 Uptime: 34m wakeups: 0 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 alt: 8/9 clang: 13.0.0 Packages: 1946 pacman: 1941
  lib: 470 flatpak: 0 snap: 5 Shell: Bash v: 5.1.8 running-in: screen
  inxi: 3.3.09

This driver is not provided since at least June in Manjaro so something was wrong already.

This error is not gpu specific, it can also occur with amd GPU’s, because lightdm usually starts too early, while the GPU drivers are not loaded yet Solution to the problem can be found here:

1 Like

Just an update, I solved my problem with the help of @freggel.doe by remove the vmmouse driver, simple!

Hi since last update I have a strange behaviour with some scripts that I used to launch in the background. Not a big deal, but somewhat annoying.

Some scripts are suspended shortly after launching them, for example :

toto@toto ❯ STS4
[1] 5465
 toto@toto ❯
[1]  + 5465 suspended (tty output)  ~/apps/sts-4.5.1.RELEASE/SpringToolSuite4 > /dev/null 2>&1
 toto@toto ❯ fg
[1]  + 5465 continued  ~/apps/sts-4.5.1.RELEASE/SpringToolSuite4 > /dev/null 2>&1

So what happened : I launched my alias STS4 which starts spring tool suite in the background with all output redirected to /dev/null (it used to work flawlessly daily for years)
A short time after, it is automatically suspended (the UI of the app is frozen, can’t click anywhere),
I enter fg and the app resumes (I can use it normally afterwards).
Happens 100% of the time, not for all scripts.

Did some research, none solved my problem




A post was split to a new topic: My monitor isn’t working during boot anymore