[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

To me it was suggested a different command line as indicated below, I followed and for 2 days the system back to normal.

Clean cache to resolve upgrade problems

The problem may be caused by old cache. Sometimes, after an upgrade, the old cache might introduce strange, hard to debug behaviour such as unkillable shells, hangs when changing various settings, Ark being unable to extract archives or Amarok not recognizing any of your music. This solution can also resolve problems with KDE and Qt applications looking bad after an update.

Rebuild the cache using the following commands:

$ rm ~/.config/Trolltech.conf
$ kbuildsycoca5 --noincremental

Just wanted to share my hard fought findings when playing fullscreen games:

There’s a hardlockup bug when you mix
-Kernel 5.15
-Optimus configuration with Nvidia drivers 470x or 4.9x

The lockup happens when you alt+tab several times the full screen to do something else. (works fine the first two times…).

It doesnt occur on kernel 5.4 with the same drivers.

It took me the whole weekend to narrow down the culprit (after this massive update on manjaro and i was wrongly suspecting Plasma…)

CPU: Intel i7-4720HQ (8) @ 3.600GHz
GPU: Intel 4th Gen Core Processor
GPU: NVIDIA GeForce GTX 960M
Memory: 1509MiB / 15462MiB

The command I used and pasted above was provided by Nate Graham (a KDE developer, I believe) here:

https://bugs.kde.org/show_bug.cgi?id=445516

Thank you, I will try it in case the issue happen again.

Hi,
I only use LTS kernels and after some artifacts on the screen in my KDE system
after switching between applications, I decided to downgrade to the nvidia-470 which is the “production stable” branch driver, instead of nvidia (495) which is the “new feature” branch driver.
I tried both in the Hardware Configuration GUI and in CLI :
sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx
Both ended up removing the kernels as dependencies (!) and the system became unbootable.
What is the correct way to do it ?

Last update broke my nvidia-340xx driver. There is no graphical environment. The computer freezes while loading the graphical environment. Can I fix this? I don’t want to go back to Windows 10.

Does this not help?

This will remove my nvidia-340xx driver. And install the video-linyx driver. My computer does not work well with it. No more options?

Do this. It is a workaround for 390 driver but it should fix the issue on older drivers too.

Hello I can confirm that this works

Only my file is under different name.


I use nvidia-340 and this file does not overwrite anything in xorg.conf.d at least in my case.

I’ve finally found parts of the issue:
I have two monitors, one of which is rotated by 90°. I’ve created a new user which can log in without issues. However, when I adjust the rotation to be “correct”, I get logged out immediately.
Upon logging in again, the rotation is not saved.
Has anyone any idea how this could be debugged or solved?
How to discriminate if that’s a cinnamon or a xorg issue?

EDIT: @Gene describes something similar here though I don’t understand how he solved it…

I’m afraid I didn’t solve the issue of the monitor. I marked my query as solved because to start with I couldn’t log in at all - I’d written a script which would orientate my monitor and that caused a crash immediately on log in. Since I’ve figured out what the issue is, I can now login - I basically just fully disconnected the monitor (power and data) and commented out my script, allowing me to login again! As the price of being able to login I’ve just stopped using my second monitor in portrait mode (my preferred orientation). It is now in landscape. I’m hoping for a more permanent fix, and have asked to have this added to the known issues.

It is not a cinnamon issue though - I use primarily i3 and occasionally (with a different user) XFCE. I think it is an Xorg issue.

1 Like

A post was split to a new topic: Boots to black screen after latest stable update

Update:
I realized both of my lts kernel packages were not marked as explicitly installed.
I marked them and the procedure to switch back to 470 was successful.
I am a bit confused about when this can happen in Arch based distros. I guess when the time Manjaro was installed on this PC , linux-lts and linux-latest packages were installed and later they became discontinued or something like that. On 2 other notebooks (with Intel GPU) of mine, kernel packages are marked as explicitly installed from the beginning.
Nvidia driver 495.44 is also suitable for my GTX 1650 VGA , but I will switch to it later. Resuming from suspend restart kwin desktop effects (due to graphichs reset) with nvidia and after that I always restart plasma, which it takes less time with the 470 driver series. I hoped 495 would solves this issue, but it did not happen.
I also noticed libxnvctrl package "NVIDIA NV-CONTROL X extension"is version still 495.44 after the downgrade of the driver.

Here an Issue which should be added to the “Known issues and solutions” list.

Issue: No search results in application launcher when using multiple kickoff instances.

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there's more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

1 Like

You should not be using 340, as it has serious security issues that will not be fixed.

What issues do you have with Nouveau?

Has there been any news on this?
How is it that no one else sees this behavior? Are multi monitor setups with rotations that rare?

Already tried 5.15?

1 Like

I’m not aware of any further news.