[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

Thanks. It worke again after the réinstallation of plasma

1 Like

Just sharing if anyone is getting the same problem below, please comment here for fixes or comments

After the update, if I suspend PC and then turn on, bluetooth is ‘dead’ and I have to manually run
systemctl start bluetooth
I use a chinese dongle as a bluetooth and never had any issue, Manjaro recognizes it automatically, but this thing is a bit annoying.
Has no issues with 5.4 kernel, but always dies with 5.10 and 5.15 kernels

1 Like

I don’t know if anyone wrote about this, but I had a problem with gdm (in reality with gjs) after update. I installed gjs-git from AUR (since there was a nasty bug crashing my session and it was fixed in a newer version), but I completely forgot about it and got the error “libffi.so.7 missing”, but first my gdm broke with a very helpful message “Oh no something has gone wrong”, so I had to dig into logs. Switching back to the original gjs package resolved the issue. From what I understood after some research this may happen with any package from AUR, not just gjs

I also have trouble starting GNOME. After the upgrade, boot hangs on the message “Failed to start GNOME Display Manager”.
First thing I tried was downgrading the nvidia driver, as I saw that many people seem to have issues with the new version:

mhwd --remove pci video-hybrid-intel-nvidia-prime
mhwd --install pci video-hybrid-intel-nvidia-470xx-prime

However, I still get the same error message on reboot.

But, when I then log into root shell and start gdm manually using…

systemctl restart gdm

… it works just fine. However, on the next reboot, I get the same error message, and I have to log into root console and start manually again. Does anyone have an idea what could be going on here and / or how I could go on to fix it?

Here’s some info that may help:

GDM seems to crash with a segfault:

 [   10.171780] gdm[929]: segfault at 0 ip 000055fdbcde494c sp 00007ffe3fe12370 error 4 in gdm[55fdbcdd2000+2f000]

/var/log/gdm is empty

In case my graphics hardware matters:

# inxi -G
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 470.86
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo
           Display: server: X.org driver: loaded: modesetting,nvidia
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.86

And here’s what’s installed:

# uname -a
Linux Rechner 5.10.79-1-MANJARO #1 SMP PREEMPT Fri Nov 12 20:26:09 UTC 2021 x86_64 GNU/Linux
# mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI

Excuse my ignorance on the process, but can I add the multiple monitors issue to the New Issues (I don’t seem to have permissions to do this myself)? In very basic terms, since the update, if I try to orientate my second monitor to portrait view with:

xrandr --output DisplayPort-0 --rotate left

there appears to be some sort of Xorg conflict, the system crashes and you are logged out ending up back at the LightDM login screen. I included relevant logs in my original post. This also appears to affect @LS650V as they described with their XFCE scaling issue.

Appreciate your help, and of course the distro itself.


Did you find the command to clear plasma cache? It’s:

rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell

To me it was suggested a different command line as indicated below, I followed and for 2 days the system back to normal.

Clean cache to resolve upgrade problems

The problem may be caused by old cache. Sometimes, after an upgrade, the old cache might introduce strange, hard to debug behaviour such as unkillable shells, hangs when changing various settings, Ark being unable to extract archives or Amarok not recognizing any of your music. This solution can also resolve problems with KDE and Qt applications looking bad after an update.

Rebuild the cache using the following commands:

$ rm ~/.config/Trolltech.conf
$ kbuildsycoca5 --noincremental

Just wanted to share my hard fought findings when playing fullscreen games:

There’s a hardlockup bug when you mix
-Kernel 5.15
-Optimus configuration with Nvidia drivers 470x or 4.9x

The lockup happens when you alt+tab several times the full screen to do something else. (works fine the first two times…).

It doesnt occur on kernel 5.4 with the same drivers.

It took me the whole weekend to narrow down the culprit (after this massive update on manjaro and i was wrongly suspecting Plasma…)

CPU: Intel i7-4720HQ (8) @ 3.600GHz
GPU: Intel 4th Gen Core Processor
Memory: 1509MiB / 15462MiB

The command I used and pasted above was provided by Nate Graham (a KDE developer, I believe) here:


Thank you, I will try it in case the issue happen again.

I only use LTS kernels and after some artifacts on the screen in my KDE system
after switching between applications, I decided to downgrade to the nvidia-470 which is the “production stable” branch driver, instead of nvidia (495) which is the “new feature” branch driver.
I tried both in the Hardware Configuration GUI and in CLI :
sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx
Both ended up removing the kernels as dependencies (!) and the system became unbootable.
What is the correct way to do it ?

Last update broke my nvidia-340xx driver. There is no graphical environment. The computer freezes while loading the graphical environment. Can I fix this? I don’t want to go back to Windows 10.

Does this not help?

This will remove my nvidia-340xx driver. And install the video-linyx driver. My computer does not work well with it. No more options?

Do this. It is a workaround for 390 driver but it should fix the issue on older drivers too.

Hello I can confirm that this works

Only my file is under different name.

I use nvidia-340 and this file does not overwrite anything in xorg.conf.d at least in my case.

I’ve finally found parts of the issue:
I have two monitors, one of which is rotated by 90°. I’ve created a new user which can log in without issues. However, when I adjust the rotation to be “correct”, I get logged out immediately.
Upon logging in again, the rotation is not saved.
Has anyone any idea how this could be debugged or solved?
How to discriminate if that’s a cinnamon or a xorg issue?

EDIT: @Gene describes something similar here though I don’t understand how he solved it…

I’m afraid I didn’t solve the issue of the monitor. I marked my query as solved because to start with I couldn’t log in at all - I’d written a script which would orientate my monitor and that caused a crash immediately on log in. Since I’ve figured out what the issue is, I can now login - I basically just fully disconnected the monitor (power and data) and commented out my script, allowing me to login again! As the price of being able to login I’ve just stopped using my second monitor in portrait mode (my preferred orientation). It is now in landscape. I’m hoping for a more permanent fix, and have asked to have this added to the known issues.

It is not a cinnamon issue though - I use primarily i3 and occasionally (with a different user) XFCE. I think it is an Xorg issue.

1 Like

A post was split to a new topic: Boots to black screen after latest stable update