[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

I have a NAS I use regularly mounted as a normal drive in my Computer.
After update I could not copy or move any files from or to my NAS. I could copy/move empty folders and edit existing data; but no files… strange!
The reason was obviously that I still had Kernel 4.19 running. Now I Installed 5.10 and everything is fine again.
Luckily I found this Topic in the forum

Did you figure it out? See my post in Support.

OK, I finally found what was preventing Xorg to start after the upgrade: VNC.
I had to remove these packages:

Now everything is back to normal with the latest Xorg.
Hope it’s useful for somebody.


1 Like

I have 2 problems.
1 - when updating kernel 5.15, the computer does not respond when restarting or shutting down, the screen is black. If you turn off the screen but not the cpu when you turn off. the same is not the case with older kernels.
I tried kde and cinnamon and the same thing happens in both cases.

2 - when the cpu starts up, the plasma desktop (x11) is loaded without a wallpaper and the desktop functions do not respond, but the menu and taskbar do. I did the same with wayland and the desktop loads normally.

There is an open ticket in xorg to handle this bug:

Some days after update my KDE Plasma is changing my desktop and set all things related to it as defaults. a bit strange.

It might also be related to clean KDE plasma cache, but I didn’t found the command line to do it.

Here is a list of known issues with the latest Xorg-Server 21.1 series …

1 Like

I can’t login anymore…I performed the update but it got stuck during the installation with the message that plasma-desktop is already present in Breaze. So to continue the installation I removed Plasma-desktop to be able to reinstall it later. and that’s where it got stuck … Plasma desktop refuses to reinstall again and I’m stuck at login password!

Hmm, it might have been a better idea to post the update blocking details before uninstalling plasma… but that doesn’t help you where you are right now.

As I’m still learning myself my advice may not be perfect, but I suspect one of two solutions to “recover gracefully” I’ve heard others mention before and two “less graceful” options:

  1. Once you get to the login prompt you can’t pass… try switch to a tty (i.e. Ctl-Alt-F2), log in, and try run pacman from there to try reinstall plasma… and if successful reboot to try login normally again
  2. If that doesn’t work, you may need to boot from a Live USB to use chroot to try accomplish the same thing… but I don’t know enough about it to make a recommendation of steps to follow in this case.
  3. If you have a Timeshift backup before the upgrade, this may be an option… but as it defaults to not backup home, it’s really only an option if you have a “Home” dir backup as well to “downgrade” all your settings as so much changed with plasma, kde, etc… with this update
  4. The last resort may be to reinstall Manjaro (previous version; similar issue to #3) and reload your Home dir backup… but let’s hope #1 helps you

Post update I noticed the audio device for my usb headset under KDE system settings>Audio>‘playback devices’ was reporting as a mono output. I was looking around and toggled the alsa profile to off from ‘alsa default’ and the device winked out of existence.

  1. Would that be the expected behavior?
  2. Can the device be recovered/reset? pacmd?

I still have the device for the headset input.

Edit: Not having sound is super annoying so I just reverted to a backup for the time being, if anyone has insight on what was happening it would still be appreciated though.

Edit Edit: Audio devices disappear in Kernels 5.14 & 5.15

update was mostly ok. The only problem was that I needed to reinstall python 3.7 from pyenv. This was because it could not import libffi anymore (needed for proton). I’m mentioning this in case anyone else runs into it.

I also upgraded from kernel 5.14 to 5.15 at the same time. No issues observed.

The new pipewire pushed in this release also has a commit from me. It’s a very simple one-liner, but your first time is always special :slight_smile:


You shoul not have done that.
Switch to tty and reinstall it.
Open a new thread detailing what you did, if further help is needed.

1 Like

Thank you, it work again. I just follow your 1st instructions !

Thanks. It worke again after the réinstallation of plasma

1 Like

Just sharing if anyone is getting the same problem below, please comment here for fixes or comments

After the update, if I suspend PC and then turn on, bluetooth is ‘dead’ and I have to manually run
systemctl start bluetooth
I use a chinese dongle as a bluetooth and never had any issue, Manjaro recognizes it automatically, but this thing is a bit annoying.
Has no issues with 5.4 kernel, but always dies with 5.10 and 5.15 kernels

1 Like

I don’t know if anyone wrote about this, but I had a problem with gdm (in reality with gjs) after update. I installed gjs-git from AUR (since there was a nasty bug crashing my session and it was fixed in a newer version), but I completely forgot about it and got the error “libffi.so.7 missing”, but first my gdm broke with a very helpful message “Oh no something has gone wrong”, so I had to dig into logs. Switching back to the original gjs package resolved the issue. From what I understood after some research this may happen with any package from AUR, not just gjs

I also have trouble starting GNOME. After the upgrade, boot hangs on the message “Failed to start GNOME Display Manager”.
First thing I tried was downgrading the nvidia driver, as I saw that many people seem to have issues with the new version:

mhwd --remove pci video-hybrid-intel-nvidia-prime
mhwd --install pci video-hybrid-intel-nvidia-470xx-prime

However, I still get the same error message on reboot.

But, when I then log into root shell and start gdm manually using…

systemctl restart gdm

… it works just fine. However, on the next reboot, I get the same error message, and I have to log into root console and start manually again. Does anyone have an idea what could be going on here and / or how I could go on to fix it?

Here’s some info that may help:

GDM seems to crash with a segfault:

 [   10.171780] gdm[929]: segfault at 0 ip 000055fdbcde494c sp 00007ffe3fe12370 error 4 in gdm[55fdbcdd2000+2f000]

/var/log/gdm is empty

In case my graphics hardware matters:

# inxi -G
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 470.86
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo
           Display: server: X.org driver: loaded: modesetting,nvidia
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.86

And here’s what’s installed:

# uname -a
Linux Rechner 5.10.79-1-MANJARO #1 SMP PREEMPT Fri Nov 12 20:26:09 UTC 2021 x86_64 GNU/Linux
# mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI

Excuse my ignorance on the process, but can I add the multiple monitors issue to the New Issues (I don’t seem to have permissions to do this myself)? In very basic terms, since the update, if I try to orientate my second monitor to portrait view with:

xrandr --output DisplayPort-0 --rotate left

there appears to be some sort of Xorg conflict, the system crashes and you are logged out ending up back at the LightDM login screen. I included relevant logs in my original post. This also appears to affect @LS650V as they described with their XFCE scaling issue.

Appreciate your help, and of course the distro itself.


Did you find the command to clear plasma cache? It’s:

rm ~/.cache/*plasma* ; killall plasmashell && kstart5 plasmashell