[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

sudo pamac update -a

solved the problem for me.


using KDE: OpenGL 3.1 is not working correctly anymore with Desktop Effects on.
Sometimes if I close a window, the window is closed, but the Screen doesn’t change (window still is shown as open). When I suspend compositing, window layout magically disappears and the image shown on screen updates to the correct state, what it should look like.

Switching to XRender fixed it for me. But I’d like to use OpenGl 3.1 again.

Black screen after login.
Installed this update and now black screen. Please consider nvidia users, every nvidia driver update screws everything.:expressionless:
Gpu: 1050 ti
Kernel: 5.10

Sorry not sure what to do. I’m used to using Nvidia-settings having the ability to create conf files for you. Not familiar with AMD.

May want to create a post

Thanks for your report!
I recognized something else: if I try to login serveral times without any changes, I have success after three or four repetitions. Login into gnome isn’t determinitic anymore :upside_down_face:

I found some interesting information about an unused but activated fingerprint authentification mechanism here How to disable "The account is locked due to three failed attempts" in Gnome - this could be the answer for my problem - one of my repetitions could have been faster than the failed fingerprint. I’ll check this and report here.

Deactivating the fingerprint sensor in BIOS seems to be the solution for my problem!

1 Like

I have flickering menus all over in Firefox 90 now. I’m using KDE Xorg Session. Any ideas what can I check? Webrender is disabled.

I fixed this problem by restarting the plasmashell but I didn’t now why it happened.
To solve this problem, first kill all plasmashell processes:

$ killall plasmashell

Then start it manually:

$ kstart5 plasmashell

wait a little bit and you will get your desktop back.
Also to make sure if this problem is resolved permanently or temporarily, I rebooted and I didn’t encountered with the problem. I hope this helps you too.

1 Like

I have still two problems with this update:

  1. After every login, I should enter my password to let the kded5 access the kwallet which is very annoying.
  2. Border of “notifications” and “Application launcher”, loosed the transparency which makes them ugly(looked at the dark gray sections in the pictures):


1 Like

Hibernation is not working properly for this update. After I run the command systemctl hibernate, my computer hibernates as usual, but when I press the power button to resume it, things are not as expected. My computer is not restored to its previous state and I get a totally clean desktop. I’ve noticed that during startup a message says resume: no device specified for hibernation appears on the top of my screen. I don’t know why this happens, I haven’t modified any configuration files after this update.

The new overview/app launcher is a feature that the developer added with the current release of Material Shell, and is completely out of the Manjaro team’s hands. Some people have been asking for ways to get Gnome’s default app launcher/overview back on his Discord, but according to the developer he had to completely disable it, since it’s not possible to just remove the trigger on super to open it. Unfortunately the only ways for you to get it back seems to be to either fork Material Shell and remove the new app launcher yourself, go back to using Gnome 3.38, or not use Material Shell at all.

Super+W/S doesn’t work for me either, but Super+0-9 does (and Super+A/D for next window) so this should probably be reported to the developer’s github or Discord server if you want someone to attempt to fix it.

After this update (ending in -5) , and even a restart, dash-to-dock fails to activate at all. “Extensions” now just shows an exclamation mark by it, and it won’t switch on.

Previous to this, is could be switched on. Not now.

[dmn@Sydney ~]$ pacman -Qi gnome-shell-extension-dash-to-dock
Name            : gnome-shell-extension-dash-to-dock
Version         : 69+14+g302c693-5

Well… fck… D:. If Gnome would have the power to save locations and size of applications and which virtual desktop they are on, this would be a non issue. I fail to see Gnome’s vision of a very modern yet simple DE, when even Windows 11 is getting tiling and Gnome only has it trough extensions, and KDE’s tiling scripts have been very buggy for me. Guess i will just use plain Gnome for a while.

Also, anyone else finding the activities button in the top left which once mouse hits it’s top left corner at high speed, activating the activities/virtual desktop switcher/full screen app launcher to be annoying ? I am constantly hitting it accidentally when trying to get my mouse up there to switch Firefox tabs or go back and forth.

Nvidia update caused the black screen on my end; using the nouveau driver at the moment.

kernel: 5.4
gpu: NVIDIA GM107GLM [Quadro M1000M]

1 Like

Did you restart GNOME Shell or logout / login after updating?

Hi, I just saw that there is in update for Dash-to-Dock, hence did it. Problem solved. That was a super fast fix. Thanks. :man_dancing: :smiley:

Problem after stable update 21-07-13: CD-ROM turns on and opens when un-suspending the PC. I have a door in front of the CD-ROM drawer and this is not good. The drawer does close though, after slamming against the door. I’ve never had this problem before. I am running Kernel 5.4.131-1, and noticed 5.10.49-1 is now also LTS, Recommended. Wondering if changing Kernel would help?
Has anyone else experienced this? Wondering if I should just unplug the CD player? I can’t remember the last time using it. I would like to have a better solution though. I did search the forum for any posts about this problem, and found none.
It’s been years since I’ve had to make a comment on a problem with an update, so please forgive me if I’m doing it incorrectly. Thanks for any help or advice you can give me.


What DE are you on? May be something like auto mounting that could be causing that. Not sure though

Great work on gnome 40, thanks!

After switching to gnome 40, I have an issue with mouse side buttons.
I was using xbindkeys with xte to bind a mouse button to ‘Show the activities overview’ with Super+R

The command that used to work was
xte 'keydown Super_L' 'key R' 'keyup Super_L'

The strange thing is that in Telegram it just types ‘r’, in browser it works like ‘back’ and ‘forward’ (which is by default), in other apps it does nothing. Gnome shortcut Super+R still works fine.

Also, anyone else finding the activities button in the top left which once mouse hits it’s top left corner at high speed, activating the activities/virtual desktop switcher/full screen app launcher to be annoying ?

Run Gnome Tweaks
gnome-tweaks in terminal or via applications Tweaks
Tweaks → Top Bar → Activities Overview Hot Corner

Switch it off and you won’t have that trouble.

If you mean Desktop Environment, it’s XFCE. I have never set the cd-rom to auto-mount. I would love to know a terminal command to see what is auto-mounted, do you know of one? I just got done reading about “autofs”, but there is no manual entry for it in the terminal emulator. Should I install this? Will it show me the auto-mounts, and allow me to turn off unwanted auto-mounts? I see many articles about auto-mounting. But, nothing on undoing an auto-mount. Thanks again for any help that may be supplied.