How to disable "The account is locked due to three failed attempts" in Gnome

Hi there,

if I type in the wrong password in gnome login screen, the account gets locked for 10min. “The account is locked due to three failed kogin attempts.” How do I disable this feature or how to change the number of attempts and locking time? There is also a bug in this feature, cause the account gets locked after one and not three attempts. So every time I type in the wrong password once, I have to wait for 10min…

Thanks :slight_smile:

Hello and welcome! :wave:

Could you post what’s in:

cat /etc/pam.d/login

Thanks

does the system with the problem have a fingerprint reader that you do NOT use - even one that is not configured, but not disabled?
For me and by now 2 more users I am aware of it is the introduction of working finger print auth in GDM/gnome that causes the issue.

I worked around it by dissabling the fingerprint reader in the UEFI

content of /etc/pam.d/login

    #%PAM-1.0
    auth       required     pam_securetty.so
    auth       requisite    pam_nologin.so
    auth       include      system-local-login
    account    include      system-local-login
    session    include      system-local-login

yes, my laptop does have a fingerprint reader, which is disabled in settings.
This could be the problem, because I think the problem occurred after a firmware update, that added support for the inbuilt fingerprint reader. I’ll try if disabling it in the UEFI helps.

Set deny = 0 in /etc/security/faillock.conf. See Security - ArchWiki

2 Likes

Turning fingerprint reader off in uefi fixed the bug :+1:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.