[Stable Update] 2021-02-28 - Kernels, Plasma 5.21.1, Frameworks 5.79, Firefox, Thunderbird, Python

Hello community,

Another stable branch update with some usual updates for you.


Get your Plasma desktop updated to the lastest stable release! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated
  • Firefox is now at 86.0
  • Thunderbird got updated to 78.8.0
  • For fans of KDE Software we have now Plasma 5.21.1 and Frameworks 5.79 added to our repos!
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You can also help us with the Stable-Review images, so the upcoming installer ISOs are solid for Newcomers!


Our current supported kernels

  • linux44 4.4.258
  • linux49 4.9.258
  • linux414 4.14.222
  • linux419 4.19.177
  • linux54 5.4.100
  • linux59 5.9.16 [EOL]
  • linux510 5.10.18
  • linux511 5.11.1
  • linux54-rt 5.4.93_rt51
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed Feb 24 11:47:21 CET 2021)

  • stable community x86_64: 1412 new and 1390 removed package(s)
  • stable core x86_64: 50 new and 49 removed package(s)
  • stable extra x86_64: 575 new and 668 removed package(s)
  • stable kde-unstable x86_64: 281 new and 253 removed package(s)
  • stable multilib x86_64: 27 new and 27 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

28 Likes

Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • Apache error:  httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server

    Please click the ► at the beginning of this line to view this solution

    Full error message:

    MMM DD HH:MM:SS ServerName httpd[45914]: httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server: /etc/httpd/modules/libphp7.so: cannot open shared object file: No such file or directory
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Control process exited, code=exited, status=1/FAILURE
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Failed with result ‘exit-code’.‘exit-code’.
    
    • Execute:

      sudo nano --backup  /etc/httpd/httpd.conf
      
    • change the following lines:

      LoadModule php7_module modules/libphp7.so
      Include conf/extra/php7_module.conf
      

      to:

      LoadModule php_module modules/libphp.so
      Include conf/extra/php_module.conf
      

      Respectively! (They are not necessarily next to one another!)

    • Save (Ctrl+X Enter Y)

    • Restart Apache (or reboot if you don’t know how or to to get that Window$ feeling again)

  • Pulseeffects stopped working

    Please click the ► at the beginning of this line to view this solution

    Execute:

    pamac install manjaro-pipewire
    pamac install gst-plugin-pipewire
    
  • gnome-shell-extension-desktop-icons  cannot be updated

    "Please click the ► at the beginning of this line to view this solution
    error: failed to commit transaction (conflicting files)
    gnome-shell-extension-desktop-icons: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/schemas/gschemas.compiled exists in filesystem
    Errors occurred, no packages were upgraded.
    

    please run the following command:

    sudo pacman -S gnome-shell-extension-desktop-icons --overwrite /usr/share/gnome-shell/extensions/\*
    

    and the issue will be resolved.

  • I’m still running on nvidia-450 and I want to recompile the 450 driver (Kernel 5.4 LTS):

    Please click the ► at the beginning of this line to view this solution
    1. Add the line IgnorePkg = lib32-nvidia-utils lib32-opencl-nvidia mhwd-nvidia opencl-nvidia in file /etc/pacman.conf

    2. Upgrade your packages (using the pamac GUI) or:

      pamac upgrade
      
    3. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    4. Boot will be stuck because no driver has been found, just open a console with Ctrl+Alt+F2

    5. First read Note 2 below, then get the sources for your driver (in my case, 450xx):

      git clone https://gitlab.manjaro.org/packages/extra/nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-450xx.git
      
    6. Compile the driver (if you get an error, see Note 3):

      cd nvidia-450xx-utils && makepkg -si
      cd ../lib32-nvidia-450xx-utils && makepkg -si
      cd ../nvidia-450xx && makepkg -sif
      
    7. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    Now, everything is working again! To check if you’re indeed running kernel Linux 5.4, you can run uname --kernel-release in a console, and to check if you’re running the driver you just compiled, you can run inxi --graphics --display OR nvidia-smi

    Note 1: to choose which kernel to boot on, you need to edit those two lines in /etc/default/grub to match those (5 as in 5 seconds to make your choice on the menu, you can put whatever):

      GRUB_TIMEOUT=5
      GRUB_TIMEOUT_STYLE=menu
    

    Then, run sudo update-grub. When booting, you’ll now see a menu with all installed kernels so you can choose which one to use for this session.

    Then finally execute the reboot command:

      sudo reboot 
    

    Note 2: During step 5 and 6: If you already have compiled the nvidia driver during last update, you can skip cloning nvidia-450xx-utils and lib32-nvidia-450xx-utils (you already have the sources, you just need to compile them again), but I suggest you remove your older nvidia-450xx folder (rm -rf nvidia-450xx) and clone it again before compiling this one, otherwise you will get an error like “folder already exists” when trying to compile.

    Note 3: When trying to compile the driver, you might get an error with two nvidia packages creating conflicts (I think lib32-nvidia-utils was one of them, I don’t remember the other one). To fix that, just uninstall those packages with pamac remove <package>.

  • I’m still running on nvidia-450 and I want to upgrade to 460 (Kernel 5.10):

    Please click the ► at the beginning of this line to view this solution
    • Print this page so you have it as a reference while in TTY2

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      pamac remove nvidia-450xx-utils
      #you will get some warnings about optional components needing this: 
      #  no worries, you'll install 460 in the next line
      sudo mhwd --install pci video-nvidia
      sudo reboot
      

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/

Moving to Zstandard images by default on mkinitcpio

Moving to Zstandard images by default on mkinitcpio

2021-02-19 - Giancarlo Razzolini

As linux-lts moved to the 5.10 version, all official kernels of Arch Linux now support zstd compressed initramfs images, so mkinitcpio is switching to zstd compressed images by default with version 30, which is currently on [testing].

If, for any reason, you are using a kernel version prior to 5.9, make sure to change mkinitcpio.conf COMPRESSION to use one of the compressors supported, like gzip, otherwise you will not be able to boot images generated by mkinitcpio.

https://archlinux.org/news/moving-to-zstandard-images-by-default-on-mkinitcpio/


Older Issues

Please click the ► at the beginning of this line to view the older issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

xf86-video-intel already exists in filesystem errors

Please click the ► at the beginning of this line to view this solution

If you get something like this:

error: failed to commit transaction (conflicting files)
xf86-video-intel: /usr/bin/intel-virtual-output exists in filesystem
xf86-video-intel: /usr/lib/libI810XvMC.so exists in filesystem
...
xf86-video-intel: /usr/share/man/man4/intel.4.gz exists in filesystem
xf86-video-intel: /usr/share/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy exists in filesystem
Errors occurred, no packages were upgraded.

Just delete the files that are in conflictand perform the upgrade again.

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

4 Likes

Everything seems fine for me ! Thank you :+1:

All fine on xfce + 5.10.
Tiny question though: Why is kernel 5.10 still not tagged as LTS?

8 Likes

Xfce, intel iGpu, linux511 all good on first glance - some .pacnew files to check, new optional dependencies for pipewire .

Update works fine on three KDE-Plasma PCs.

Thanks to the Manjaro-team :slightly_smiling_face:

regards
caho

Updated without problem.

Thanks Manjaro Team

Everything went smooth, thank you!

Update on three computers went fine:
KDE, XFCE and kernel 5.4, 4.19 and 4.14.

Will Kodi 19 be added in next stable updates? They finally made the switch to python3 I think.
Edit:
Can someone explain what this is?

:: Running post-transaction hooks...
( 1/26) Creating system user accounts...
Creating group saned with gid 952.
Creating user saned (SANE daemon user) with uid 952 and gid 952.
1 Like

Fine for me. Had to spend a bit of time reconfiguring the launcher but everything is great. Thanks to the Manjaro team - great OS!!

Not sure if this is the right place for that complaint, but the new KDE start menu is now a lot less easy to use with a keyboard. Previously I was able to press Win and then start navigating up or down with arrows keys in the favourites list, now I first need to press right and then can’t wrap around to the bottom by going above the top.
Also, the order of my favourites was jumbled and the defaults (GUI updater etc.) were added again, but since I had to reorder everything important to the top anyway, that doesn’t matter, I guess.

1 Like

Update went well, no issues but slow download-speed. the new application launcher is weird, i’m not used of it and don’t feel comfortable with it. is there a way to configure it to the old fashioned mode? i haven’t find a way till now.

Right click on the launcher button. This will give you the option to try other types of launcher (show alternatives) or configure your current launcher.

I use the Application Launcher option and it’s changed but I have it quite similar to how it used to be in terms of functionality. I like it fine.

Xfce, Kernel 4.14.

All went fine and smooth as usual.

In this update I see NetworkManager updated to 1.30.0-1 and is blatantly improved in terms of loading time and in the terms of signal strenght: my wifi adapter (TP-Link Archer T9UH) in the room where the laptop is placed (the router is distant two rooms and two doors), used to have a signal of about 70/71%; now, also after several reboots, it always take a signal of 82-84%; IDK if is just a cosmetic change of nm-applet, but as I’ve said, the wifi connection is blatantly fatser to load.

Long live rolling release!

EDIT:
I’ve found a minor issue with x86_energy_perf_policy package, reported here:

[Stable Update] 2021-02-28: x86_energy_perf_policy: unsupported CPU

1 Like

Excellent. No issues here :smiley:

1 Like

No issues updating.

How do I remove the Suspend option from the new kde launcher 2.0 tho?

I tried that already, but it doesn’t bring back the old style. I also don’t like the only alternative it offers. I actually do prefer the grid that is now the default, but it should at least select the first entry there by default for better keyboard navigation. And I don’t care about the categories, which are now always visible.

Also, my secondary monitor now shows desktop icons again the background got reset.

I’m quite sure that it is not the right place, but having the same complaint, I really like the new look of the start menu :slight_smile: It is not so hard to browse using arrow keys (and alt+arrow) btw, but I don’t have right arrow and have to use numlock everytime.

All fine on linux510 + LUKS/BTRFS + XFCE
Only need to downgrade xfce4-power-manger to 1.6.6 (use only for monitor MX Master mouse Battery State
AC Icon is still broken
Other then that there are no issues

Also switched to telegram-desktop-manjaro