[Stable Update] 2021-02-28: x86_energy_perf_policy: unsupported CPU

Hi, I had a minor issue after the mentioned Stable update 2021-02-28:
the package x86_energy_perf_policy has been updated from 5.10-2 to 5.11-1.
With the current release, I am no longer able to set the Energy Performance BIAS for the CPU (for battery saving purposes); my cpu is an Intel Core i5-3210M; when on battery (eg by using TLP) i set it to “power”: using x86_energy_perf_policy 5.11-1 I got x86_energy_perf_policy: unsupported CPU.; downgrading it to 5.10-2 (from A.L.A) has solved the issue. I would report it on upstream, but I don’t know where: I see that x86_energy_perf_policy is owned by kernel.org, as you can see, eg. here:
Arch Linux - x86_energy_perf_policy 5.11-1 (x86_64)

So: can someone point me out to the right upstream repository where I can report such issue?

have you tried with

I’m already using intel_pstate:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver

Sorry if I bump this thread (well, I am the OP :slight_smile: )

I also tried the newest x86_energy_perf_policy 5.14 -1, but again as I attempt to set the performance policy, I still get unsupported CPU.
The last revision which works is 5.11 -1.

I ask again to anyone: where is the upstream repo of x86_energy_perf_policy? (I cant’t figure it out where is)
I would report such issue in the right place.

I can ignore it.

By checking here: https://www.kernel.org/doc/Documentation/ABI/testing/sysfs-devices-system-cpu if Intel Energy and Performance Bias is available, there must be /sys/devices/system/cpu/cpu*/power/energy_perf_bias which on my system doesn’t exists, so, despite the fact that x86_energy_perf_policy 5.11 -1 is working and when by executing sudo x86_energy_perf_policy performance and verifying that has been applyed by sudo x86_energy_perf_policy -r I got

cpu0: EPB 0
cpu1: EPB 0
cpu2: EPB 0
cpu3: EPB 0

My system still missing /sys/devices/system/cpu/cpu*/power/energy_perf_bias , so x86_energy_perf_policy does nothing.
But I am sure that in past (I installed manjaro on February 2019) such file was present; maybe during this time, the kernel and the CPU governor has become “smarter” to apply the most appropriate parameters in other ways… Who knows…