[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Did anyone manage to solve the font problem? I create a symlink in /etc/fonts/conf.d/ and reinstall ttf-dejavu but doesn’t change anything.

Hi @wils0n,

Can you check your settings under the “Fonts” tab of xfce4-appearance-settings ?
Documentation is available here: xfce:xfce4-settings:appearance [Xfce Docs]

On my side, I disabled the “Custom DPI setting”.


Thank you for your response. It was enabled, I disabled it but doesn’t change.

Kernel 5.10.2 causes problems with LUKS

Kernel 5.9 still boots without problems. With kernel 4.10 I do not get a solution.

To investigate the matter I made an entry for 5.10 in the file /boot/grub/grub.cfg from an entry for 5.9. Unfortunately without success. The same error occurs.

A diff with a backup of the file and /boot/grub/grub.cfg, re-created with grub-mkconfig -o /boot/grub/grub.cfg, shows no further differences.

I can’t upload any pictures yet.

ERROR: device '/dev/mapper/luks-b266a6a4-ce7f-4a76-8bdc-936f0bfc8605 ' not found.
 Skipping fsck.
mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: cant't access tty: job control turned off
[rootfs ]$ _

In the running system I get the following IDs:

$ blkid
/dev/nvme0n1p1: UUID="b266a6a4-ce7f-4a76-8bdc-936f0bfc8605" TYPE="crypto_LUKS" PARTUUID="0c63fc14-01"
/dev/nvme0n1p2: UUID="b1460aa5-5a41-41ec-8c17-5e71ada82eca" TYPE="crypto_LUKS" PARTUUID="0c63fc14-02"
/dev/mapper/luks-b266a6a4-ce7f-4a76-8bdc-936f0bfc8605: UUID="3d126ac0-9d2b-4688-bac3-72a08e002fa7" BLOCK_SIZE="4096" TYPE="ext4"
/dev/mapper/luks-b1460aa5-5a41-41ec-8c17-5e71ada82eca: UUID="ccc803c2-446b-44f7-aa01-0a48c107bf54" TYPE="swap"

My WLAN card is no longer working since the update (no wifi symbol although the card seems to be recognized in the hardware configuration). I tried to switch the driver from linux54-broadcom-wl to broadcom-wl-dkms, but it didn’t help.

Which fonts you talk about?

There is no solution for otherwise it will be noted in known issues

Remove pipewire-pulse .

Any chance I could replace pulseaudio entirely without break something in Manjaro?

Yes, you could. The Arch wiki Pipewire page had more info about it not too long ago, but it was removed. I’m not sure why.

However, @Ste74 just made some adjustments to our manjaro-meta packages in the unstable branch, so it should be easier in the future.

1 Like

That command installs bumblebee for me, however i need hybrid intel nvidia prime driver.

Nice! I just tried the KDE, thanks.


If the normal case is that the filesystem should NOT be mounted as Read-Only.
Then why does the new config define the variable named GRUB_ROOT_FS_RO as true?
Given your explanation, defining that variable as false by default would make more sense.

The update totally broke my installation. After updating I got a black screen with only the mouse cursor visible.

Tried every solution I could find for the same issue but nothing changes, I get multiple errors (kwin_x11, plasmashell, krunner) and the clicking the see details button says a lot of R300.dri.so or something like that, so I assumed something went bad on my end.

Then I decided to do a clean install and can’t get past the welcome screen… it stays there and can see the boot process in the background (it stops after starting SDDM); trying to move the window makes the screen to go messy and closing it does nothing.

So for now, I’ve lost access to hundreds of GBs of data I thought they’d be safe since I’m running the STABLE branch…because I can’t even boot the live USB because it has the same freakin bug.! 20210103_190341|375x500

I have a GTX 1070 BUT EVERY TIME I run

sudo mhwd -a pci nonfree 0300

it just installs linux510-nvidia-390xx, but before the update it had installed nvidia-455xx, and my friend with a 1070TI also running Manjaro can run the same command and 455xx.

1 Like

Python 3.9 broke everything relating to steam; protontricks and installing stuff for windows games – apparently AUR python-vdf and Valve official upstream doesn’t support yet python 3.9. (was stupid enough to delete compatdata for a game that I was tinkering with to get running and now even installing vc_redist.x86.exe (vcrun2019 ?) or something just fails in setting up new protonprefix…)

Then downgrading python to 3.8.6 broke pamac AUR parts and yay AUR parts and other stuff (complaining about missing module “setuptools” in setup.py).

And also made downgrade funky but remained functional enough to “downgrade” python back to 3.9.

python 3.8.6 and downgrade complains about missing pacman_mirrors
$ sudo downgrade python
Traceback (most recent call last):
  File "/usr/bin/pacman-mirrors", line 20, in <module>
    from pacman_mirrors import pacman_mirrors
ModuleNotFoundError: No module named 'pacman_mirrors'
Available packages:

    1)  python    3.7.2  2  x86_64  (remote)
    2)  python    3.7.2  3  x86_64  (remote)
-   3)  python    3.7.3  1  x86_64  (remote)
-   4)  python    3.7.3  2  x86_64  (remote)
-   5)  python    3.7.4  1  x86_64  (remote)
-   6)  python    3.7.4  2  x86_64  (remote)
-   7)  python    3.7.4  2  x86_64  (local)
-   8)  python    3.8.0  1  x86_64  (remote)
-   9)  python    3.8.0  1  x86_64  (local)
-  10)  python    3.8.1  1  x86_64  (remote)
-  11)  python    3.8.1  1  x86_64  (local)
   12)  python    3.8.1  2  x86_64  (remote)
-  13)  python    3.8.1  3  x86_64  (remote)
-  14)  python    3.8.1  3  x86_64  (local)
-  15)  python    3.8.1  4  x86_64  (remote)
-  16)  python    3.8.1  4  x86_64  (local)
-  17)  python    3.8.2  1  x86_64  (remote)
-  18)  python    3.8.2  1  x86_64  (local)
-  19)  python    3.8.2  2  x86_64  (remote)
-  20)  python    3.8.2  2  x86_64  (local)
-  21)  python    3.8.3  1  x86_64  (remote)
-  22)  python    3.8.3  1  x86_64  (local)
   23)  python    3.8.4  1  x86_64  (remote)
-  24)  python    3.8.5  1  x86_64  (remote)
-  25)  python    3.8.5  1  x86_64  (local)
-  26)  python    3.8.5  2  x86_64  (remote)
-  27)  python    3.8.5  2  x86_64  (local)
+  28)  python    3.8.6  1  x86_64  (remote)
+  29)  python    3.8.6  1  x86_64  (local)
   30)  python    3.9.0  1  x86_64  (remote)
-  31)  python    3.9.1  1  x86_64  (remote)
-  32)  python    3.9.1  1  x86_64  (local)

select a package by number: 32
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) python-3.9.1-1

Total Installed Size:  79.38 MiB
Net Upgrade Size:       1.53 MiB

:: Proceed with installation? [Y/n] 
python 3.9 and protontricks
Traceback (most recent call last):
  File "/usr/bin/protontricks", line 33, in <module>
    sys.exit(load_entry_point('protontricks==1.4.4.dev4+g0fab781', 'console_scripts', 'protontricks')())
  File "/usr/bin/protontricks", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 972, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/protontricks/__init__.py", line 1, in <module>
    from .steam import *
  File "/usr/lib/python3.9/site-packages/protontricks/steam.py", line 8, in <module>
    import vdf
ModuleNotFoundError: No module named 'vdf'

New Nibia release tonight: 20.2.1 …

Over the weekend i updated 11 manjaro-systems, most of them with nvidia drivers and kernel linux54. They all got kernel510. Everything works fine. Great job! Congratulations to the team.
Good idea to work together with softmaker. I’m using their office since the middle of 1990th years and is the very best of non-microsoft-offices. You can find it in the AUR, too.

Thanks for this, it looks like this being enabled by default was causing a whole bunch of issues with both konsole and alacritty, where the copied text was showing up in strange places, there were weird characters added and more.

I googled for this problem (I narrowed it down from the release post from bash, their release notes are fantastic) and found this thread.

1 Like

Please reinstall the mhwd-db package, after that you should be able to see the latest compatible configuration.

I have adjusted the hooks:


<HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)
>HOOKS=(base udev autodetect keyboard keymap modconf block mdadm_udev encrypt lvm2 filesystems fsck)

in /etc/mkinitcpio.conf

mkinitcpio -P

I have not checked it, but I think encrypt would have sufficed.


I’m experiencing the exactly same issue. After this update Manjaro fails to boot into graphical UI with the error (Light Display Manager failed). However, if I open a TTY console and restart the lightdm service, it will load up the GUI.
I checked the lightdm logs but couldn’t find anything meaningful to me. Did you manage to solve your issue?

Funny thing is that my other machine with a nvidia card, updated just fine. This one with a radeon RX 5700 is the one giving me trouble… :frowning: