[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Trying to resume from suspend (sleep) I only have a black screen.
The system is working. I can interact with it and when I plugged in a portable monitor it worked, but primary laptop screen will not come back up.

T580 Thinkpad, Plasma, Intel Graphics

i don’t have the open-cl packages installed;
do i need them or are they meant for programmers?(i saw my card 1050 mobile)apparently is cuda powered?
just trying to fix the same error at shutdown.

If you have proprietary video drivers, try this. I had the same problem and this did the fix:

In /etc/default/grub
change GRUB_ROOT_FS_RO=true to GRUB_ROOT_FS_RO=false
and do sudo update-grub


How can I execute this if I can’t tty into the system? I also can not chroot from a live usb.

Emojis only broken in discord so it has nothing to do with noto-emojis

in a virtual environment:
noto-fonts 20190926-4
noto-fonts-cjk 20190409-2
noto-fonts-extra 20190926-4
they look as expected

switched branch and sudo downgrade noto-fonts noto-fonts-cjk noto-fonts-extra


Open a new topic here: #support:Graphic-Cards and provide more technical info.

(an inxi --admin --verbosity=7 --filter --no-host --width would be the absolute minimum)


Hi everyone.

I have issues with the new update and kernels,

I’m on Manjaro stable xfce and I have an AMD GPU (RX 5700)

On kernel 5.10, with the amdgpu.dc=0 in the grub boot options, it just glitches out the display during the systemd boot stuff (I removed the quiet option), and I can’t access the tty (I can only reboot, ctrl-alt-del)

On kernel 5.10, without the amdgpu grub option, it gets stuck after the systemd boot stuff (it seems it can’t start lightdm even though there’s the [ok] started lighdm line). However, if I access the tty with my user account, and execute “sudo lightdm”, lightdm appears and everything works well.

On kernel 5.4, everything works fine without the amdgpu grub option.

I would like to use the 5.10 kernel without the hassle, does someone have an idea?

Thanks for your help

PS : 5.9.16 and 5.10 have the same behaviour

No I don’t think the opencl packages are necessary. Just the nvidia-utils and the kernel54-nvidia modules. If you only want to fix the problem.

I happen to have the opencl packages because I do some 3D rendering stuff… And yes they are related to cuda somehow. I also noticed that the above packages are installed by default with the mhwnd script. So why not nave them anyway…

Just try with the anformentioned ones and let me know how you did…

1 Like

Update: after following what some people in the post suggested, which was:

  • Removed all packages that required Nvidia (cuda, nvdia-prime, nvidia-455xx-utils, etc.)
  • Ran command sudo mhwd -a pci nonfree 0300
  • Ran command sudo pacman -S cuda
  • Used nvcc to compile a file
  • Trying to run that file still returns the provided PTX was compiled with an unsupported toolchain. in fw.cu at line 106

Everything else works fine, currently installed packages are:

$ pacman -Q | grep nvidia
lib32-nvidia-utils 455.45.01-3
linux54-nvidia 455.45.01-6
mhwd-nvidia 455.45.01-3
mhwd-nvidia-390xx 390.138-1
nvidia-prime 1.0-4
nvidia-utils 455.45.01-2
opencl-nvidia 455.45.01-2

$ pacman -Q | grep cuda  
cuda 11.2.0-1

How did you install it? Only option in Manjaro hardware kernels shows only the experimental version as an option to install. My system is up to date except for this latest update. Thanks

Turns out it’s a problem with Arch itself.

According to this post on stack overflow Arch updated CUDA without meeting the requirements for the Linux driver version (check the post for additional links).

My solution was simple and it worked, simply rolling back to the previous version with:

$ sudo pacman -U https://archive.archlinux.org/packages/c/cuda/cuda-11.1.1-1-x86_64.pkg.tar.zst

Now allows you to use nvcc and run the program on your machine.

1 Like

PLEASE HELP! Updated about 30 mins ago and manjaro is not booting into KDE. After installing the update it asked to reboot but after rebooting it doesn’t load into the GUI and just hangs. I don’t post on the forum very often so please let me know if you need any further info. Hopefully I can get back into my system tonight.

Hi all I really need some help after this update.

As many others have noted I also got the linux-latest and linux57 are in conflict and linux-latest and linux58 are in conflict

and couldn’t update so from what I read here the thing to do was to remove them ( I may have misunderstood but that’s what it seemed to me).
After which I could install the update. But now I can’t boot into a graphical environment.
I can get into a tty session and I’m pretty sure I have no graphics drivers now.
so how can I resolve this please?
I have an GTX 1060 card.
This is actually my daughters computer so she’s freaking out right now.
Any help much appreciated.

i restored using timeshift. will leave the update for another day after doing some reading. Assuming Nvidia graphics driver issue.


I think I’m gonna have to do a fresh install for my daughter, I can’t seem to resolve this.

This happen because 5.7 and 5.8 are EOL and Manjaro doesn’t support this Kernels anymore, the linux-latest Upgrade to 5.9 so it’s safe to remove 5.7 and 5.8

Remove nvidia-455xx-utils manually in the Add/Remove software or by the terminal

pamac remove nvidia-455xx-utils

then install the new video-hybrid-intel-nvidia-driver,it should work now.

Yeah I did remove them then rebooted but now I have no graphical environment so it’s not really safe to do.

Before I even begin upgrading, what exactly are the implications of this amdgpu.dc=0 ?? Does it impact AMD GPU performance in any negative way?