[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Update of my Intel desktop system with an NVIDIA gpu that requires the 390.xx drivers is apparently fine with the 5.9 kernel. However it booted to a blank screen with the 5.10 kernel, probably because there are no linux510-nvidia-390.xx drivers (yet?).

Edit 2021 Jan 03:
With the appearance of the linux510-nvidia-390.xx drivers in the repositories I reinstalled the 5.10 kernel, which now included those nvidia-390 drivers, and rebooted the system, all is apparently fine so far with 5.10 kernel.

Noto Sans Regular looks different from old VM and my updated machine. The fonts names are equal but visual is not the same.

  1. I didn’t know about this script
  2. Since I already did the almost upgrade. I should wipe my virtualenv and rebuild it?


I updated my USB that I use with a Tanix Wintel box, plus updated kernel to 5.10.2 when prompted. After reboot, noted that:

  1. first time starting each program is very slow, but on subsequent uses, firefox thunderbird etc. seem to start faster

  2. vidcutter AUR version needed to be rebuilt (didn’t start), but nordvpn-bin did not

Thanks for the good work and happy new year!


Hello, after the update the computer does not turn off completely. It’s a 2017 iMac. I put down the inxi -Fazy.


>>> inxi -Fazy                                                               
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=d0afa473-0962-44fc-8fdb-20a57fafbde7 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Apple product: iMac18,2 v: 1.0 serial: <filter> 
  Chassis: type: 9 v: Mac-77F17D7DA9285301 serial: <filter> 
  Mobo: Apple model: Mac-77F17D7DA9285301 v: iMac18,2 serial: <filter> 
  UEFI: Apple v: 428. date: 06/16/2020 
  Info: Quad Core model: Intel Core i5-7400 bits: 64 type: MCP arch: Kaby Lake 
  family: 6 model-id: 9E (158) stepping: 9 microcode: DE L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 24008 
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: Apple driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
  Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo 
  bus ID: 1-5:4 chip ID: 05ac:8511 serial: <filter> 
  Display: wayland server: X.Org compositor: gnome-shell 
  driver: amdgpu note: n/a (using device driver) - try sudo/root 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.0x22.5") 
  s-diag: 1166mm (45.9") 
  Monitor-1: XWAYLAND0 res: 3840x2160 hz: 60 dpi: 203 
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
  OpenGL: renderer: AMD Radeon RX Graphics (POLARIS11 DRM 3.39.0 
  5.9.16-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.3.1 direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aae0 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple 
  driver: brcmfmac v: kernel port: 3000 bus ID: 02:00.0 chip ID: 14e4:43ba 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3 
  v: kernel port: 3000 bus ID: 03:00.0 chip ID: 14e4:1686 
  IF: enp3s0f0 state: down mac: <filter> 
  Local Storage: total: 447.13 GiB used: 28.96 GiB (6.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 0107 
  ID-1: / raw size: 325.96 GiB size: 319.85 GiB (98.12%) 
  used: 28.27 GiB (8.8%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 
  ID-2: /boot/efi raw size: 200 MiB size: 196.9 MiB (98.45%) 
  used: 298 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 39.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 265 Uptime: 6m wakeups: 2 Memory: 7.67 GiB used: 2.97 GiB (38.7%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 1325 pacman: 1307 
  lib: 382 flatpak: 7 snap: 11 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.2.01 
~ >>>                                                                          
~ >>>                       

@philm I am glad to help reporting issues.
I also noticed problems with Chromium:

Actually I’m not getting any audio from kernels 5.10 , 5.9 or 5.4

Which Hardware do u use?
Do u have tried 4.19?

As far as I know, after the upgrade your old virtualenvs will not work anymore, and you need to rebuild them. If you have the requirements.txt file, it should be straightforward. Otherwise, you need to remember all the packages you installed in the virtualenv… you may explore lib/python3.8/site-packages directory to see what you had in your old virtualenv.

People have mentioned here issues with Nvidia already, I’m running a laptop with an Intel GPU + 1050Ti and after the update and the reboot all is well, except for one major thing (for me) which is CUDA.

Running nvcc on a .cu works fine, but trying to run it after compiling gives:

the provided PTX was compiled with an unsupported toolchain.

I’m working to solve this ASAP because I need CUDA for a work I have to present due in two weeks, so any help is more than welcome.

Also I’ve always had issues with Nvidia as I only want the drivers to run CUDA, nothing else, I don’t want my X to be on the dGPU or play videogames, but I’ve always had issues to make this work. Before needing CUDA for school I was just using the Intel GPU and everything worked much better, will see how it goes from here with this new update.

Here are the packages installed on my system:

$ pacman -Qe | grep cuda
cuda 11.2.0-1

$ pacman -Qe | grep nvidia
lib32-nvidia-utils 455.45.01-3
linux54-nvidia-455xx 455.45.01-4
nvidia-455xx-utils 455.45.01-1
nvidia-prime 1.0-4

$ uname -a
Linux UD-Legion 5.4.85-1-MANJARO #1 SMP PREEMPT Mon Dec 21 21:38:53 UTC 2020 x86_64 GNU/Linux

After I installed this update I tried to install kernel 5.10 and I get the following error:
/usr/bin/grub-probe: error while loading shared libraries: libzfs.so.2: cannot open shared object file: No such file or directory
Running sudo update-grub gives the same error. I verified that I have zfs-utils installed.
The first time I installed Linux 5.10 I didn’t see the error and I also deleted Linux 5.9, not I only have the fallback kernel, 4.19.
Now I can’t make any kernel besides 4.19 which was already installed to show up in grub. Any help is appreciated!

EDIT: I fixed it by replacing grub-vanilla with grub.


the font is the same but looks different

I have an old nvidia gpu on that computer, had an issue after updating: black screen, no error.

Fixed by opening virtual console alt + shift + F2
installed nvidia drivers packet called linux510-nvidia

Works after that. :+1:

I have intel-nvidia hybrid card. GTX 850M. After the update nvidia-prime not working. Auto install not working. Any help?

Auto install proprietary driver gives me this error.

> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:00:02.0 (0300:8086:0416) Display controller Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
> Dependencies to install:  video-modesetting
> Installing dependency video-modesetting...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-modesetting/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
> Successfully installed dependency video-modesetting
> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
warning: nvidia-prime-1.0-4 is up to date -- skipping
warning: lib32-nvidia-utils-455.45.01-3 is up to date -- skipping
resolving dependencies...
looking for conflicting packages...
:: nvidia-utils and nvidia-455xx-utils are in conflict (nvidia-libgl). Remove nvidia-455xx-utils? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: nvidia-utils and nvidia-455xx-utils are in conflict
Error: pacman failed!
Error: script failed!

Done ...

Hi! Just updated and I can’t run vorta, this is what I get:

Traceback (most recent call last):
  File "/usr/bin/vorta", line 33, in <module>
    sys.exit(load_entry_point('vorta==0.7.1', 'gui_scripts', 'vorta')())
  File "/usr/bin/vorta", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/vorta/__main__.py", line 9, in <module>
    from vorta.models import init_db
  File "/usr/lib/python3.9/site-packages/vorta/models.py", line 17, in <module>
    from vorta.utils import slugify
  File "/usr/lib/python3.9/site-packages/vorta/utils.py", line 22, in <module>
    from vorta.borg._compatibility import BorgCompatibility
  File "/usr/lib/python3.9/site-packages/vorta/borg/_compatibility.py", line 1, in <module>
    from pkg_resources import parse_version
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3239, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 567, in _build_master
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 884, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'apscheduler' distribution was not found and is required by vorta

Seems to be working now, I just rebuilt the packages python-apscheduler and then vorta itself

@rf2020 for nordvpn:

you need to create the system group manually and add yourself to that group:

sudo groupadd -r nordvpn
sudo systemctl enable --now nordvpnd.service
sudo gpasswd -a your user name nordvpn


And this is configured in the OS settings

Hi all!

I have an Intel-Nvidia Optimus Laptop, with manjaro KDE and kernel 5.4 LTS.
After updating to this new stable release, an old issue came up.
During shutdown i got this message

sd-unmount[xxxx]: Failed to unmount /oldroot: Device or resource busy
sd-unmount[xxxx]: Failed to unmount /oldroot/sys: Device or resource busy
shutdown[1]:Failed to finalize file systems, ignoring

I always thought this was an Nvidia driver or a systemd issue. But probably has something to do with manjaro mhwd scripts.

Here is how i solved it (or at least i think i solved it…)

  1. I removed video-hybrid-intel-nvidia-455xx-prime driver with
sudo mhwd -r pci video-hybrid-intel-nvidia-455xx-prime

but i kept video-modesetting intact

  1. I removed with pacman every Nvidia related package, leaving in the end only the mhwd-nvidia-xxx ones. These should not be removed! In the end, i have something like:
$ pacman -Q | grep nvidia

  1. I manually installed with pacman the following packages (in this order)

and the last one…

  1. I rebooted.

After that, no more errors, during shutdown. Both intel and nvidia drivers are loaded ( checked with inxi -Gxxxz ). And the Nvidia driver works on demand. Of course I’m not sure if there is any switching between the two drivers as I don’t know how to check it. Any help?

Otherwise, a flawless update.

Can you be more specific? I can’t find it.

Zeitgeist is an actual dependency of Pantheon Music, it’s not in Orphans, and if I try to remove it, pamac wants to remove Pantheon Music as well, so it’s not just a build dependency.

I’ll just go without a GUI file search until the conflict gets resolved.