[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

I just upgraded to linux510 (sudo mhwd-kernel -i linux510 rmc) but did not see a new Nvidia package for this kernel. Is Nvidia driver 390.138 supported for this kernel?

If not for which kernels does the following change log entry apply?

Nvidia legacy driver got updated to 390.138

Read the OP. :wink:

I bow to your greater experience. :wink:

I used Ubuntu LTS for 6 years. It was reliable for 3 years at a stretch. By then it was so old I wanted to upgrade, but it couldn’t be upgraded in place and I had to completely re-install. This was a pain, as I do a huge amount of customization just to be comfortable, and it took a few weeks to remember all the tweaks and do them again. At the end of the 2nd 3 year stretch, I switched to Manjaro. (Now that I’ve retired from most of my serious work, I have a little more patience for tricky upgrades…)

1 Like

Hey community,

Thx for the feedback so far. Here some answers!

Thx for reminding me. I’ve pushed the update.

You can delete that file. Double check if you have /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG.

If you look at the package changes Pamac is at version 10.0.3-4. So check if your Mirrors have synced yet.

Please open a new thread in our hardware section (Laptop) so we can help. Doing it here it will be lost …

You can ignore those warning: proc: Bad value for 'hidepid' · Issue #16896 · systemd/systemd · GitHub

@The_Quantum_Alpha thx for your tutorial on AMD graphics. I’ll add it to second post: [Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

@D.Dave Thx for the info on .slice. Will add it to the second post: [Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Which Nvidia drivers did you had before the update. Maybe check in /var/log/pacman.log.

Did you check if linux510-nvidia was installed? Please run: sudo mhwd -a pci nonfree 0300

We dropped Python 3.8 support from Manjaro with this update. Open a new thread in our Software Section to help you out. However there is a python38 package in the AUR.

Try to boot another kernel like linux54 and post a new thread about your problem in our Kernel Section.

The issue with Bluetooth and Kernel 5.10 should be fixed in our testing branch. Please switch and confirm.

Please open a new thread in our Hardware Section (Laptop) to help you out with your Hybrid card setup.

You can still install the 455xx driver if your card supports it. Simply uninstall nvidia-390xx drivers and manually install nvidia thru mhwd:

sudo mhwd -r -i pci video-nvidia-390xx
sudo mhwd -i pci video-nvidia

Also provide us your hardware id of your graphics card, so we may add it to the 455xx driver: hwinfo --gfx


Updated yesterday with new kernel 5.10.2. I see no notable glitches.

But in logs constantly, basically every minute, appearing errors like

Dec 31 08:43:11 home-laptop bumblebeed[43241]: Module 'nvidia' is not found.
Dec 31 08:44:12 home-laptop bumblebeed[43358]: Module 'nvidia' is not found.
Dec 31 08:45:12 home-laptop bumblebeed[43474]: Module 'nvidia' is not found.
Dec 31 08:46:12 home-laptop bumblebeed[43585]: Module 'nvidia' is not found.
Dec 31 08:47:12 home-laptop bumblebeed[43700]: Module 'nvidia' is not found.
Dec 31 08:48:13 home-laptop bumblebeed[43815]: Module 'nvidia' is not found.
System:    Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Timi product: TM1703 v: XMAKB3M0P100B serial: <filter> 
           Mobo: Timi model: TM1703 v: XMAKB3M0P100B serial: <filter> UEFI: Insyde v: XMAKB3M0P100B date: 03/22/2018 
Battery:   ID-1: BAT0 charge: 16.2 Wh condition: 17.7/40.3 Wh (44%) volts: 8.3/7.7 model: CPT-COS R13B02W type: Li-poly 
           serial: <filter> status: Discharging 
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 705 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 705 2: 707 3: 744 4: 707 5: 707 6: 742 7: 702 8: 703 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Xiaomi driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d12 
           Device-3: Cheng Uei Precision Industry (Foxlink) XiaoMi USB 2.0 Webcam type: USB driver: uvcvideo bus ID: 1-5:2 
           chip ID: 05c8:03a2 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel s-res: 1920x1080 s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Xiaomi driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 4040 bus ID: 02:00.0 chip ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 46.59 GiB (19.5%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS256GD9TNG-62A0A size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 80000E00 temp: 29.9 C 
Partition: ID-1: / size: 58.81 GiB used: 19.1 GiB (32.5%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: /boot/efi size: 548.9 MiB used: 264 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p2 
           ID-3: /home size: 165.48 GiB used: 27.49 GiB (16.6%) fs: ext4 dev: /dev/nvme0n1p4 
Swap:      ID-1: swap-1 type: partition size: 8.79 GiB used: 2.1 MiB (0.0%) priority: -2 dev: /dev/nvme0n1p1 
Sensors:   System Temperatures: cpu: 33.0 C mobo: 30.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 229 Uptime: 12h 31m wakeups: 17 Memory: 7.68 GiB used: 2.95 GiB (38.3%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1321 Shell: Bash v: 5.1.0 running in: termite inxi: 3.2.01 ```

Same here, and can’t install Catfish without removing Zeitgeist now, which is a requirement for
Pantheon Music.

Everything is fine but i got lots of warning about Manjaro/kernel/sound/soc files

Managed to fix the warning message. Edited the grub config file /etc/default/grub and added rw to the following line so it now looks like this:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet rw udev.log_priority=3”

Then ran the following line in the terminal:

sudo grub-mkconfig -o /boot/grub/grub.cfg

This fixed the warning message.

1 Like

Hmm, I’m getting the following error:

Failed to prepare transaction

could not satisfy dependencies:

  • removing mhwd-db breaks dependency ‘mhwd-db’ required by mhwd,
  • if possible, remove mhwd and retry

Edit: nevermind, worked ok after reboot.

Had literally the same problem. Try this here, it worked for me:

I guess it just became incompatible with the new grub version. :man_shrugging: I used it for years without problems, but in the end I don’t care how the GRUB screen looks like as long as it boots my favourite OS(es) :slight_smile: .

Installation went fine, on a reboot got a message to say install the latest kernel, so I installed 5.10.2-2 from the System Settings - Kernel dialogue. That all seemed to go fine, and so I rebooted, selected the advanced Grub options and selected the 5.10 kernel that I had just installed. However, the system hangs immediately thereafter. Anyone have any suggestions? Have I missed anything out or should I have done something differently?

Hi, usually I edit the taskbar size back and forth to have “unbehaving” icons re-adjust themselves.

This update was the biggest mess for me during all the years with Manjaro KDE. Spent 2 hours fixing it.

Update itself was fine, but after reboot I noticed ugly font and lots of wlan errors during startup, and WiFi (ASUS adapter with BCM4360 chipset) was not available. Multiple reboots and re-installation of Broadcom drivers didn’t help, so decided to switch from Kernel 5.4 to 5.10.

Couldn’t even boot to GUI on 5.10 because of TLP error - Stuck boot at "Finished TLP system startup/shutdown" new kernel Removing TLP didn’t help, still no GUI.

Back to kernel 5.4, noticed that Nvidia drivers (GeForce 1030) were marked as not installed after update (worked fine before). Trying to install them always resulted in error

nvidia-utils and nvidia-455xx-utils are in conflict

After multiple attempts I manually removed nvidia-455xx-utils and GUI instantly crashed. Reboot, no GUI again. Thankfully, I was able to re-install nvidia-utils via CLI. Right after that, GUI was live again, and drivers were marked as installed this time. Except this error:

Warning: config ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’ is invalid!

As per @philm suggestion, removed MHWDCONFIG file and rebooted. Everything was fine, except no WiFi still. Re-installed kernel 5.10, rebooted into it, and - finally graphics and WiFI work fine (but only on 5.10, still no WiFi on 5.4).

The only remaining issue with both kernels is extremely big and blur font now - https://i.postimg.cc/NF6Ztb1b/4032-2268-max.jpg (screen size is “32”, and as you see, a short message uses alsmost all the screen space).

1 Like

I tried to change the size back and forth and it didn’t work, however setting the size to 47 instead of 45 restored the old icons size.
Thank you


Hello ! Since the update, I have a problem with my Grub menu (my computer is in dual-boot with Windows): a second Manjaro entry appeared, and I don’t know how to remove it (I checked /etc/grub.d/, I didn’t see anything unusual).

I also updated the kernel to 5.10, and since then, my computer takes a very long time to shut down.

Does anyone have an idea how to solve these problems?
PS: Happy new year !

Well, nvidia drivers have to be removed before installation, otherwise, system cannot run DE, though TTY works.

As posted in another thread before finding this one:

An excerpt from the bottom of my sudo pacman -Syu --debug output:

debug: started resolving dependencies
debug: checkdeps: package zfs-dkms-2.0.0-1
debug: checkdeps: missing dependency 'zfs-utils=2.0.0' for package 'zfs-dkms'
debug: checkdeps: missing dependency 'dkms' for package 'zfs-dkms'
debug: finished resolving dependencies
looking for conflicting packages...
debug: looking for conflicts
debug: check targets vs targets
debug: check targets vs targets
debug: package zfs-dkms conflicts with linux59-zfs (by zfs)
debug: conflicting packages in the sync list: 'zfs-dkms' <-> 'linux59-zfs'
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: zfs-dkms and linux59-zfs are in conflict

Any ideas? Should I try to upgrade zfs-utils first? Should I first upgrade to kernel 5.10?

Normally I’d try and navigate this myself but I am very reluctant to take extra risks on a home server. Advice is appreciated.

1 Like

That is how I understand it: If you comment it out the warring will go away and the systemd-fsck will not work. You can verify it by running:

systemctl status systemd-fsck-root.service

I am reading more on the subject and as it looks like it all goes to the “Systemd does it all” , I am trying out the systemd-fsck, so I left the grub line, removed the fsck from the HOOKS line in the /etc/mkinitcpio.conf and run:

sudo mkinitcpio -P && sudo update-grub

The systemd detected my filesystems, created services for them and runs the scan on boot.