[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

Update went smooth with UI . Bluetooth problems through previous update are gone.

Good work @ manjaro

works on my new rick: https://linux-hardware.org/?probe=43e87ec746

Ok, to “make a point”:

The misspelling is not the only thing which is wrong. Even in your example, you could see the addtional dash (-) for fasttrack et al is missing in the man.

The EXAMPLES section of the man (the most valued documentation IMHO, I hate enumerations of parameters given as “documentation” or “manual”). Do use too less dashes:

EXAMPLES section

EXAMPLES
Most optional arguments are self explaining others require explanation. The API functions is mainly designed to help packagers and iso-builders. However it can be of use for everyone because it takes the hazzle out of
editing your pacman-mirrors configuration.

Commands
• Which countries has mirrors?

     pacman-mirrors –country-list

   • Which countries in my custom mirror pool

     *pacman-mirrors –country-config

   • What branch am I on

     pacman-mirrors –get-branch

Commands requiring sudo
• I want to permanently change branch to unstable, use mirrors from Germany and France, use only https and http protocol in that order

     sudo pacman-mirrors –country Germany,France –api –set-branch unstable –procotol https http

   • Create a mirrorlist with German mirrors

     sudo pacman-mirrors –country Germany

   • If you want more countries in your mirrorlist add them they will be written to your custom mirror pool

     sudo pacman-mirrors –country Germany France Denmark

   • Create a mirrorlist with 5 mirrors up-to-date on your branch

     sudo pacman-mirrors –fastrack 5

   • I want to choose my mirrors

     sudo pacman-mirrors –interactive

   • I have a custom mirror list and I want to create a new custom mirror list?

     sudo pacman-mirrors –interactive –default

   • I have a custom mirror list - can I reset it?

     sudo pacman-mirrors –country all

Advanced use samples - BEWARE OF THE DRAGONS
(snipped away because not relevant here).

Whoes output would be more handy if it is get outputted when a incorrect parameter is given. Also I’m very sure the short help did not mention continent, but I can’t reproduce that anymore.

Report:

  • encryption OK
  • mkinitcpio.conf not overwritten, no pacnew because last time, doh
  • openvpn works, sans pia, who need a kick in the nuts for bad ipv6 conf

Yet I am still annoyed.

  • Thunderbird… No comment
  • What the hell happened to custom kwin(?) keyboard shortcuts? I see nothing of the sort in kde settings any more. I need my custom commands back!
  • Why the hell does the compositor keep crashing/disabling itself for weeks now?

So to sum up: death by 3 papercuts

1 Like

I see that file system checking is enabled at each boot, I get some messages that my files are clean, I didn’t set any forced check in fstab.

Keys or slider for controlling backlight level in my Dell XPS 15 7590 (with an LED HD display) isn’t working anymore since this update :frowning:.
But if I change the level and then restart my laptop, the new setting is applied.

Any clue ?

I’m under Manjaro 20.2 (KDE Plasma)

EDIT : fix by [Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

Check is being performed by systemd services:

systemd-fsck@.service
systemd-fsck-root.service

It sounds like maybe the khotkeys package was removed?

2 Likes

black screen after laptop suspend after upgrading to 5.9.8-2, rolled back to 5.9.1_rt10-1 fixed it

A post was split to a new topic: Wine not detecting wine-mono

But I didn’t have those messages before this update, is fsck service necesssary for my system ? and from what I see it’s launched before local-fs.target and shutdown.target.

Since the previous update I got this issue with the kickstart menu in KDE-Plasma.

In advance I appreciate all the help.
Regards

Manjaro KDE; Lenovo T440 - will provide more info as appropriate but may start a separate thread.

Following the upgrade (Note: still on first run following reboot), Bluetooth drops the connection to my Doqaus Care 1 Headset when audio playback stops. I will run more tests but what should happen is that the headset itself switches off after a few minutes of silence and switching them back on should re-establish a connection.

There seems to be no auto-connection with this headset now, nor the Bluetooth speakers. It does seem to have established a stable connection with my BlackBerry though, which wasn’t the case up until now. Only file transfer from the phone to the PC was useable, initiated from the phone, and even that was a bit temperamental sometimes.

The BT panel icon was also missing on initial reboot; I had to put that back after restarting bluetooth.service.

I’ll investigate further & see if I can find the culprit.

N.B. I haven’t read all the way through this thread, will do so now, apologies if this has already been raised.

ETA:
The connection to the OlixarBoom speakers just dropped after approx. 8 minutes and promptly re-established the BT link. I’ll keep testing tonight with my BT devices.

FETA:
I see I’m not the only one experiencing audio issues. Note my inbuilt speakers continue to work after BT bails out.

1 Like

Greetings,

I’m getting black screen after update. On all kernels.
4.19 - 5.9

Using nouveau driver

startx (not working - Couldn’t exec startkde: no such file or directory)
startplasma-x11 (not working - $DISPLAY is not set or cannot connect to the X server)

Any help with this is appreciated

AT

Thanks for that @chomsky I will look at that. Didn’t have an issue before though with the OlixarBoom boom-brick or loss of link with the Doqaus headset whilst these stayed on (an inbuilt powersave feature in the headset turns those off normally after about 5 mins of complete silence but this doesn’t seem to be happening now).

After the update my system booted to a black screen. Switching to tty1 also only showed a black screen. Switching back to tty7 or tty1 again would then show blinking cursor.

I was able to fix by logging into tty2 and removing/re-installing the nvidia drivers w/ mhwd

Previously I was running kernel 5.8.18 and nvidia 455.38
After update I was(am) running kernel 5.9.8 and nvida 455.45
The GPU is a GTX 1070.

Hopefully this helps anyone else with a broken system after the update.

I have issue with my bluetooth speker since the previous release. The Blueman crashed a lot. My bluetooth speaker keeps getting disconnected when i play nothing. Disconnection never occures when i forced my PC to play a really long video.

Running XFCE Manjaro, on 5.4 Linux Kernel.

[quote=“LA-MJ, post:169, topic:38196”]
Yet I am still annoyed.

After reading of your problem, I tried on my own systems. 1 desktop and 1 laptop. My shortcuts and commands are still there.

As far as I remember kwin (.config/kwinrc) does the windows, desktops and compositing. Look for kglobalshortcutsrc

It works here on both machine but I use amdgpu. Look into your amdgpu/nvidia config for opengl

Hope this will help

Exactly what it says.

Hello,

I hope, someone can help me to fix my Libreoffice. Last update (2020-11-18) broke the GUI of my Libreoffice in that way, that it doesn’t use the systems theme (arc/Cinnamon) anymore. Instead it looks like old Windows 95/98. Just to tell you, it is an old version of Libreoffice 4.06 and 32-bit I use in a x86_64, because I need it for a certain extension. I had build it from AUR some years ago (lib32-libreoffice-de) and it worked until now with no complains. I’m not able to tell, what update is responsible for this behaviour so far, because it had been rather a lot of updates this time. Until now this problem doesn’t occur on an other installation with archlinux (32-bit) itself.

Thank you for helping me.

Oslo