KDE Plasma kickstart issue: loop message "Applications updated."

Since the stable update of 2020-11-04; the problem of a kickstart appeared again in the menu, this kickstart interrupts the use of the menu, with a message that says: “Applications updated.”

I exhausted all my previous tricks that allowed me to correct it, delete the folders:


This problem is repeated in 2 PCs, one with nvidia graphics card and one with intel.
I found some tricks but no luck

kbuildsycoca5 --noincremental

I ran this at home but nothing was fixed, even here at work.

And I see that this file is being recreated each time I try to check the kickstart menu

I’ll try something to delete/rename this ksycoca5 restart and check is something changes. (and report back)

In this, my office PC, got this info:

mhwd --listinstalled
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Thanks for any help to fix this issue. Regards

Edit #1. Also dolphin is behaving strangely, very slow it gets stuck on things that before … configure, assign applications to open files.

Now, all I have left is the next test:

Exit my session, from a terminal rename the folders: .local, .config and I think also delete .cache; and so try to find the culprit. I will have to spend hours reconfiguring my profile :frowning_face: .

2020/11/26. I disable all the animations (taskbar, plasma) I got a more responsive system, but the original loop issue persist. I think that I need to recreate my user profile… but don’t have time at this moment.

On past monday, I see a “recursive warning” in the log, then I edit the file :


And return the “old” line of code that was changed recently:

mainItem: Loader {
    id: sidePanelStack
    asynchronous: true
    width: item ? item.width: 0
    height: 1000 //start with some arbitrary height, will be changed from onVisibleChanged
    //height: containment ? containment.availableScreenRect.height - sidePanel.margins.top - sidePanel.margins.bottom : 1000
    state: "closed"
1 Like

I have the same issue with you and I also realized that when I right-click to the desktop or a panel the “Add Panel” entry shows up but disappears. I think these 2 bugs could be related


It’s got something to do with the file ~/.config/mimeapp.list
It stopped when I deleted it

1 Like

I also have both issues, application update loop and diasppearing “add panel” entry. Deleting mimeapps.list “fixes” both issues. But it is the file for default applications, so we need it.

EDIT: Moving mimeapps.list file to .local folder fixes the issue keeping default apps as is.
mv ~/.config/mimeapps.list ~/.local/share/applications/

I restated the issue here also: Location of mimeapps.list file in .config folder causes plasmashell, dolphin and panel problems


There have been Stable Updates after 11-04. Any difference?

I have these issues with last stable update (2020-11-27). I’m not sure when the issue started for me, but I’m sure it was before the last update.

Sorry, I moved to a new house and I only have Internet today; I will try these new updates from last week.

But the problem persisted in the last 2 updates in November.

Thank you @ceres; I will try your solution, although if I remember correctly, I did something similar (delete the file), now I will try to copy it.



Same issue here, mv ~/.config/mimeapps.list ~/.local/share/applications/ was the fix for me!

1 Like


Sadly, no solution has worked for me.

I will have to apply the nuclear solution: rename my profile and start migrating all settings and documents until the culprit is located. The bad thing is that I don’t have much time for this.

Hopefully, I will be able to detect the cause and document it.


I just freshly installed OS using latest 20.2 ISO and after a few minutes issue begins… I tried above solution works for a bit until it starts up again… Fresh install nothing installed yet… Well, except LibreOffice fresh…

This problem in KDE, brings my PCs to their knees.

On very rare previous occasions, this problem fixed itself, but lately, new updates arrive and the problem simply does not get fixed. All the tricks that worked for me have failed, except the recreation of the profile that I need to try. But if the problem occurs in new installations, I don’t think it will work to recreate the profile this time.

I wouldn’t want to desert Manjaro either; it’s been many years and he has proved to be great except for this flaw. I am being drawn to jump into Garuda (KDE) only to miss Manjaro again and return to it. :thinking:

I will never leave KDE I am currently on a working install of sorts. Just having flatpak-plugin issues where it’s breaking pamac GUI… I created a thread for it awaiting a fix otherwise I want to install fresh start from zero on a separate SSD… For now until a fix is found I will remain on current setup…

At one point (*in the past), I found that some appimage, flatpak, bauh applications try to create menu entries causing this problem. I don’t remember if I had to delete the entries from the menu or rename the folder from the path.

(* note added)

I am certain someone will find a solution gotta be patient…


Same issue here.
Moreover, before command:

mv ~/.config/mimeapps.list ~/.local/share/applications/

in Settings > Kernel panel, my second kernel (not in use) was not marked as Installed.
After moving the file, now that kernel is marked properly.

More precisely, I didn’t got the “application updated” message, but I couldn’t click on any item in the Application Menu. The sub-menus appeared only for one second and then freeze the panel. Cpu usage for plasmashell was about 60%.

Waiting for a permanent patch… :innocent:

1 Like

Somebody already posted a fix, and 3 hours in with countless packages installed issue has not creeped out anymore…

Seems like the problem lies in kservice-git package.

I am quite sure it was pulled by installation via manjaro architect. No idea why are kf5-git packages pulled in by default insead of regular ones…

After removing the package and installing non-git version, the issue does not seem to return anymore.

sudo pacman -Rdd kservice-git ktextwidgets-git kwallet-git

And install back regular package version:

sudo pacman -S kservice ktextwidgets kwallet

I am good to go… Also no need to do the move file thing, I didn’t, I rand those 2 commands as soon as Install was done… :smiley:


@TechXero, not always the problem is kservice-git package.
I have not that package.

@gan Am on KDE and as soon as I did what I mentioned above I haven’t had any issues… And am on a fresh install …

Me too, I mean, fresh install (ten days old).
I got the problem after last update.
Clearly, the bug is more difficult to trace what it seems. :thinking:

@gan 10 days old ok. Me just couple of hours old. I hope issue doesn’t creep up for me. As for you try running commands anyway as those packages are part of Manjaro KDE 20.2…

1 Like