[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

Hello community,

Another stable branch update with some usual updates for you!


Soon to be a thing: AMD Ryzen Mini-PC by Beelink … #stayhome, #staysafe, #stayhealthy

  • Most of our Kernels got renewed. 5.8 is now marked EOL
  • Linux-latest now pulls 5.9 instead of 5.8
  • KDE Plasma5 is now at 5.20.3
  • KDE Frameworks got updated to 5.76.0
  • Firefox got updated to 83.0
  • Thunderbird is now at 78.4.3
  • Mesa is now at 20.2.2
  • OnlyOffice got updated to 6.0.1
  • Deepin got new package updates
  • Another beta and stable release of Firefox
  • LxQT 0.16.0 got released
  • Wine is at 5.21
  • AMDVLK is now at 2020.Q4.4
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release candidate! KDE, XFCE and Gnome


Our current supported kernels

  • linux44 4.4.243
  • linux49 4.9.243
  • linux414 4.14.206
  • linux419 4.19.157
  • linux54 5.4.77
  • linux57 5.7.19 [EOL]
  • linux58 5.8.18 [EOL]
  • linux59 5.9.8
  • linux510 5.10-rc4
  • linux54-rt 5.4.77_rt43
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed Nov 18 06:56:34 CET 2020)

  • stable community x86_64: 1587 new and 1572 removed package(s)
  • stable core x86_64: 37 new and 37 removed package(s)
  • stable extra x86_64: 877 new and 909 removed package(s)
  • stable multilib x86_64: 29 new and 30 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

20 Likes

Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/


Older Issues

Please click the ► at the beginning of this line to view the older issues

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

4 Likes

Still user-manager is version git. Causes part of kde frameworks is git - 5.77 version.

1 Like

Any idea of when the 20.2 RC 2 is uploaded? the links are dead now

Its uploading now

Great work; everything works fine (kernel 5.9.8, gnome, qemu …). Thanx!

After the reboot I unintentionally had kernel 5.8 active, before the update it was intentionally kernel 5.4 LTS. Then I installed kernel 5.9 because 5.8 is EoL, but 5.9 didn’t activate itself after the reboot as manual work again. What is wrong?

1 Like

Hi Im using CoreCtrl to slow down amd gpu fan spin but after update it doesnt start anymore. Im using stable kernel 5.4.77, but tested with 5.8 and 5.9.8 same issue

1 Like

It might need a rebuild. Can you open a terminal and try to start it from there?

Small correction: Actually it’s version 78.4.3. My account status doesn’t allow me to quote links or provide the correct link to the release notes.

1 Like

Just updated to the latest version. I noticed my audio devices are disabling after boot. It doesn’t happen instantly, but gradually a few minutes after boot.

My main audio device is a Focusrite Scarlett Solo 2nd Gen, which gets detected and works, but stops working after a while.


EDIT:

I get these logs the moment the audio device disconnects:

|18-11-2020 12:44|kernel|xhci_hcd 0000:0a:00.3: xHCI host not responding to stop endpoint command.|
|---|---|---|
|18-11-2020 12:44|kernel|xhci_hcd 0000:0a:00.3: USBSTS: EINT|
|18-11-2020 12:44|kernel|xhci_hcd 0000:0a:00.3: Host halt failed, -110|
|18-11-2020 12:44|kernel|xhci_hcd 0000:0a:00.3: xHCI host controller not responding, assume dead|
|18-11-2020 12:44|kernel|xhci_hcd 0000:0a:00.3: HC died; cleaning up|
|18-11-2020 12:44|kernel|usb 5-1: USB disconnect, device number 4|
|18-11-2020 12:44|kernel|usb 5-2: USB disconnect, device number 3|

Update: I connected the audio interface to a USB 2.0 port. The device was previously connected to a USB 3.0 port.

I still think this difference shouldn’t be an issue, because it worked fine before. Did something change related to audio in this update?

4 Likes

I made the update on three computers:

  1. 1 * KDE: update went fine
  2. 2 * XFCE: update went fine

Thanks!

2 Likes

corectrl: error while loading shared libraries: libbotan-2.so.16: cannot open shared object file: No such file or directory

Seems like there is a rebuild of corectl needed. @schinfo will check that and might provide the needed fix.

got this message in pacman log

    `OpenVPN now uses a netlink interface for network configuration. The systemd
[2020-11-18T11:39:18+0100] [ALPM-SCRIPTLET]    units start the process with a dedicated unprivileged user 'openvpn', with
[2020-11-18T11:39:18+0100] [ALPM-SCRIPTLET]    extra capabilities(7). The configuration should no longer drop privileges,
[2020-11-18T11:39:18+0100] [ALPM-SCRIPTLET]    so remove 'user' and 'group' directives.
[2020-11-18T11:39:18+0100] [ALPM-SCRIPTLET]    Scripts that require elevated privileges may need a workaround.`

user-manager has been worked into plasma-desktop, so it’s no longer present in the repo. user-manager-git would be suggested, because it “provides” user-manager.

To clarify. You don’t need User Manager. It’s provided by the main Plasma packages now.

KDE 5.20, NVIDIA 455.x, Kernel 5.4 here - the upgrade causes me to be stuck on boot due to a regression in the sddm display manager. Appears to be a race condition, the NVMe drive might be too fast!

Downgrading to sddm 0.18.1 lets me boot to the graphical desktop.

Edit: Fixed with sddm 0.19.0-2.2 - auto login had something to do with it

4 Likes

Try if sddm-0.19.0-2.1 fixes your issue.

Check if corectrl 1.1.1-4 fixes the issue for you.

Im unable to find this version only 1.1.1-3 from official repo the latest. I was able to rebuild it from aur 1.1.1-2 and that fixed it