Wine not detecting wine-mono

With the past few Wine updates, I get the message in the attached image when Wine updates my 32-bit Wine container.

I have wine_5.21-1 and wine-mono_5.1.0-1 installed from the Manjaro Official Repositories. I click Cancel since I would prefer to use the Manjaro Official Repositories.

However, WineHQ seems to indicate that wine-mono_5.1.1 should be used with wine version 5.19 (and I assume newer). Is this the issue?

https://wiki.winehq.org/Mono#Versions

Wine_Mono_Installer

You’ll need to install wine-mono-bin (also wine-gecko-bin if needed) from the AUR.

Still get the same message after wine-mono-bin install from the AUR. Also installed wine-mono-gecko-version-fix from the AUR to see if that resolved the issue. Confirmed that /usr/share/wine/mono/wine-mono-5.1.1 is present now.

Download https://dl.winehq.org/wine/wine-mono/5.1.1/wine-mono-5.1.1-x86.msi, move it to /usr/share/wine/mono/

Edit: If you do this, to prevent possible issues during updating in the future, you should do one of the following:

# 1: Move the file to user cache, but it will only work for the current user
mkdir ~/.cache/wine; sudo mv /usr/share/wine/mono/wine-mono-5.1.1-x86.msi ~/.cache/wine/
# 2: Or remove the wine-mono package
sudo pacman -R wine-mono
# 3: Or delete the downloaded file before system update if wine-mono has been updated to 5.1.1
sudo rm /usr/share/wine/mono/wine-mono-5.1.1-x86.msi
# 4: Or allow pacman to overwrite that file on the next update that has wine-mono updated to 5.1.1
sudo pacman -Syu --overwrite usr/share/wine/mono/wine-mono-5.1.1-x86.msi

Have you tried to rebuild wine with the new version(of mono) for wine to regonize the replacement? Comments in the AUR seems to suggest that’s the case.

Then just use the built-in downloader for now.

If for any reason someone wants to install the non-shared version, they can use Wine’s automatic built-in downloader.

https://bugs.archlinux.org/task/62351?project=5&string=wine-mono

These packages are also in the official repos.

Thanks everyone for the comments. The solution by wntr worked for me.

I have experienced the same problem. I downloaded this *.msi as recommended. In attempting to move it to /usr/share/wine/mono, I am prevented from doing so due to lacking the requisite permissions. Can anyone help me to ascertain the steps I should take now? Thanks, Jules

Never mind. I figured this out. Silly me. It just needed to be moved in the terminal emulator. I had lazily thought I could do so in the File Manager. Problem solved.

Sure, but…

…there will be conflicting files when wine-mono updates.

Right, because you really shouldn’t be manually placing files in the system. That’s why we have a package manager.

Again, there’s ongoing discussion:

https://bugs.archlinux.org/task/62351?project=5&string=wine-mono

1 Like

I’ve spoken too soon. Yes, I moved this *.msi, but in so doing I have created a different problem, addressed by Yochanan in a helpful reply to me. I will need to study the discussion to which that reply directs me. Meanwhile, I am as of yesterday suddenly unable to launch a Windows application that has worked perfectly well in Manjaro by way of Wine since I installed it six months ago. I will apply myself and report back should I learn anything of use to others.

After trying some of the strategies mentioned in this thread, all of which failed, I removed Wine from the system and then installed it again from the repositories. When I then attempted to launch applications that rely upon Wine, I received two messages from Winetricks. First, this one:

You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.

Then, a few minutes later, this one:

wine cmd.exe /c echo ‘%AppData%’ returned unexpanded string ‘C:Program Files’ … this can be caused by a corrupt wineprefix (wineboot -u may help), by an old wine, or by not owning /home/juleslevinson/.wine

At present, I do not understand either of them well enough to act in a way that will prove effective. If anyone can explain them to me, I would appreciate their doing so. Thank you.

A possibility, updated my post just in case. @LS650V @juleslevinson

On the wine-mono package, by the looks of its state and the thread you’ve linked, seems its either going to be dropped, or the PKGBUILD will be replaced with the one from AUR.

Per your suggestion, moved /usr/share/wine/mono/wine-mono-5.1.1-x86.msi to ~/.cache/wine/. Also copied any remaining msi files from /usr/share/wine/mono/ and /usr/share/wine/gecko/ to ~/.cache/wine/. Removed the wine-mono and wine-gecko package from my installation so there should not be any conflicts now. I will manually download appropriate msi files in the future as necessary.