[Stable Update] 2020-09-08 - Kernels, Mesa, Browsers, KDE Apps 20.08.1, Systemd, LibreOffice 7.0.1, Deepin

Hello community,

Here comes our latest stable package update.


Get the latest Phosh image for your PinePhone #stayhome, #staysafe, #stayhealthy

  • Some more KDE-git and Deepin package updates
  • LibreOffice is now at 7.0.1
  • KDE Apps are now at 20.08.1
  • Palemoon browser got renewed to 28.13.0
  • Systemd got another point-release
  • File conflict with dunstify got fixed
  • Firefox got updated to 80.0.1 and 81-beta4
  • Gambas 3.15 saw it’s first point-release
  • Most of our Kernels got updated
  • Wine is now at 5.16
  • We added CoreCTRL so you can tweak your grahics cards better
  • AMD managed to get another AMDVLK release out
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest RC of Manjaro Mikah 20.1! XFCE, KDE and GNOME


Our current supported kernels

  • linux44 4.4.235
  • linux49 4.9.235
  • linux414 4.14.196
  • linux419 4.19.143
  • linux54 5.4.62
  • linux57 5.7.19 [EOL]
  • linux58 5.8.6
  • linux59 5.9-rc3
  • linux54-rt 5.4.61_rt37
  • linux56-rt 5.6.19_rt12

Package Changes (Tue Sep 8 11:50:26 CEST 2020)

  • stable community x86_64: 1743 new and 1716 removed package(s)
  • stable core x86_64: 63 new and 60 removed package(s)
  • stable extra x86_64: 944 new and 948 removed package(s)
  • stable multilib x86_64: 28 new and 27 removed package(s)

A list of all package changes made in this update can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

20 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable-Staging Updates Announcements RSS feed

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

Older Issues

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

7 Likes

Smooth update 2 hrs ago! :wink: I wrongly replied to the ARM post then. @Strit pulled me up on that one :laughing: Never mind. This update is just fine on my XFCE setup. Many thanks Manjaro Team :grin:

1 Like

Everything went well.
I had the ==> WARNING: Possibly missing firmware for module: xhci_pci warning.
Linux58/440 kde.

Thanks for the updates <3

1 Like

Almost everything ok on my Xfce + 5.8 kernel.
Just got this warning :

(14/24) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_ADDRESS = "fr_FR.UTF-8",
	LC_NAME = "fr_FR.UTF-8",
	LC_MONETARY = "fr_FR.UTF-8",
	LC_PAPER = "fr_FR.UTF-8",
	LC_IDENTIFICATION = "fr_FR.UTF-8",
	LC_TELEPHONE = "fr_FR.UTF-8",
	LC_MEASUREMENT = "fr_FR.UTF-8",
	LC_TIME = "fr_FR.UTF-8",
	LC_NUMERIC = "fr_FR.UTF-8",
	LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Applied that : [HowTo] Troubleshooting locale errors

Have this :

[meuh@ordi1 ~]$ localectl
  System Locale: LANG=fr_FR.UTF-8
      VC Keymap: fr
     X11 Layout: fr
      X11 Model: pc105
[meuh@ordi1 ~]$ locale -a
C
en_US.utf8
fr_FR.utf8
POSIX
[meuh@ordi1 ~]$ 

1 Like

Hello,

One warning directory permissions differ on /var/lib/mlocate/ filesystem: 755 package: 750 manjaro
Is this important or it can stay as is??
Other than that… all went smooth XFCE kernel 4.19

only run

sudo chmod 750 /var/lib/mlocate
3 Likes

My update fails with the following result.

:: Starting full system upgrade...
:: Replace xapps with community/xapp? [Y/n] y
looking for conflicting packages...
:: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux419-nvidia-440xx
:: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils' required by lib32-nvidia-440xx-utils

P.S. I am using Optimus Manager and not the default Manjaro Solution

1 Like

Went smooth but:
KDE: akonadiserver didn’t start.
That’s the same Problem which we had with the last update:
sudo aa-complain /usr/bin/akonadiserver
helps.
like mentioned in “akonadi-cant-launch-mysqld-after-update-of-mariadb

1 Like

I have the same issue:

:: Starting full system upgrade...
:: Replace xapps with community/xapp? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils' required by lib32-nvidia-440xx-utils

Edit:
As noted by vostmarhk, cuda was the root of the problem. I removed cuda, updated, switched to 450.xx and then reinstalled cuda for a sucessful update!

2 Likes

Upgraded on KDE, so far so good. It seems that CUDA no longer works with Nvidia 440, but requires 450.xx. So I am attempting for a second time to transition to the 450.xx, we’ll see if compositing and screen locking are still breaking in KDE after every other suspend with this driver or not.

Edit: it seems that a number of people on Nvidia have issue updating (me included, but I worked around it), because CUDA or some other package now depends on the 450.xx driver without any warning. I suggest you add this issue and workarounds (upgrading 440->450 or removing Cuda) to the known issues.

3 Likes

you cannot have both nvidia-440xx and nvidia-450xx installed. You need to decide for one or the other.

I’ve had the same issue. if you have CUDA package installed, you have to remove it if you want to stay on the 440 driver. Otherwise, you have to remove the 440 driver and install the 450.

1 Like

Also upgraded on KDE

“So far” no issues.

However the during upgrading I got

[ALPM] warning: directory permissions differ on /var/lib/mlocate/
filesystem: 755 package: 750

This warning seems occasionally reported in update threads. Not sure if it’s an issue or not.

Also, QEMU requires a Braille display driver.

I find it kinda weird that qemu has brltty as hard dependency while I’m sure not many people will use it.

More PAM and PAMBASE? :confused:
this time I have timeshift loaded…
and pacnew is … not that new anymore…
:grin:
Edit - I checked the shopping list for this one, no PAM…still, backups will be made before updating :slight_smile:

1 Like

ähnliches Problem:

:: Starte vollständige Systemaktualisierung…
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
:: nvidia-450xx-utils und nvidia-430xx-utils stehen miteinander in Konflikt (nvidia-libgl). nvidia-430xx-utils entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Unerfüllbare Abhängigkeit ‘nvidia-430xx-utils=430.64’, benötigt von linux54-nvidia-430xx
:: Entfernen von nvidia-430xx-utils verletzt Abhängigkeit ‘nvidia-430xx-utils’, benötigt von lib32-nvidia-430xx-utils

Die Deinstallation von Cuda löste auch hier mein Problem!

see up @papajoke

Rt3090bc4 not working in 5.4 and 5.7 kernels without boot flag pci_aspm=no or pci=noaer , both of THEM are working too.
Without these parameters there is no possibility to view any WiFi… What is going on?

Thanks, I overlooked that part.

But somehow after the upgrading of mlocate, it seems the permissions of /var/lib/mlocate are set to 750. At least not with my interference. So I hope I didn’t had to chmod /var/lib/mlocate before the upgrading.

Updated 3 versions of Manjaro Openbox on 2 Desktops and 1 laptop no problem other than the mlocate permissions (solution from @papajoke)