Nvidia-450xx-utils and nvidia-440xx-utils are in conflict

There could be light at the end of the tunnel. Now install nvidia-450xx-utils, or is that premature, I’m not sure…Check Pamac.

I’m a step ahead of you :smiley:

https://imgur.com/a/zPptvAI

1 Like

Yep, fair play :laughing:

Follow (tracking) this thread, it seems we’re close to a solution :crossed_fingers: :smile:

Note: I updated to 450xx in System > Hardware Configuration and uninstalled the 440xx there as well, this after I ran:

sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils linux58-nvidia-440xx cuda nvtop
1 Like

:white_check_mark:
Your System is up to date!

:checkered_flag:

1 Like

Rock ‘n’ Roll! :metal: :grin:

Leave the thread open because @Olomorn needs to read this too. I think he’s crashed out for now but it might be useful when he wakes up :laughing:

To sum up (I think):

  • I installed Kernal 5.8.6 using System Settings > Kernel
  • I edited Grub: sudo nano /etc/default/grub and changed GRUB_TIMEOUT from 0 to: GRUB_TIMEOUT=10 (may not be an issue for you if you get Grub Menu already.)
  • I ran sudo update-grub and rebooted.
  • I hit the Shift key (and tried F8 while at it but, it may have just went straight there, not sure which) to get the Grub menu.
  • I choose a menu option (but forget which) and selected Kernel 5.8.6.
  • I ran the following command to remove the 440xx: sudo pacman -R linux54-nvidia-440xx nvidia-440xx-utils linux58-nvidia-440xx cuda nvtop
  • I installed video-nvidia-450xx using System Settings > Hardware Configuration ( https://imgur.com/a/zPptvAI)
  • I uninstalled video-nvidiea-440xx while there.
  • Updated using Pamac, now with no conflicts.

Aside: I’m in the process of reinstalling cuda using Pamac, this for Blender’s sake and I left nvtop uninstalled, as I don’t use it.

Thanks for your help everyone!

3 Likes

Good summary, kudos :smile:

Well, I run into the same error message about 440 and 450 driver conflict. I was not alarmed and manually removed nvidia 440 driver. Run installation. It succeeded and … lightdm failed to start on reboot.

I was able to login using console. Then as root I executed the following command to let it autodetect my card and install drivers for it:

mhwd -a pci nonfree 0300

I took command from wiki documentation on " Configure Graphics Cards".

Reboot again and I am back in business and reporting the solution to this thread.

Here is what I see if I list installed packages on my machine:

pacman -Qqe | grep nvidia
lib32-nvidia-450xx-utils
linux57-nvidia-450xx
linux58-nvidia-450xx
nvidia-450xx-utils
1 Like

There seems to be a lot of issues between the free and non-free drivers still. I have had similar issues that were unrelated to nvidia but affected my trackpad and hotkeys. It goes on and on…

But it’s good to know we all share our knowledge and experiences :grin:

❯ pacman -Qqe | grep nvidia
lib32-nvidia-450xx-utils
linux54-nvidia-450xx
linux58-nvidia-450xx
nvidia-450xx-utils

So. I’m back on my computer. I read what you said and now I’m trying to remove every conflicting packages, update my system, and then reinstall the necessary packages.
So I did this:

>>$ sudo pacman -R nvidia-418xx-utils lib32-nvidia-418xx-utils linux57-nvidia-418xx linux54-nvidia-418xx linux419-nvidia-418xx cuda linux-latest-nvidia-418xx nvidia-prime

and now I can update with sudo pacman -Syyu ! Which is a notable improvement.

I am a bit worried though, because I know that sometime graphic driver can be a pain to install, and I’d rather do something else than configure everything again… but I’ll think about this after the updates :sweat_smile:

If worries … make sure to force/install/reinstall your preferred driver profile.
ex:

sudo mhwd -f -i pci video-nvidia-450xx
1 Like

Hey so…
The update is completed, everything seemed ok, I installed video-nvidia-450xx and nvidia-prime and all was well. Then I rebooted and nothing works anymore :cry:

At boot I can select Manjaro on the grub screen, and then nothing, just a black screen. From this black screen, I can open a terminal with Ctrl Alt F2. I tried startx but it did not work, and I don’t know how to troubleshoot this further… Maybe I should open a new topic for that ?

This indicates you have a dual-gpu setup … meaning you should not be installing just an nvidia profile … but a prime profile, like video-hybrid-intel-nvidia-450xx-prime

okay, that’s weird I have to install this since I didn’t remove anything like this (at least I think so?)

also this package does not seem to be available, is it an exact name or just an example of what to look for? I am pretty useless without precise instructions, sorry

I’ll keep searching on the internet for now anyway :sweat_smile:

Edit: it seems I am stupid and didn’t see that the driver you mentioned was already installed…

Okay so I basically removed all the drivers I could, except for an old bumblebee one and now it works so I’m gonna leave it at that for now, thank for your help everyone <3

Edit: I lied, I didn’t leave it at that :stuck_out_tongue:
I have completly removed bumblebee and everything that was necessary and now I have installed video-hybrid-intel-nvidia-450xx-prime as you said, Cscs, and it works perfectly! Yeah!

@cscs @wordler @Olomorn and whoever else is still reading this, I’ve summarized this thread into the stable update wiki so if you could have a read and tell me if I missed something?

I’ve also marked Natetronn’s answer as the solution for this issue,

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.