Akonadi can't launch mysqld after update of mariadb

Hi there, as described in the update-post (here and here )after the update to mariadb 10.5.5-1 akonadi won’t start for me with the error

org.kde.pim.akonadiserver: Starting up the Akonadi Server…
org.kde.pim.akonadiserver: Failed to detect mysqld version!
org.kde.pim.akonadiserver: Could not start database server!
org.kde.pim.akonadiserver: executable: “/usr/bin/mysqld”
org.kde.pim.akonadiserver: arguments: ("–defaults-file=/home/termy/.local/share/akonadi/mysql.conf", “–datadir=/home/termy/.local/share/akonadi/db_data/”, “–socket=/run/user/1000/akonadi/mysql.socket”, “–pid-file=/run/user/1000/akonadi/mysql.pid”)
org.kde.pim.akonadiserver: process error: “execvp: Permission denied”

when i start sql manually before, with the same arguments it works just fine:

mysqld --defaults-file=/home/termy/.local/share/akonadi/mysql.conf --datadir=/home/termy/.local/share/akonadi/db_data/ --socket=/run/user/1000/akonadi/mysql.socket --pid-file=/run/user/1000/akonadi/mysql.pid [130]
2020-08-22 16:16:36 0 [Note] mysqld (mysqld 10.5.5-MariaDB) starting as process 8932 …

and after that akonadi start up normally.
So it seems it is some kind of permission issue that akonadi is no longer allowed to run mysqld?
When i downgrade mariadb to 10.4.14 everything work normally again.
I hope anybody has any ideas on how to further troubleshoot, i couldn’t find any matching issues on the internet, only ones where myslq won’t run and am kind of out of ideas…


I read and tried, did the suggested but mysqld doesn’t start. Conclusion Akonadi is unusable in Manjaro, tried in Neon ok, tried in Arch ok

I read some old posts and did this:

> [Debug]
Tracer = null

[% General]
Driver = **QSQLITE**

% 23ServerPath = / usr / bin / mysqld
Host =
Name = akonadi
Options = "UNIX_SOCKET = / run / user / 1000 / akonadi / mysql.socket"
ServerPath = / usr / bin / mysqld
StartServer = true 

I replaced the original driver with this driver and with Arch linux rewrote / usr / bin / mysqld which is the link.
After this, Akonadi works and Korganizer, but a little shaky, but I opened the exported file with Korganizer, not import, and the system accepted. It’s not a solution, I call it patching with a stick and rope.

i’m not really sure if i can follow what you did there? O_o

also, just to be sure: you did replace my username with yours when you tried to launch mysqld manually, right?

@Termy ,

It is normal for me to try your proposal, it is normal for me to replace your name with mine. :slight_smile: That way I start aconads but there is no use of it. I also did downgrade files, but I didn’t manage to get my personal calendar into the calendar.
usr/bin/mysqld is link to mariadb
There are 2 drivers Driver = QSQLITE and QSQLITE3, I put the stars to emphasize because I don’t know the forum notation whether bold
An empty space is inserted by the forum and the line% 23ServerPath = /usr/bin/mysqld is inserted by the google translate
I used the QSQLite driver. When I started Korganizer I somehow inserted my exported .ics file and got my dates in the calendar. A sloppy solution but until the problem is solved I am satisfied
Maybe pure luck, but I see that there is no proposal and no official solution. Due to the changes that are halfway and I read somewhere that mariadb does the db conversion but not for aconadi.

I’m giving up, this is not normal in the header of the message I’m writing, it says that I can upload pictures, it says that I can link, and when I do that, it can’t

This seems to be related to apparmor.
sudo aa-complain /usr/bin/akonadiserver fixed it for me.

Once the issue is fixed, or if this doesn’t help in your case, you should issue a
sudo aa-enforce /usr/bin/akonadiserver,
to reactivate apparmor.


wow, thank you!
aa-complain did solve it for me :smiley:

To hone my troubleshooting skills: how did you figure out it was related to apparmor?

I can’t get a result. I neatly restored the files I saved before my changes. Restart the system, did the suggested commands and the result was nothing. The server reports the same error as before. Restart again typed the same suggested pieces and again nothing.
There is no personal calendar item in the organizer. All of this is unstable and I just ruined what worked for me. I can return my exported calendar in which the birthdays are. Thanks for the suggestions but because of this I will not reinstall the system, I am not in win98. Thank you for your help :slight_smile:

This sometimes works but only until the first restart or switch to another linux
I compared Arch and Manjaro. In the arc everything works ok and in the minor as if it is a disagreement of the Korganizer program. There is no Local Calendar in Manajr, I searched for settings and I don’t find anything with that name.
When you try to import an .isc file that contains Local Calendar, it either doesn’t import it or imports it into something that has isc in the name. There are even two additions in Akonada that I don’t understand, one adds an .isc file and the other an .ics folder. Where I did not immediately understand. I only realized that Akonadi and Korganizer are in collision, some distributions have an older Korganized scheme some do not. It will take almost a week for a couple of birthdays to be added to the calendar with this trivial thing.







hm, my ~/.config/akonadi/akonadiserverrc looks the same, too.

do you really get the same error when running akonadictl --verbose start ?

and what output does

mysqld --defaults-file=/home/your_user/.local/share/akonadi/mysql.conf --datadir=/home/your_user/.local/share/akonadi/db_data/ --socket=/run/user/1000/akonadi/mysql.socket --pid-file=/run/user/1000/akonadi/mysql.pid`


do you really get the same error when running akonadictl --verbose start ?
Yes , i dont know to put screenshot or browser is not compatibil (waterfox)


that normally means mariadb sucessfully started. does the output/errors from akonadictl --verbose start change after you launched mysqld?

akonadictl --verbose start
Akonadi is already running.
I think I figured out what the problem was, Personal kCalendar no longer exists, now it’s one of those isc files but which, I don’t know, is one file and one is a directory and it comes down to the same thing. A rename can be done in the Personal Calendar but then the compensation stops working. It goes non-stop dancing start with that long command, re-import the isc file and even work, stay isc in the organizer and persona calendar, it is already a lottery whether it will work from the first time or not. Thank you for your help :slight_smile:

Just wanted to chime in to say I had the same issue after the latest Manjaro stable updates on 2020-08-28.

aa-complain fixed my issue.

Thank you - this worked for me as well! I’ve set the enforce as well. Will check after a reboot.

Thanks! I had this same issue after the latest updates, this totally fixed it :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.