Repeated keys in activity overview

Hi, there is a long time without a problem, but now, I’ve got a little one a bit annoying. As the title say, there’s a weird thing happening when I type a key in activity overview mode on Gnome desktop.
It’s not an absolute problem, but it takes time to understand that several letters spawned in the search bar, erase them and make a new research to open an application.

Here, on the picture, I typed only one “m” on my keyboard, but two others joined their friend. So I browsed the Web for people who get the exactly same problem, but I’ve only found one post on AskUbuntu, and it is now down with a 404 error.

So, have you some solution here for this strange problem ?

Sorry, can’t reproduce it.

  • Sounds like it could be a keyboard issue.
    • Have you tried another one?
    • Does it only happen with one letter?
  • How often does this issue occur?
  • Can you reproduce it on a live ISO?
  • Can you reproduce it with no extensions enabled?
  • Can you reproduce it on a new user account?

So, I don’t know where it came from, but now it’s fixed by log out/log in in gnome shell. I guess that’s the best solution for this problem… If someone has this error and has a better explication, feel free to add your answer.

I have the same issue on my both PCs. ALT+F2 -> R fixes the problem, but its so annoying(


This one solved my problem too. But doing it everytime is so annoying.

Which log should I check, in order to target the problem? It started after the update.

I have the same problem, every time I press the W window key, in the gnome search box when typing anything the first letter is duplicated. I’m using the system with everything updated to the latest version.

I have the exact same issue. I had the issue initially every time I installed. Then, I decided to unplug my keyboard during install and use it only in bluetooth mode. Everything worked perfectly. Then, I literally just updated 10 minutes ago and it is doing the exact same thing. I will simply hit the meta key and start typing, and whichever letter I type, it types double and I have to backspace and keep typing. And to answer the questions to asked the others.

  • I don’t have another keyboard to try
  • It happens with all letters
    -Every time I go into overview and start typing
    -It did not happen in the live ISO
    -I just disabled all extensions and it did nothing
  • I will try a new user account but have low hopes.

If it were a keyboard issue it seems that it would have done it on the several other distros I have tested over the past week.

And even more specifically, after my install a half-hour ago, it was great. I updated, and it is doing it again.

Creating a new user and switching users fixed it. Which, in my mind, makes no sense if it were a keyboard issue.

Does this provide you with any insight as to what it may be?

No, however it’s now narrowed down. Check the config files in the affected user account.

1 Like

Update: Machine freezes and does not leave black screen when coming out of deep sleep. However, this has happened on several distros using Gnome, so I am almost certain it is an Nvidia config issue.

This is relevant because I just got home and had to reboot from said lockup and the keypress issue is now back. Exact same behavior. I’ll check the config files all the same.

I think we may have narrowed it down more. I have a Keychron K8 keyboard. I normally use it wired over USB, however, I had noticed that one of the ways I tried to workaround the issue when reinstalling was connecting over Bluetooth in the live ISO, letting the installer finish, and then when I would boot into the OS, it was fine for a bit. I’m going to start paying closer attention to how it is connected and when exactly the issue starts up. As I type this, everything is perfect. I am unplugged and connected over BT. But there seems to be a lead, at least.

I also have noticed the same problem for a long time now, every time when I try to type into the activities overview’s search bar, the first key that I press is double-typed.

the only solution is to restart ALT + F2 and the r gnome as mentioned above.

GNOME Shell 43.1



Just made an account to reply here. I have the same problem since today. The only change in my Setup was a second connected Monitor, which makes no sense…

Same issue over here

➜  ~ cat /etc/lsb-release                
➜  ~ gnome-shell --version
GNOME Shell 43.1
➜  ~ uname -r             

The issue was originally present in kernel version 5.15.78-1 so I updated to 5.19.17-2 to see if it was fixed, doesn’t seem that way.

Installation on Laptop and not an issue with the keyboard, as the issue is not present with other distros.
Alt+F2 > R will resolve the issue temporarily but issue will return on rebooting.

I’m having this problem too. Just installed latest fresh Manjaro Gnome release and dist-upgraded. I don’t know what that ‘R’ means in that fix as it does nothing in that run box if I type it and press enter.

Just adding I have the same issue with repeated keystrokes. The ALT+F2 ‘R’ fix works for me as well. Confirmed with multiple keyboards. Does not happen on Windows.

I’m having the same issue with repeated keystrokes. The ALT+F2 ‘R’ solution also works for me, but it’s annoying to have it running.

Confirming that one is affected by this behavior without leaving information on what kind of system this occurs is only helpful if more info is posted about the system affected:

and if possible some effort on find this cause would be furthering the cause of this issue:

So far the input of @jordanmiracle has narrowed it down for the issue experienced

Leaving answers to these questions could help narrow it down:

The issue could be a bug in “Dash to Dock” extension. Go to extentionsDash to dockSettingsAppearance tab → Disable Show overview on start up. That fixed the issue for me.


You are correct, Enabled “Show overview on start up” → logout → login → getting double key input in the application search bar.

But when disabled the “Show overview on start up” → logout → login → it is fixed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.