Pamac 10.1.3-3 rendering issue (gtk3-nocsd related? Confirmed on KDE and Xfce, Nvidia and Intel GPU)

After applying the stable updates and rebooting my system, I am seeing rendering issues with Pamac 10.1.3-3.

Here is my original post for reference:

Here is a screenshot to illustrate the issue:

Not only does text not appear, but there is an ugly black border around the edges.

Additional version information:

  • Stable Updates from 2021-07-13
  • Pamac 10.1.3-3
  • KDE Plasma Version: 5.22.3
  • KDE Frameworks Version: 5.84.0
  • Qt Version: 5.15.2
  • Kernel Version: 5.10.49-1-MANJARO (64-bit)
  • Graphics Platform: X11
  • Graphics Processor: NVIDIA GeForce GTX 1650/PCIe/SSE2
  • Nvidia proprietary driver: 470.42.01

To compare here is what it should look like:

Seems like the rounded corners, and the shadow, is plain black.
Did you mess with desktop effects? Applied some customization in System Settings? Is your compositor properly enabled?

//EDIT: OH! I see it? What is this windows title bar you have here?!! Definitely some windows customization going on here… Open both links in separate tabs, and go back and forth: yours and mine

//EDIT2: something something No CSD something?

1 Like

Nothing out of the ordinary with the compositor. Other GTK apps display properly with smooth corners and shadows. Disabling the compositor makes no difference (in regards of fixing the issue with Pamac.)

Didn’t say to disable the compositor, quite the opposite. What about my two EDITS? Does that ring a bell?

It may be a theme issue. Have you tried a different GTK theme?

Just saw your edits. Looks like that’s what triggered it: gtk3-nocsd

That’s good news and bad news, because I absolutely hate client-side decorations that violate Fitt’s law. Muscle memory, I keep clicking to close a window and it always “misses” because they brought the X (close button) away from being flush with the upper-right corner (“infinitely large target”).

No it’s not he’s using Adwaita here (he opened this thread after we flooded the announcement thread).

Yeah so now you know, Pamac will not work with NO CSD. It has been decided going forward Manjaro doesn’t support NO CSD. CSD is the future for Manjaro. Wether we like it or not (looking for official message about it wait for it).

Honestly, that’s a real bummer. I see they removed it from the official repository as well. :confused:

One of the main reasons I use KDE instead of GNOME is to avoid the overuse of CSD.

Here it is

Here’s where my confusion with GTK4 came from also (in announcement thread).

These mobile-device prioritized trends are really sucking the wind out of me…

I wish desktop and mobile were kept on divergent paths and don’t overlap on each other.

1 Like

Let hope that Pamac-QT development will go forward once Pamac 11 releases (it is another application made by another dev, but I think Pamac-QT uses some libraries from Pamac(-GTK).

[sarcasm] Hurray for CSD! [/sarcasm]


I hope so too! It’s one I’ve kept my eyes on but never installed, seeing how it hasn’t been considered stable or up-to-date compared the the flagship Pamac (GTK).

I’m afraid that’s not correct. I too am using the gtk3-nocsd-git module and I’m not getting that weirdness that the OP is getting. :arrow_down:

Ergo, it must be a theme-related issue.

That’s weird then that removing his NO CSD package fixed the issue.

Probably a GTK thing. GTK is eevull.

We hates it, Preciousss, we hates it.


1 Like

I suppose it could be:

  • outdated No CSD package
  • different No CSD package than yours (I can find two in AUR)
  • something unrelated that automagically randomly fixed itself when he did something
  • a GTK thing

But that’s weird if it is a theme issue he tried Adwaita, Breath, and they had same exact issue (and I suppose Adwaita being the reference, it can’t be a problem with that?).

Installing gtk3-nocsd-git brings back the same rendering issue. :frowning: Uninstalling it fixes the problem once again. (The issue/re-fix doesn’t appear until after I logoff and log back in, so that everything takes effect.)

pamac info gtk3-nocsd-git
Name: gtk3-nocsd-git
Version r82.512c2bd-1

So currently, as of the latest Stable Updates and Pamac 10.1.3-3, the only way to get around this rendering issue is to keep gtk3-nocsd-git uninstalled. :confused: Other than using Window Rules that will look funky with duplicate controls (by forcing Kwin to always draw a title bar), I guess I’ll have to keep my hopes up for Pamac-Qt.

With gtk3-nocsd-git installed (I’m assuming latest version from the AUR?), can you also post a screenshot of Pamac’s Preferences dialog window?