[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

This is so great! Almost everything went smoot, only little hickup was that the redshift.service faild to start after reboot, but systemctl --user restart redshift.service fixed this.

The exact same version?

It works fine with me. Maybe try logging in and out once again. I did this couple of times as well. Also, a tip if that works for you. Go to Layout switcher and apply/reload desktop of choice.

Hope it works :crossed_fingers:

Who else on KDE finds the new Pamac GUI interface (especially the Settings) to be a step backwards in layout and presentation?

I’m using the Breath 2 (Dark) theme, which I believe is one of the defaults on Manjaro KDE.


It is a theme issue. Check the theme you’re using in KDE Settings → Appearance → Application Style → GTK Application Style, and try another theme that is up to new GTK standards. I think in the official themes only Adwaita is correct. However, in your screenshot, there is not even the text so something is weird, if I select Breath Dark I have the text, even if it is not correct.

Same issue with Adwaita. Same ugly black border around the bottom edge of the window as well.

And now my GTK apps don’t match my Breath 2 Dark theme. :frowning:

Open a support thread then because something is up on your side I guess. Pamac is GTK 4. Breath GTK theme is GTK2/GTK3. It needs an update.

//EDIT: unfortunately very unlikely this Breath GTK theme is updated, it has been archived, last update 5 years ago GitHub - manjaro/artwork-breath-gtk: Breath GTK2/3 Theme for Manjaro Linux

Agreed. I think some tweaking is required still.

Something is wrong on your end,I just tried Adwaita and it looks fine here

1 Like

Could that be a Wallpaper leaking through ?

As far as I remember, I’ve started out using the Breath 2 Dark theme (KDE/Qt) and for GTK apps I’ve used (Breath-Dark). I haven’t done anything fringe in regards to fonts, colors, or themes. So as a stable update on a flagship software (Pamac), this issue caught me by surprise.

Am I missing GTK4 packages that have to be installed manually? I don’t believe I have any GTK4 apps on my system with which I can test if there is a rendering issue. (All my other GTK apps still appear fine, but I believe they are built with GTK3.)

EDIT: Fixed incorrect theme name.

No it wasn’t, but for some reason that weird shadow has gone away since rebooting a second time. I’ll wait and see if it comes back.

Had this issue as well. I had yaourt installed.

sudo pacman -R yaourt
sudo pacman -R package-query

This removed both the issue causing packages, and allowed the update to work.

Pamac has AUR support built in, so I’m not even sure why I had yaourt installed. And it seems like it’s the only thing that requires package-query anyway… Or so I hope.

1 Like

Anyone else on KDE facing this issue (missing icons) after applying the Stable updates and rebooting? I posted the link to the other thread which contains screenshots of the problem.

Hi -

The system’s been restarted several times since the post. There is no change - arrow keys do not work when selecting among the search results.

Layout Switcher? What is that? I searched for it but nothing turns up.

Use the git version of the tools

The upgrade has broken any Steam game that goes full screen. It either crashes Cinnamon to fallback mode or stutters the screen into unresposiveness. One of the game logs indicated that the windows geometry was flipping from 1920x1080 to 1920x1027 and back repeatedly.

The launcher has always had issues, I gave up on it a long time ago.

If you would like additional troubleshooting with it, please create a topic in #support:gaming.

Not quite yet. Pamac <=10.1 still uses gtk3 and libhandy while >=v11 will use gtk4 and libadwaita. :wink:

The package is called gnome-layout-switcher and appears in the application menu as Layouts.

So the Pamac rendering issue cannot be GTK4-related (on my KDE system.)

I’ve tried every combination of themes (Plasma, Qt, and Gtk), as well as colors, as well as rebooting. Something about the new Pamac (10.1.3-3) must have triggered this. It’s the only Gtk application that does not display correctly on my KDE system.

Thanks, I don’t have it installed. I will look for more information on what these other layouts look like before considering this.