Pamac 10.1.3-3 rendering issue (gtk3-nocsd related? Confirmed on KDE and Xfce, Nvidia and Intel GPU)

A difference here he’s apparently using Intel video, you apparently have a dual video card system (or only Nvidia, your info are not clear in profile).

I’m using only Nvidia, latest proprietary drivers available from the repository / mhwd.

  • Kernel Version: 5.10.49-1-MANJARO (64-bit)
  • Graphics Platform: X11
  • Graphics Processor: NVIDIA GeForce GTX 1650/PCIe/SSE2
  • Nvidia proprietary driver: 470.42.01

EDIT: Oh, I see the confusion with my profile. I merged the details from two different computers. In fact, I’ll go ahead and do a full update on my other laptop (Xfce, Intel GPU) and see if I get the same rendering issue with gtk3-nocsd-git installed.

Same rendering issue with Intel GPU, Xfce, and gtk3-nocsd-git on a different computer.

Uninstalling gtk3-nocsd-git (then logging off, logging back in) resolves the rendering issue, just like with my KDE + Nvidia computer.

For the record, I hate (yes, it’s a strong word), hate client-side decorations for a desktop or laptop PC. It’s been nothing but a mess of mis-matched window appearances and needless violations of Fitts’ Law that cause frustration when trying to quickly close a window (yet you need to use extra precision to land your mouse cursor over the tiny target.) It’s just comical at this point and I don’t understand why it has picked up such momentum. Luckily, KDE users have a sanctuary for the meantime and can use Kwin’s Window Rules to force title bars for errant applications. (Which makes them more consistent and easier to close.)

To me from the start the issue lies with the No CSD thing. I don’t know why Aragon doesn’t have the issue, but I don’t see any other explanation.

video : nouveau
me too: i want gtk3-nocsd-git for my desktop
Change themes, colors profils, dark/white, remove gtk style css in $home : always same problem as @winnie : not view fonts in some zones (only in preferences)

switch GTK_CSD work (but not perfect)

GTK_CSD=0 pamac-manager

acapture_0714_180233.0


GTK_CSD=1 pamac-manager

acapture_0714_180345.1

I have the same problem and the only solution I have found (Xorg only) is to uninstall gtk3-nocsd and install gtk3-classic from AUR. This way I can remove CSD and have pamac usable.

Btw. I don’t think forcing CSD to non Gnome users is good approach.

1 Like

You’re not really forced to use GTK applications with CSD, or Pamac for instance. You are free to use something else (Octopi? Pamac-QT?).

But realistically, it is developed as a GTK application, and the developer (yes, it is one man who work on his free time to develop Pamac) decided it to be GTK and with CSD, so unless you find the manpower to provide Manajro team with developers to create an alternative, we don’t really have a choice here.

It is the best package manager GUI for Manjaro, so you do you but I will make compromise and use Pamac :stuck_out_tongue:

Certainly. And it’s messed up in terms of the colors ─ which might be a theming issue, but I never use the Pamac GUI anyway ─ but I don’t get the window border craziness that you’re seeing. :thinking:

The color problem in dark themes is with all non Adwaita based GTK themes (for example Breath themes, Materia, Breeze, all have some colors issues).

1 Like

Ah, that would explain it. I’m using the Mojave Dark theme ─ I think it’s from the AUR but I don’t remember, as I don’t switch themes all that often. :slight_smile:

Edit: Yes, here it is…: gtk-theme-macos-mojave. It’s an AUR package, indeed. :wink:

Pamac-QT seems to be dead now.

At first, I strongly appreciate work of any developer contributing to community. But I also think giving feedback is important.

I have nothing against pamac being CSD as long as i can use gtk3-nocsd, my problem is that now i can’t. What is the point of this change? Manjaro is not Gnome only, does this change helps Manjaro? Does it make it more welcoming for other DEs users? So, is this a good/necessary change?

1 Like

It makes it universal on all systems Manjaro supports. Phone included. Manjaro originally is GTK world (XFCE).
I don’t like CSD either. But it has been decided already since long time, and going forward us complaining will not change anything. Also feedback here is most likely never gonna be read.

Place for feedback and reporting issue would be the Gitlab for Pamac.

The thing is simple. We use libhandy for Pamac now, which doesn’t play nice with gtk3-nocsd or other packages like gtk3-classic. Pamac is a more or less Gnome application. With the switch to libpamac we are now able to provide more than one UI for Pamac. 10.1 is more or less designed to work also on the Pinephone or any other mobile devices. The GTK4 port is still ongoing and will use libadwaita. If you don’t like the changes, you’re still able to compile 10.0 series. We only have to make it adopt to libpamac changes.

Trying to understand this better. Is it to mean that future versions (11, 12, etc) will be available with more than one toolkit (i.e, gtk, qt) out of the box, beginning with the switch to libpamac?

No it simply means that we are now more flexible for other UIs based on libpamac. When there will be a Qt version we have to see. Currently we have other priorities to tackle. For those loving 10.0.x design can still compile v10.0.7 release:

Yes, but there are 175 open issues on Gitlab.

This is weird because, i have the issue described above too, but not on every tabs, look :



There are 3 tabs on this windows (Pamac → Preferences) and no rendering issue on the “Advanced” tab (the middle one).
On my computer, this is ok with Adwaita-dark theme, but NOT ok with all Matcha-dark-xxxx themes.

I did not change anything related to gtk3 packages on my system (xfce), and have default i915 video driver.

What can i do ?
Thanks

this issue is open

it’s related to libhandy widgets in KDE

bug in libhandy library. in “advanced” list is not in show/hide zone, is not same widget ? libhandy is for gnome, for the moment not exists real support for kde :cry:

2 Likes