Pamac's new look

You have to install and select matching themes for QT and GTK, that’s all. And you select the GTK theme in System Settings → Appearance → Application Style → Configure GTK Theme (at the bottom right corner)

I use the Materia themes from official repositories (materia-kde and its optional dependency materia-gtk-theme), and it works good. I don’t use Kvantum at all. I think the issue wit htheme is the theme itself, I just reported the issue with Materia for example so users should just do that to fix the issues with themes.

pamac-qt is another program which has nothing to do with pamac-gtk (which is what we’re talking about here). I use Pamac GTK on KDE without issue (but the theme specific issues. If you use the default Manjaro themes there is no issue).

The button text was changed between 10.0.6 and 10.1.2 :slight_smile:

I have access to pamac version 10.0.6-2

  • Preferences > Official Repositories > Refresh Mirrors List
  • When clicked I get a progress bar on the parent window.

I also have access to pamac version 10.1.2-0.1

  • Preferences > General > Refresh Mirrors
  • When clicked I get nothing.


  • If I click the button multiple times (testing of course), pamac terminates — just peacefully goes away.

1 Like

Ah yeah, i remember now, but was a good call to trim down the name, as is clear that is about a list of mirrors.
Have you tried the version from testing ?

Yep I got the same behavior, I don’t have anything anywhere showing progress. It also terminates if I do two clicks on the button (it shouldn’t allow multiple clicks in my opinion, until the operation is finished, good example of that is the Update tab when you click the Refresh button it is not allowed to click it before operation ends), terminal output says this before exiting:

emon_real_generate_mirrors_list_co: code should not be reached
Bail out! ERROR:../src/transaction_interface_daemon.vala:83:pamac_transaction_in
terface_daemon_real_generate_mirrors_list_co: code should not be reached
Aborted (core dumped)

Pamac 10.1.2-0.2 on KDE, Testing branch.

The truth is, all applications should be mede to properly interpret morse code clicking
-- --- .-. ... . / -.-. --- -.. . / -.-. .-.. .. -.-. -.- .. -. --.

@medmedin most likely you open an Issue so we can track your complaint. Pamac is Gnome adaptive application now, we will port to GTK4. Currently we are in progress to make Pamac ready for the Mobile Phones, like the Pinephone. Therefore we introduced libhandy and libadwaita for the GTK4 Port.

We are currently concentrating on Gnome and XFCE edition first, to get Pamac ready. Also we don’t support gtk3-nocsd or gtk3-classic, as libhandy and libadwaita only works with CSD enabled. Our focus on theme support is on Adwaita and Matcha. Supporting Plasma with this v10.1.x series is currently secondary, as we first have to finalize the Gnome 40.1 ports.


@omano and @stargazer. Please open an issue regarding the refresh mirror thing, so we can track it. Also explain which visual feedback you guys expect.

I’ll do as I did for the other issues I encountered, I’m just never rushing reports and wait for more user feedback usually when I report an issue, in case the issue is on my side only.

Expected feedback is what apparently happens for others here

Seems like it is not a theme issue, probably screenshot is from GNOME and not KDE. Issue is probably KDE related.

KDE - once i run Refresh database and then run again the Refresh mirrors, the progress bar is no longer shown, that means there is some inconsistency there, but the mirrors do get updated … Just need to click once.

You’re not talking about the same thing at all. Since start user talked about the Refresh Mirrors button in Preferences, Now you talk about the Item in the Menu called Refresh Databases (which this item actually shows the progress you were displaying in screenshot).

I get no progress bar when refreshing mirrors on Cinnamon as well. The theming issue is still there on preferences but the add/remove icons are much better.

Thank you for your hard work and taking feedback onboard @guinux

1 Like

My screenshot shows Refresh mirrors progress bar, and i just mentioned, that i can no longer see the progress bar for Refresh mirrors after i clicked the Refresh database.

We talk about Pamac …

See, Refresh mirrors with feedback progress.

For me it simply never shows any progress when I click the Refresh Mirror button.

And i just told you how i could reproduce what you experienced …

We can have this deaf discussion forever.
For me it simply never shows any progress when I click the Refresh Mirrors button. I don’t click Update Databases beforehand.

I guess this should be reported upstream to the theme author, I just did for Materia theme (guinux confirmed it is theme issue)

1 Like

I think the issue here is, that you might expect a visual feedback in the window you have opened, in this case the preference window, and not on the main application window of Pamac. Especially it might be an issue on mobile, as then the windows are stacked on top of each other. So having the progress bar under the refresh mirrors button would make sense, as on mobile you won’t see the main window not at all.

And again: open issues, otherwise we won’t prioritize them. Most of our developers have no time to lurk into the forums!

Nope, there is no progress at all, in the main window.

I’ve had the same issue on every dark theme I’ve tried, I’ll do some more testing

Try Adwaita-dark it works good. But yeah the Breath-dark has the issue, Materia-dark too, so I don’t know.

1 Like

Is nice to see how the progress from calling me blind a few days back to calling me deaf comes about … You seem to be a very nice and thoughtful person.

Either on my end was a glitch and it showed up, and now no longer shows after doing something else, or is simply a bug … either way, needs investigating, is inconsistent.

I can see the progress bar for refresh mirrors while in the output progress