KDE Plasma 20.2 issue.. Unstable


After installing fresh the new Manjaro KDE 20.2 panel and Applications menu started acting all weird… Not allowing me to highlight anything and trying to add widgets to panel shows widgets page in a refresh loop… Upon close inspection got messages like invalid sRGB profile and plasmoids empty spacer null etc…

In short 100% CPU usage unusable panel/widgets/Applications menu…

New 20.2 release seems to be buggy !

Same issue here, the menu and the panel seems very laggy.

Not only that but can’t do anything… Frustrating

Is it related?

You may check if you have other symptoms.

What do you mean by other symptoms ? All I get is exactly what was mentioned… 100% CPU Usage and unusable panel/Application Menu

  • high cpu (100%) for plasmashell
  • slow and unreponsive dolphin actions.
  • “applications updated” error message loop in applications widgets on panel. (so, cannot start apps)
  • appearing and sudenly disappearing “Add Panel” entry in context menu (right click) on panel and desktop.

just try that and see if it works:
mv ~/.config/mimeapps.list ~/.local/share/applications/

Well, I gave up and wiped SSD waiting for an update. I am on another Install dating back to last month updated to latest… Only issue is as mentioned Flatpak breaking pamac… For now…

‘mv ~/.config/mimeapps.list ~/.local/share/applications/’ fixed the problem for me. Thanks ceres!

1 Like

But it will come back after a few apps it happened to me again after fix. This is a temporary fix… Awaiting permanent one…

From what I’ve been reading, just removing "~/.config/mimeapps.list " would have the same effect.

No solution yet, but it’s current and active, see: KDE Bug Report - https://bugs.kde.org/show_bug.cgi?id=429593#c12

Looks like they have a fix: https://bugs.kde.org/show_bug.cgi?id=429593#c25

1 Like

I had issues with show alternatives in the menu,it would stick and the menu would remain open. I had to restart to fix it.I found it did repeat actions trying again and again. I did a reinstall and issue seemed to disappear.

Thanks my first problem resolved :wink:

1 Like

Same problem. But my whole computer freezes and I can’t even open console to restart KDE.

I have tried everything and the problems continue:

  • Right click on taskbar, add widgets (infinite cycle updates widget list).
  • Plasmashell uses too much CPU. (>50%)
  • Applications updated" appears in the start menu and never desappears.
  • No “add panel” option in taskbar.
  • Kate, Dolphin get laggy.
  • I can’t reorder the icons in the taskbar.



sudo pacman -S plasma kio-extras

sudo pacman -S kde-applications

systemctl enable sddm.service --force
systemctl reboot

This solved it for me!