Network connections suddently vanish (Noob alert)

So today i booted up my pc as usual, and quickly got prompted to my desktop on KDE plasma manjaro. But suddently i noticed that the wifi icon had a little yellow exclamation (!) point, i clicked on the icon, and saw that i was actually disconnected from my main wi-fi network, i clicked on it and selected ‘‘connect’’, but then, out of the blue, all of my connections vanished and the message ‘‘no connections available’’ appeared on the screen, the connections would quickly reappear, and no matter how many times i tried to connect to any wi-fi network, all of the connections will simply disappear, as if i had no network chip on my pc. I don’t know what happened, yesterday my pc was all fine and dandy, but now it just doenst want to connect to the wi-fi ( and also, when i press ctrl + alt + T the konsole won’t open, i don’t know if this is related but all information is necessary).


That’s interesting, because I have a similar problem. I also wrote a posting, but sadly I am not allowed to link it.

My wifi only goes down when I upload a lot. When the wifi is gone, it’s gone. I can only restart the computer to get online again.

Yeah, that’s a really strange problem, because everything was fine yesterday, and even if i restart it still doesn’t work, idk if this is a KDE only issue, im going to format my manjaro partition and install xfce to see if solves my problem

I use XFCE. My installation is over 1 year old. I never had internet problems. It just started somehow a few days ago.
I installed the newest broadcom driver from the repositories. Not sure if it helped, I will monitor the issue the next days. At least today the internet seems to be better, but I have the issue seldom, so it’s difficult to monitor.

I also has the same exact problem in KDE. Even the shortcut for konsole is also gone for me right when the issue start. Plus the usual Manjaro updater and Pamac trayicon are also gone. I tried to do a fresh install two days ago and it happens again right now.

After reading here and there, I found a solution for me. It seems this whole problem happens due to git dependencies being installed in the system. Actually there were two problems that I had face and solved them using this method here:

  1. Major stuttering in KDE:
  1. Network unable to connect:

It seems everything works fine now. I think this won’t work on XFCE though.