Many -git versions from Architect, installed as User-manager-git dependences

Recently, after last update, I’ve got problems with KDE Applications Menu.

As reported here KDE Plasma kickstart issue: loop message "Applications updated.", the solution could be remove kservice-git and install kservice regular version, as tested from @TechXero, or do
mv ~/.config/mimeapps.list ~/.local/share/applications/
Another post: Issue with menus

I installed manjaro with Architect.

So, I tried to find what package installed these -git versions, reading pacman.log from when I installed Manjaro and, finally, I found it! User-manager-git.

I did the command:
$ pactree -u user-manager-git

and filtered with only -git packages I have installed, I get these packages:

attica-git karchive-git kauth-git kbookmarks-git kcodecs-git kcompletion-git kconfig-git kconfigwidgets-git kcoreaddons-git kcrash-git kdbusaddons-git kglobalaccel-git kguiaddons-git ki18n-git kiconthemes-git kitemviews-git knotifications-git kservice-git ktextwidgets-git kwallet-git kwidgetsaddons-git kwindowsystem-git kxmlgui-git sonnet-git kjobwidgets-git kio-git solid-git

They are the only packages on my system that are in -git version.
And all of them are dipendences of user-manager-git installed by Architect.
In repositories, each of them has its corresponding regular version.

I would like to replace user-manager-git with the regular version, because I think I will have problems sooner or later. The question I ask those who will be able to answer is:

can i uninstall user-manager-git and those dependences, and reinstall the regular version right away, without breaking my system?
What is the properly command with pacman? I should do it from a live CD?

I have only git version of user-manager in the repo. Do you have the regular version?
Besides, the bug mentioned in the post is resolved already: 429593 – KBuildSycoca loop causes hangs

You are right.
User-manager is not present in the repositories.
But, what package has installed these packages in -git version?

And is safe to uninstall them?

On my other Manjaro (on my laptop) user-manager-git isn’t installed (I suppose because I installed manjaro there with a regular ISO Live).
Do you think is safe uninstall it?

I could do a command like this:
sudo pacman -Rdd <package>-git
and then
sudo pacman -S <package>

I found another post with the same problem (less then one month ago), but without a solution reply.

I don’t know.
I also don’t have user-manager-git installed, but I have other -git packages you listed.

I tried some to replace with the regular ones but it caused issues, for example replacing kiconthemes-git with kiconthemes affected appearance of my desktop (I don’t experience any problem with -git packages actually other than mimeapps.list issue, I did it just for curiosity :slight_smile: ).

Mmmh… maybe, in order not to have problems, we should replace all of them, since there are cross dependencies between them.
Maybe we should switch to TTY and stop plasma-desktop.

You see, I would like to replace every git version because I fear that sooner or later they will bork the system.

On reflection, those -git packages, coming from AUR, are always a newer, more advanced version than their counterparts found in the repos.
When we update the system, we may have some sort of partial update, right?

Unfortunately, I do not have the necessary skills to be able to decide for myself. On the other hand, it would be better to try to fix things now that I have a system recently installed and not customized.

1 Like

Not entirely sure how you ended up with them but yes you can replace them all with the regular versions.

Sorry, @cscs, but I can’t understand a thing.

I have two machine: a laptop and an old pc.
On the first, I installed Manjaro 2 years ago by ISO live; on the second, I installed Manjaro ten days ago by Architect.
Both on Stable branch.

On my laptop I don’t have any -git packages, and it is that I want.
On the pc, I have many -git packages.

Why Architect has installed those -git version if I stay on Stable branch?

I dont know either.
But I do know there is more than one KDE profile … there is also KDE-Dev which does have git packages.

Is it possible you chose that by accident?

manjaro/kde-dev/Packages-Desktop · master · Profiles & Settings / iso-profiles · GitLab

manjaro/kde/Packages-Desktop · master · Profiles & Settings / iso-profiles · GitLab

Oh, it is possible. How can I verify that?

I can see it in the Manjaro repository on my computer

From the graphical package manager (I’m still using pamac-classic) select to install the regular version off all your -git packages and apply

Well the package list mainly (see the links above)
(or if you opted to create/save an installation log which could maybe tell us more)

From a quick comparison I could mention for example the regular KDE profile has the following packages by default while dev does not:


And the reverse (exists on Dev profile) of course for a number of git packages like:


And a bunch of ‘devvy’ things like these are also not present by default in the regular profile:

1 Like

So I can install regular version without uninstall the -git versions? Sorry but my English isn’t very well.

The graphical package manager should be able to manage the transition

1 Like

Thanks for your list.
It is strange: I don’t have xorg-mkfontscale but I have khotkeys.
I don’t have breeze-git e breeze-gtk-git.
I don’t have plasma-desktop-git and I have the regular plasma-desktop

But I have almost all items from the last list, the ‘devvy’ list. :face_with_monocle:

So, how can I switch to regular? Can I transition with Pamac and follow the @Lolix suggest, or I have to resign myself and reinstall Manjaro?

It should be easy enough to just install the regular versions - the package manager should handle the conflict and prompt to remove and replace.

Ok, I will try it. And for the "devvy’ items, should I uninstall them?

Its up to you if you want to keep them … a number of them are from base-devel which is required for using the AUR.

Ok, I think I leave them, if they are harmless.
Well, I’ll try and I will post the result.

Where Architect save the installation log? In /var/log I have only pacman.log.

I believe just in root / might be anything if it is left.

I found it. Its name is .m.a.log

11/27/20  18:56:43  selected: [Manjaro-kde]
11/27/20  18.59:55  selected 'full' profile
11/27/20  19:00:28  packages to install: .....

and there is the list of the packages installed. But there are not any -git packages. And there are the ‘devvy’ packages neither.
I think something went wrong…