KDE plasma bugs after each update [Stable Update] 2022-09-12

I am only linking those posts here which I think are relevant. There are tons more posts/threads about problems with Plasma of which I think they are caused by something else, and those are posts/threads I will not link to here.

Well, I am using 5.4 LTS — remember those three letters? Besides, the kernel doesn’t have anything to do with the stability of Plasma.

This thread is about a very real problem with one of the official Manjaro releases — a problem that is all too gratuitously being shrugged off — and although there is a solution (for now), it’s not an officially supported one.

Furthermore, the #member-hub is not accessible to everyone. One has to be a TL2 or above to have access to it.

Still, your subtle hint at requesting that this thread be closed is noted, but perhaps you could be more aggressive in your attempt, in which case it is my duty to point out that you are free to flag the thread, or any post on it. Alternatively, if the existence of this thread offends you so much, then you can also always unsubscribe from it and/or add it to your mute/ignore list.

Meanwhile, the rest of us are looking for an actual solution that doesn’t require a partial upgrade scenario.


I’m aware of all that, and I find the topic interesting, hence the reason I didn’t flag or unsubscribe. I just wanted to point out the obvious double standard of allowing this non-support thread to remain open when other non-support topics get shut down by moderators.

It’s not a non-support thread. The problem is real and needs to be remedied, one way or the other.

Here’s another one, and it may provide us with a clue… :arrow_down:

I don’t think it’s their network driver. I think it’s a race condition, and if so, then this may also lie at the root of most of the other problems, because from my own experiences with 5.25.5, the problems appear to be timing-related.

A few weeks ago, @philm told me that he had had to apply three patches in order to get Plasma 5.24.6 to work with the previous release of the KDE Frameworks, and that seems odd to me, given that the split-up between the KDE Frameworks, Plasma Desktop and KDE Applications should guarantee that either of those three projects should allow for an upgrade without breaking anything — that’s why KDE split them up into separate projects.

In addition to that, I am also wondering whether Arch also had to apply those patches, and whether it is those patches that are causing the problems with 5.25.5. :thinking:


u may be right b/c i tried fedora and it was working fine …the wifi was working flawless. I didnt try arch based distro to see if the issue is similar but thanks for the info


Looks like I switched from cinnamon to a train wreck… :laughing:
I was happy about the upgrade to Plasma 5.25 'cause I use multiple monitors and 5.25 fixed some of the disaster. Of course a lot still remains.

Q: do I interpret this thread correctly that for the next month or two whatever I have in front of me is what there is, and then there will be an upgrade to 5.26 which will bring “new fun”, and sometime in 2023 I should expect a 6.0 upgrade with more “real fun”?

Folks, I have some good news. :wink: Thanks to the Upper Grandmaster of the Secret Order of the Manjaruminati, @philm, those of us who chose to skip the update from Plasma 5.24.6 to Plasma 5.25.5 now have the ability to install the updated Plasma 5.24.7 LTS. @philm was so kind as to build the packages on the GitHub server and to make them available here. :arrow_down:

So if you’ve skipped the upgrade from 5.24.6 to 5.25.5 but you want to upgrade to the newest 5.24.7 LTS, then here’s what you need to do… :arrow_down:

P.S.: Make sure you create a backup first!

First, get the file plasma-5.24.7-LTS.zip from the link above — you only need that one file.

Now, I have personally opted to create a local repository under /var/cache/pacman/, but you can use a directory in your $HOME if you like. Note that if you do put it under /var, then it’s best to become root first… :arrow_down:

su -

… or, for those of you who’ve disabled the root account, … :arrow_down:

sudo su -

Given that on my system here, I’ve put the new local repo under the /var hierarchy, I will be continuing this HowTo with the methodology as I have done things here — I’m sure you can adapt this to your own needs. :wink:


mkdir /var/cache/pacman/plasma-lts
cd /var/cache/pacman/plasma-lts
mv /home/your-username-here/Downloads/plasma-5.24.7-LTS.zip ./
unzip plasma-5.24.7-LTS.zip
repo-add plasma-lts.db.tar.xz *.zst
cp /etc/pacman.conf /etc/pacman.conf.bak
nano /etc/pacman.conf

At this point, you’re going to have to make sure that you first and foremost comment out the line for ignoring the plasma group… :arrow_down:

#IgnoreGrp = plasma

Next, look for the section where the repos are being defined, and add your own local repo between the [core] section and the [extra] section… :arrow_down:

Include = /etc/pacman.d/mirrorlist

[plasma-lts]                                # ← new section
Server=file:///var/cache/pacman/plasma-lts  # ← new section
SigLevel = Optional TrustAll                # ← new section

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Save the file — if you’re not familiar with nano, press Ctrl+O followed by Enter and then exit the editor with Ctrl+X.

Next, log out of Plasma completely — you have to be looking at the SDDM login screen — and switch to a tty with Ctrl+Alt+F2. Log in as yourself and issue the command to update your system… :arrow_down:

sudo pacman -Syu

After this step, it is not strictly necessary to reboot, but it might be a good idea nevertheless. :wink:

Once again, a big Thank You to @philm for making this possible. :wink:

:clap: :clap: :clap:


Would we still have to add the KDE-relevant packages to pacman’s ignore list?

1 Like

You lucky guys :grin:

1 Like

I took the plunge with my secondary system from KDE 5.24.6 → 5.25.5, and it was a step backwards. They’re also re-writing a lot of the code for animations and effects, and thus it loses much grace in day-to-day workflows and tasks. The experience was disappointing and felt like a meaningless “update” to a once glorious desktop environment.

So glad I stuck with 5.24.6 on my main system. :crossed_fingers: I’m happy I made that decision.


No, on the contrary. See my post higher up — it wasn’t ready yet when I accidentally submitted it due to some stupid shortcut key in chromium. My updated post contains all the instructions. :wink:


Updated post. Updated post… :thinking:

@Aragorn supposedly added something useful to the original post… should help us out… let’s see…

Blah, blah, blah… seems unimportant.

What else…

Repos? Sources? What? Lol… sounds like hacker stuff. Probably not important either…

What did he add to the post to make it supposedly helpful for us…?

Still looking… still looking…

OHHHHHHHHHHHH!!! That’s it!! The round of applause! THE TROPHY!!! THE FREE DRINKS!!! Ohhhh, bless you @Aragorn for the motivational emojis!

:sob: :sob: :sob:

Now I know what to do! Life is so good once again! :raised_hands:


It’s missing a crucial step. The .zip archive file (plasma-5.24.7-LTS.zip) was never extracted, hence there are no packages to “add” using the repo-add command.

Perhaps this command can be slipped in, rather than the initial mv command? :point_down:

unzip /home/your-username-here/Downloads/plasma-5.24.7-LTS.zip -d ./

Optionally, an additional step to remove the large (no longer needed) .zip file, since mv is not used.

UPDATE: System fully updated and using KDE 5.24.7, via the local plasma-lts repo. :sunglasses:


Didn’t even need to reboot! (Disclaimer, I’m also using kernel-modules-hook, which is why I’m able to keep using the system without a hitch, even after a kernel update.)

Had to replace the mv line with the replacement unzip command, and everything else worked out smoothly. :+1:

I want to give a special thanks to @philm for making this possible and creating the packages.

And to @Aragorn for the instructions and learning experience on adding your own local repositories.

But most importantly I want to thank all thirteen of my social media followers. Without your support these past 10 years, I wouldn’t be here today! We’re going to make it to the top one day! I PROMISE YOU. WE WILL MAKE IT TO THE TOP. :rocket:


All hail Upper Grandmaster @philm!!!

Thank you, thank you, thank you for this!

Success was had!


:partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face: :partying_face:


I believe with this you’ll even be able to downgrade back, right?

1 Like

First and foremost, THANK YOU for this plasma update!!

Here’s a question that’s simmering around the noggin’ … Once I have completed this update, what will happen when the next plasma update comes along? Will we / should we re-enable the IgnoreGrp = plasma until the coast is clear again or will this plasma LTS update allow us safe harbor until the next plasma LTS update comes along?


AFAIK, because of the positioning of the [plasma-lts] section in /etc/pacman.conf it overrides the “Default” Plasma. So, I don’t think it’s necessary to remove it.


I know, but I realized this only after I had already gone to bed. I’ve updated my post now. :wink:

Don’t forget to like, subscribe and hit the notification bell! :stuck_out_tongue:

Normally you should be safe, due to the section for [plasma-lts] sitting above the [extra] section in /etc/pacman.conf.

That said, there is a possibility that @philm will be adding an official repo for Plasma LTS, given the new Manjaro-branded hardware that’s about to come out, and which may ship with the LTS instead.


So I was partially right when saying it should be safe due to its position.

And I was also right in saying this should allow you to upgrade to the previous version:


Even i don’t waste my time with plasma, happy for you all .

Dunno, d’you think so after upgrading to 5.25 without backing up my system(like a dumbass)?..? Good question that… :thinking: