KDE Frameworks 5.108 bug with copy/move symbolic link

EDIT: This bug has been removed from Manjaro by Stable Update 2023-07-27.

KDE Frameworks 5.108 introduced this nasty bug:
copy/move symbolic link moves link destination instead
It’s fixed in 5.109, which is expected to be available in late August.

EDIT: apparently it’s been around since Frameworks 5.102, but I use symlinks a lot and didn’t notice it until after the 2023-07-17 stable update.

It affects running scripts as well: in Dolphin I dropped a symlink on a Python script’s desktop file, and the script saw only the real path and did things in the actual file’s directory instead of the symlink’s directory. On the day before I installed the 2023-07-17 stable update, it was operating on the symlink’s directory, as intended.

Later I accidentally deleted a few files by creating symlinks in another folder, then moving the symlinks to yet another folder. They did not move; actually the target files moved into the folder onto which I dropped the symlinks, but i didn’t know that, as I didn’t open the folder. When I tried to move the symlinks again it asked if I wanted to overwrite them, I said yes, and the real files got replaced by the symlinks. Result: the real files no longer exist, there are only dead symlinks.

This sounds nasty! The risk of data loss is surely worrying.

  • Is it sure that KDE devels won’t make a fix available before a month from now?
  • Is the change meant for landing in 5.109 ready availble in the frameworks repo? Is it simple enough to be backported (e.g. by making a temporary aur package based on 108 + fix) for those wishing to experiment that path?

The fix is in Frameworks 5.109 already.

Frameworks 5.109 as a whole is still in testing.
I saw a page with the sched but have lost the URL.
It looked like final release is on Aug 12th.
After that it’s up to Arch devs, before Manjaro can bring it in.

philm suggested to ask the Arch devs to do …
(something, didn’t understand what he meant),
but that’s beyond my comfort zone, so i just remember to be careful.
(Btw, i had backups of the files i deleted.)

I already fixed it with kcoreaddons 5.108.0-1.0


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.