Desktop icons stop responding to double clicks

So since this or the prev update I’m having a problem with the KDE desktop icons: they just randomly stop responding to double clicks. Documents/folders don’t open, programs don’t launch etc. Keyboard cursor navigation and pressing enter works normally. Sometimes this is fixed by changing the wallpaper or rebooting, but not always.

Another issue is with qbittorrent, for some reason single clicks now act as double clicks in it. E.g.just clicking a torrent with multiple files in it opens its folder.

Desktop anomalies that dont affect others is likely a configuration issue.
With KDE … maybe a bad plugin/widget/etc.
In any case - you should likely create your own thread.

Had this problem some updates ago.
What worked was adding


into the [KDE] section of ~/.config/kdeglobals
Don’t know the default value but that one was fine for me.

1 Like

A post was split to a new topic: KDE Frameworks 5.108 bug with copy/move symbolic link

Will try this, thanks.

I have the same since some months, tried a lot to figure out what’s wrong. Also with a clean install, or with a new mouse : no change.
What I found out: after booting to the desktop, yes no icon double-clicks on the desktop will work, but (!), when klicking the networksymbol in the taskbar, or the audio-loudness, then their respective panels pop up. And this action only will get your double-click on the desktop icons again working.
So: I think something does not initialize well at the very start of KDE Plasma, but does when you left-klick once, one of those 2 icons in the KDE taskbar. Can not tell you what’s wrong. But this work 100% (for me)

1 Like

So this occurs on the liveISO and directly after install?

For everyone experiencing something like this I might suggest trying a new user … test that.

I tried the suggestion by MMMMMaett from above and so far (few days) it seems good. Will report if this happens again.

The qbittorrent bug is unfortunately still there. I don’t see anything like that in other programs so it could be something local to it.

After [Stable Update] 2023-07-27, the qbittorrent bug is also fixed!