KDE Doesn't boot

Hi all,

I’ve gone to several forum posts with no solution found. Manjaro does not boot into GUI, stuck at screen which says:

I can open Manjaro into TTY2 and troubleshoot from there but no luck so far. I’ve updated grub, pacman mirrors, system updates, xrandr and xorg come back with no displays found.

Any help is appreciated,

Hi @rhinorun,

That message itself, just means your NVMe drive is A-OK, I also get it, so there’s nothing to worry about.

Nevertheless, you saying it doesn’t move past the message, means something’s amiss. We just need to find out what, which means inspecting logs. The best way would be from a chroot environment.

  • So now I’ve got to ask, so you know how to enter the chroot environment?
  • Do you have a relatively new USB thumb drive handy?
1 Like

Was this after an update? A change in a configuration? Switching to a different kernel / video driver?

Are you able to manually start the display manager with:
sudo systemctl restart display-manager

Does this reveal anything after a failed attempt:
systemctl status display-manager
journalctl -u display-manager


1 Like

Hi there,

Yea the system won’t proceed past this message, I can access the system in tty but that’s it. I’m also booted off a live USB at the moment and can run in chroot, where exactly should I go from here?


sudo systemctl restart display-manager

returns with nothing and

sudo systemctl status display-manager

returns with some errors. I wish I could copy paste my terminal output but i don’t know how to do that on the forum from tty. Sorry for the image quality.

type: startx and post picture of it

Oh that’s right, i forgot to include this in the first post. When i attempt to run startx the command isn’t recognized.

Are you using a Nvidia card with the proprietary drivers?

Nope, it has an integrated Intel GPU. I use the video-linux drivers. I’ve installed and reinstalled the graphics drivers many times using mhwd to no success.

I’ll post my mhwd lists later.

are you using wayland since the startx doesnt work?
did you tried with different kernels?
rerun also update again:
sudo pacman -Syu

I’ve tried multiple kernels with no solution. I’m running linux515 now. Updating via sudo pacman -Syu returns with no change and as for Wayland or X11 I’m not sure, since xrandr and Xorg come back with outputs.

Tried Xorg but was met with the
Fatal server error: (EE) no screens found(EE)

Here’s the contents of the Xorg log file.

it looks like there is some messed up config according to the log, post output from:
find /etc/X11/ -name "*.conf"

1 Like

Sure, here you are:

why do you have there a vesa conf, and also a nvidia conf since you dont have any nvidia?
post output also from:
mhwd -l && mhwd -li
cat /etc/X11/xorg.conf.d/99-calibration.conf
cat /etc/X11/xorg.conf

I honestly have no idea why I have Nvidia drivers, must have happened when i was installing different drivers.

Here are the outputs:

you have installed all the available drivers, which you should not have… remove them all:
sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-modesetting
remove the configs:
sudo rm /etc/X11/mhwd.d/vesa.conf
sudo rm /etc/X11/mhwd.d/nvidia.conf
remove also the xorg.cong (or rename it):
sudo rm /etc/X11/xorg.conf

1 Like

Allrighty thanks, i removed them all except for video-linux but still no change. Won’t open the GUI.

Try re-installing video-modesetting again, and then reboot.

This assumes you removed the errant .conf file(s).

1 Like

Allrighty, tried reinstalling video-modesetting, still nothing.


Also i made sure those conf files were erased, but when I went to remove them they were already nonexistent. However there was a xorg.conf.d file with some configs for the touchpad