GTK themes doesn't work correctly after Plasma 5.20 upgrade (Manjaro testing)

It can be noticed in case of pamac.

If the new GTK theme is applied, all looks fine:

But after the session is relogged or system restarted, the window buttons are missing:

They are there and I can close the window, clicking the empty space blindly, but the issue persists with every GTK theme I tried so far. I first suspected that my themes were outdated, so I downloaded some recent ones but the issue stays.

1 Like

Hey,

care to share
cat ~/.config/gtk-3.0/settings.ini

Sure:

 michaldybczak  alienware-PC  ~  cat ~/.config/gtk-3.0/settings.ini
[Settings]
gtk-application-prefer-dark-theme=false
gtk-button-images=true
gtk-cursor-theme-name=breeze_cursors
gtk-cursor-theme-size=24
gtk-decoration-layout=close,minimize,maximize:
gtk-enable-animations=true
gtk-fallback-icon-theme=breeze-dark
gtk-font-name=Noto Sans,  10
gtk-icon-theme-name=Hey-black
gtk-menu-images=true
gtk-modules=colorreload-gtk-module:appmenu-gtk-module:window-decorations-gtk-module
gtk-primary-button-warps-slider=false
gtk-shell-shows-menubar=1
gtk-theme-name=WhiteSur-light
gtk-toolbar-style=3

Hmm… Looks like I have many lines from legacy settings that are no longer relevant. It’s possible that they conflict with new ones. I could try to delete some, but I will be guessing which ones doesn’t belong here anymore. I could be wrong and break it even more…

I’ll check it once I get more time, so probably in few days :frowning:.

Unless you have some ready suggestions @bogdancovaciu ?

I thin the one you can remove is the

Here is the one i use now:

[Settings]
gtk-application-prefer-dark-theme=true
gtk-button-images=true
gtk-cursor-theme-name=Adwaita
gtk-cursor-theme-size=24
gtk-decoration-layout=close,maximize,minimize:minimize,maximize,close
gtk-enable-animations=true
gtk-font-name=Cantarell,  10
gtk-icon-theme-name=Papirus-Dark
gtk-menu-images=true
gtk-modules=colorreload-gtk-module:window-decorations-gtk-module
gtk-primary-button-warps-slider=true
gtk-theme-name=Breeze
gtk-toolbar-style=3
1 Like

me i install aur gtk3-nocsd-git and i have title bar with pamac for a look more kde

2 Likes

I tried to experiment with settings.ini and other files in the folder like assets and gtk.css, colors.css, window_decorations.css but no luck, issue persisted. So I renamed ~/.config/gtk-3.0/ to ~/.config/gtk-3.0.bak, changed gtk settings from UI to Breath and back to the WhiteSur-light. It created again a clean ~/.config/gtk-3.0/ folder.

I restarted the system and the issue is gone. My guess is: the fault was in gtk.css which pointed to window_decorations.css and that pointed to assets folder, which had invisible buttons svg files. Probably some fallback after old settings. The new gtk.css also is pointing to that file now, but the file is gone, as well with the assets folder, so decorations are taken from the chosen gtk theme.

So to sum up. Before I had in ~/.config/gtk-3.0/

assets/ - folder with faulty svg files
bookmarks
colors.css
gtk.css - pointing to colors.css and window_decorations.css
settings.ini
window_decorations.css - pointing to assets folder

After the ~/.config/gtk-3.0/ was restored to default state, all I see inside are:

colors.css
gtk.css - again, still pointing to colors.css and window_decorations.css
settings.ini

Also, comparing the old settings. ini and the the new one, I noticed only change in one line:

OLD:
gtk-modules=colorreload-gtk-module:appmenu-gtk-module:window-decorations-gtk-module

NEW:
gtk-modules=appmenu-gtk-module:colorreload-gtk-module

So the culprit here was probably this window-decorations-gtk-module which needed additional css file which needed additional folder, which had broken files.
I hope this makes sense :wink: .

I guess bookmars file has to be copied over to new gtk-3.0 settings, since it has bookmarks for gtk file explorer, which I want to keep.

Thanks @bogdancovaciu for pointing me to the right configs.

1 Like

I had an issue only with close button on my MateriaBreath GTK themes, solved it with moving window_decorations.css to window_decorations.css.bak, so those Breeze buttons don’t interfere with
theme’s built-in ones.

EDIT: But this file was created again. So, to fix this issue properly, we need to open a bugreport on bugs.kde.org.

1 Like