Failed to start light display manager but works from tty


Since the latest update I get the error “failed to start light display manager” and the booting stops.
I can still start XFCE by going to tty2 and run startx. I can also run lightdm under sudo from one of the tty’s and it works.
I don’t have any fancy graphics drivers, I use the internal intel GPU on my I5.

I have no clue what is going on. See here the lightdm.log directly after boot:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=683
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.01s] DEBUG: Launching process 689: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.01s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.01s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.03s] DEBUG: Process 689 exited with return value 1
[+0.03s] DEBUG: XServer 0: X server stopped
[+0.03s] DEBUG: Releasing VT 7
[+0.03s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.03s] DEBUG: Seat seat0: Display server stopped
[+0.03s] DEBUG: Seat seat0: Stopping session
[+0.03s] DEBUG: Seat seat0: Session stopped
[+0.03s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.03s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.03s] DEBUG: Seat seat0: Stopping
[+0.03s] DEBUG: Seat seat0: Stopped
[+0.03s] DEBUG: Required seat has stopped
[+0.03s] DEBUG: Stopping display manager
[+0.03s] DEBUG: Display manager stopped
[+0.03s] DEBUG: Stopping daemon
[+0.03s] DEBUG: Exiting with return value 1

I also found this in the x-0.log

Fatal server error:
(EE) no screens found(EE) 

The error log indicates that it’s because of plymouth. If you removed it, you should check if it’s still enabled somewhere because it tries to run it.

I’ve not touched plymouth. Don’t know if it was even installed. Does Manjaro use it?

edit: but you got the answer indeed. I installed plymouth from the AUR and now the display manager works again. Still don’t know why I suddenly need plymouth, but at least it’s working again.

1 Like

Good to see you have it working, but you might want to check and see if lightdm-plymouth.service is enabled instead of lightdm.service:

systemctl status lightdm-plymouth.service

If it is enabled, try enabling lightdm.service instead:

sudo systemctl enable --force lightdm.service

If this doesn’t work, you can undo this by running:

sudo systemctl enable --force lightdm-plymouth.service

Also, if you need/want plymouth, you can just install the plymouth package from the official repos.

No, lightdm-plymouth.service does not seem to be enabled, it’s not activated. lightdm.service on the contrary is.

B.t.w. after reading what plymouth does, it does not seem to be really used during boot, I don’t have a splash screen of any kind.

I installed it through the AUR because that’s what the arch wiki tells me ( I’ve never dealt with plymouth, first had to look up what it did :slight_smile:

It’s a mistery for me where this plymouth thing comes from.

  • I don’t have a plymouth hook in mkinitcpio.conf
  • I don’t use splash in the grub cmdline
  • I don’t seem to find any reference to plymouth in the lightdm.conf.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.