Dash to dock fails and default desktop view changed after the update

I’ve just updated the system and after the restart I ran into something that looks like bug.

The first thing is, I completely lost my dash to dock configs. They don’t work and also the extension’s GUI can not be accessed.

after-update-2

Output:

Error: GSettings key preview-size-scale not found in schema org.gnome.shell.extensions.dash-to-dock

Stack trace:
  _checkKey@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:563:23
  createCheckedMethod/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:515:30
  _bindSettings@/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/prefs.js:545:81
  _init@/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/prefs.js:219:14
  buildPrefsWidget@/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/prefs.js:1013:20
  _init@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:209:40
  OpenExtensionPrefsAsync/<@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:122:28
  asyncCallback@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:115:22
  run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:177:20
  main@resource:///org/gnome/Shell/Extensions/js/main.js:19:13
  run@resource:///org/gnome/gjs/modules/script/package.js:206:19
  start@resource:///org/gnome/gjs/modules/script/package.js:190:8
  @/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17

The second thing is, after the start up I’m seeing the workspaces menu first. And also workspaces are on a gray background.

and I feel there are lots of problems coming.


  • Notification bar completely turned to black itself. It was grey before the update.
  • Some pop-op menus can be stucked at screen.

Is there anyway to back gnome 3.38?


  • Switch amongst workspaces while using CTRL + ALT + Arrow (Left / Right) does not show which workspace what active panel it has. All workspace thumbnails are empty.
1 Like

I’ve got the same issues after the update

I Am also having the same problem. Even my desktop couldn’t boot.

For the dull gray background, I suggest you try the “Blur my Shell” extension.

As to the settings for dash-to-dock, I get the same “Something’s Gone Wrong” message. But it appears to be using the old settings I had made before upgrading, and it’s working as expected.

I’m having the same issue after update.

I can’t reproduce this issue with 69+14+g302c693-3. It did happen to me while testing as the gschemas.compiled was not being compiled before. Keep in mind there is still not a stable release and we’re using the WIP PR until then.

Indeed. That’s why I added it to the AUR. :wink: Maybe it’ll find it’s way into the repos…

1 Like

Same here

For me, removing “schemas” under /usr/share/extensions/dash-to-dock@micgx.gmail.com resolved the issue.

Same issue here. I was completly uptodate and installes the updates this morning.
After the reboot my dock icons are larger than before and when I try and open the settings I get the above error dialog.

Same issue as others here, but this dir didm’t exist for me

As Dash-to-dock extension is not yet ready for Gnome 40, why you don’t switch to the default Gnome 40 dock ? I know it is not the same thing that ‘Dash-to-dock’ but it works.

How do you enable the default dock?

Disable the ‘dash-to-dock’ extension, and press on Super key or Activities buttons. You can use three fingers (touchpad) or keyboard keys (arrows). Another solution is to choose ‘Gnome’ choice in the Gnome layout switcher.

Thanks for suggestion, as a solution that’s a great alternative. I like it! But dash to dock is not working as old for me and that tend me to try some unstable solutions, as a result sometimes I even see some kind of vertical rectangle. Lol.

That rectangle also can change its color according to background :smile:

At the end, I removed whole gnome40 implementations of dash-to-dock ext and installed with pamac from the database again. It’s looking fine than the unknown rectangle but still can not use my configs. Whole dock is looking like inside of an high opacity rectangle and I think that’s the default with some broken options.

By the way, there are some conflicts in Layouts app and Extensions.

I had run into an error with no output while trying GNOME. Dash to dock completely was not able to run and other layouts (except Manjaro and Manjaro Legacy).

I noticed that there’s a Night Theme Switcher Extension. It’s cool but after using that, losing the theme options. Like mine, I’m using Matcha Light Azul and wanted to try the night theme but after disabling it, didn’t return to the theme. It stayed at same, dark / night theme.

Mine was in /usr/share/gnome-shell/extensions/dash-to-dock@micgx.gmail.com. After I removed the schemas folder I do not get this error message in the extensions app anymore.

2 Likes

I deleted that entire directory and still the extensions dialog doesn’t work.

I’ve just tried this solution, now I’m able to access the options but dash-to-dock is still faulty. Opacity is not working as expected, at first it works with a vertical rectangle that I mentioned in my last comment.


And a few actions later it denies the opacity.

But sizing properties are working, they’re able to change.

eventually give this one try:
rename /home/(user)/.config/user to for example user.bak
and reboot quickly.
The effekt is that Manjaro is set to default Gnome…
Returning is possible, but keep a backup of the file “user” anyway.

I can confirm that after doing following, I can open settings window without any issues:

cd /usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/
sudo mv schemas schemas-bak

And then in the settings switching to using built-in themes under Appearance tab made it look good again :wink:

13 Likes

Sorry, forgot to mention that I did a reboot after removing the folder. Not sure if that helps…